Contribute
Register

Radeon RX 4XX/5XX standalone system, AMDRadeonX4250.kext (GVA support H264) does not support HEVC HW

pastrychef

Moderator
Joined
May 29, 2013
Messages
11,183
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Are we talking about RX580 in general, or just the OEM? Mine's a Sapphire Pulse RX580.
I tested my PowerColor RX 560. It wasn't an RX 580.
 
Joined
Mar 5, 2019
Messages
38
Motherboard
Asrock z370
CPU
i7-8700
Graphics
Radeon VII
Mac
iMac
Mobile Phone
iOS
Hi! Help to understand! In FCPX 4K, videos are processed by the processor when viewed. No optimization. The processor heats up and the rollers brake. I have a Radeon vii card that works normal only in davinci. How do I run radeon vii it in fcpx to view and edit by timeline? Config: Asrock z370 i7-8700 radeon vii
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
11,183
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Hi! Help to understand! In FCPX 4K, videos are processed by the processor when viewed. No optimization. The processor heats up and the rollers brake. I have a Radeon vii card that works normal only in davinci. How do I run radeon vii it in fcpx to view and edit by timeline? Config: Asrock z370 i7-8700 radeon vii
Did you try disabling IGPU and using iMacPro1,1 system definition?
 
Joined
Apr 12, 2012
Messages
7
Motherboard
ASUS Maximus VIII Hero
CPU
i5-6600
Graphics
Vega 64
Mac
MacBook Air, Mac Pro
Please someone need to write a guide on this, at least for Mojave.

I've traded in my setup for a i5-6600 Vega 64 trying to save some headaches, everything runs like a charm but then I notice that it does hit 300% CPU when playing an HEVC file with Quicktime or Resolve.

I've tried iMacPro1,1 and my board doesn't seems to let me "disable" iGPU but I've set my primary display to PEG.
Tried force hardwareVideoDecoder, AppleGVA forceSWDecoder no and forceATI yes
 

Attachments

Joined
Sep 19, 2010
Messages
576
Motherboard
Asus Z87 Maximus Gene VI
CPU
i7-4790K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
Please someone need to write a guide on this, at least for Mojave.

I've traded in my setup for a i5-6600 Vega 64 trying to save some headaches, everything runs like a charm but then I notice that it does hit 300% CPU when playing an HEVC file with Quicktime or Resolve.

I've tried iMacPro1,1 and my board doesn't seems to let me "disable" iGPU but I've set my primary display to PEG.
Tried force hardwareVideoDecoder, AppleGVA forceSWDecoder no and forceATI yes
Give this EFI folder a try. Back up your current one so you can restore it if this one does not work. You should be able to disable IGPU in BIOS. Once you have it disabled, WhateverGreen will do the rest in terms of renaming your discreet GPU to the correct name in Mac (eg, GFX0).
 

Attachments

Joined
Apr 12, 2012
Messages
7
Motherboard
ASUS Maximus VIII Hero
CPU
i5-6600
Graphics
Vega 64
Mac
MacBook Air, Mac Pro
Give this EFI folder a try. Back up your current one so you can restore it if this one does not work. You should be able to disable IGPU in BIOS. Once you have it disabled, WhateverGreen will do the rest in terms of renaming your discreet GPU to the correct name in Mac (eg, GFX0).
Works perfectly!
 
Joined
Jul 5, 2016
Messages
23
Motherboard
GA-Z170n-Wifi
CPU
i7-7700
Graphics
RX 560
Mac
iMac, MacBook, MacBook Pro
Mobile Phone
iOS
Does anyone have issues with wake from sleep? I’m using the iMac Pro definition and my RX560 has acceleration but wake from sleep goes to black screen. Didn’t have this issue before changing disabling iGPU and changing system def.
 
Top