Contribute
Register

Please Help with 10.15.2 Handoff, Apple Watch and Safari Bookmarks!

Joined
Dec 19, 2013
Messages
9
Motherboard
Gigabyte GA-Z87X-OC-F4-Clover
CPU
i5-4670K
Graphics
GT 640
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
Hello all,

My system seems to be working fine except for Handoff, Apple Watch and the syncing of Safari Bookmarks. The network, WiFi, Bluetooth, Apple Store, iMessage and Facetime are working fine.

The General tab does not include the "Allow Handoff between this Mac …" option.

The Security & Privacy tab does not include the "Use your Apple Watch to unlock…" option.

Strangely, at one point Safari was syncing in one direction, FROM the Hackintosh! (my other systems were able to see updated bookmarks). On the other hand, Tabs works in both directions. So, I assume I have kext problems…

My WiFi hardware: TP-LINK TL-WDN4800
My Bluetooth hardware: IOGEAR Bluetooth 4.0 USB Micro Adapter (GBU521)

Additional steps taken:
- I have updated Clover and kexts
- I have followed the instructions for the iMessage fix: https://www.tonymacx86.com/threads/an-idiots-guide-to-imessage.196827/
- I have followed the instructions for the Handoff fix: https://www.tonymacx86.com/threads/solved-handoff-continuity.248447/
- As I have the IOGEAR Bluetooth 4.0 USB Micro Adapter, I Installed AirPortAtheros40.kext and IO80211Family.kext into EFI/../other
- I have followed the troubleshooting steps from https://www.tonymacx86.com/threads/...alina-on-any-supported-intel-based-pc.285366/
- I have removed this computer from my account and added it back in.
- I have insured the services are enabled in the iCloud settings.

As directed here (https://www.tonymacx86.com/threads/macos-catalina-10-15-problems-and-workarounds.288383/) I have uploaded the requested files.

Please advise.
Thank you in advance.
 

Attachments

Joined
Dec 19, 2013
Messages
9
Motherboard
Gigabyte GA-Z87X-OC-F4-Clover
CPU
i5-4670K
Graphics
GT 640
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
Please help.
 
Joined
Aug 9, 2018
Messages
3
Motherboard
Gigabyte Z97-HD3P
CPU
i7 4790K
Graphics
GTX 760
Mac
iMac, MacBook
Mobile Phone
iOS
I have the same problem. I've tried a lot of things, but Safari synch bookmarks just from the Hack but no both directions.
We must to wait before a clear solution. This forum has great people working on.
 
Joined
Dec 19, 2013
Messages
9
Motherboard
Gigabyte GA-Z87X-OC-F4-Clover
CPU
i5-4670K
Graphics
GT 640
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
At this point I can only assume it has to do with the IOGEAR Bluetooth 4.0 USB Micro Adapter (GBU521) with chipset 20702A3. This is what I see under Bluetooth in the System Report:
Apple Bluetooth Software Version: 7.0.2f4
Hardware, Features, and Settings:
Name:
Address:
Bluetooth Low Energy Supported: Yes
Handoff Supported: No
Instant Hot Spot Supported: No
Manufacturer: Broadcom
Transport: USB
Chipset: 20702A3
Firmware Version: v14 c4096
Bluetooth Power: On
Discoverable: Off
Connectable: Yes
Auto Seek Pointing: On
 
Joined
Dec 19, 2013
Messages
9
Motherboard
Gigabyte GA-Z87X-OC-F4-Clover
CPU
i5-4670K
Graphics
GT 640
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
If needed, here is the latest problem report dump:
 

Attachments

Joined
Mar 9, 2012
Messages
1,886
Motherboard
GA-Z87X-OC Force
CPU
i7-4770K
Graphics
HD 5770
Mac
iMac, Mac Pro
Mobile Phone
iOS
@ macduck13 - Judging from the Bluetooth read out it looks like it's not compatible with Mac. You should get similar results like the ones in this pic for 'Handoff' to work with all your Apple devices. have a look in the Buyers Guide' for a compatible Wireless/Bluetooth Combo card. Good luck.
 

Attachments

Joined
Dec 19, 2013
Messages
9
Motherboard
Gigabyte GA-Z87X-OC-F4-Clover
CPU
i5-4670K
Graphics
GT 640
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
@esafeddie,
Thank you for your reply. I have the IOGEAR Bluetooth 4.0 USB Micro Adapter and the TP-LINK TL-WDN4800 because they were listed as being compatible.
Thanks, again.
 
Joined
Mar 9, 2012
Messages
1,886
Motherboard
GA-Z87X-OC Force
CPU
i7-4770K
Graphics
HD 5770
Mac
iMac, Mac Pro
Mobile Phone
iOS
Are you running the latest clover version? I suspect you're not because of how your Clover Folder is constructed if your system is booting as UEFI, drivers32uefi Folder is no longer included. The Folder tree should be something like this example, you also have two very important kexts missing, lilu.kext and WhateverGreen.kext. Do a bit more research and try to find and follow a few examples of systems close to your build for guidance.
 

Attachments

Joined
Dec 19, 2013
Messages
9
Motherboard
Gigabyte GA-Z87X-OC-F4-Clover
CPU
i5-4670K
Graphics
GT 640
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
@@esafeddie,
Yes, I am running the latest version, Hackintool reports I am running Clover 5103. The drivers32uefi folder is empty.
As seen below, I have those kexts installed as well.
Screen Shot 2020-01-20 at 15.59.34.png


A couple kexts e.g., GenericUSBXHCI.kext, are missing as I have been removing USB-related kexts to see if they are in conflict.

Thanks, again.
 
Last edited:
Joined
Mar 9, 2012
Messages
1,886
Motherboard
GA-Z87X-OC Force
CPU
i7-4770K
Graphics
HD 5770
Mac
iMac, Mac Pro
Mobile Phone
iOS
Try removing unwanted empty Clover folders and items as they serve no purpose apart from slowing down boot up times. If you're running a usb internet connection instead of an ethernet cable which has to be registered as Built in to enable iMsg and F/Time, there is a patch to hack to override this if your connection is via usb but I am unable to recall the pacific method, I think it is a method devised by RehabMan, like a I said research is the key.
 
Top