Contribute
Register

macOS Sierra PB: Need testers for new AMD Radeon drivers!

Status
Not open for further replies.
Joined
May 15, 2016
Messages
4,873
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
A little salt in the wound ...

Out of curiosity, I installed the current Ubuntu Studio onto a flash drive and after letting it settle in, I changed the igpu setting to pcie and booted. You may have guessed where this is going ... it booted just fine without the Intel igpu. I have not messed with it a lot, but it supports multiple monitors, though sound seems to be limited to only the hdmi port. i used the lspci command and it reports that it is using the standard amdgpu driver -- not the amdgpu-pro that AMD lists on their web-site. It boots fast too.

So it is possible to use these cards on these machines without the igpu, but getting macOS and Clover to do that remains to be done. But still a lot of progress has been done.
Cool! I hope it gets figured out before Vega 10 launches.

I can't wait for the Vega 10 cards to come out.
Vega 10 .png
This is the Beta 4 12.2 9500controllerkext in iHex. It has the same pattern and volume or size as the polaris10 and Baffin support. I gotta start saving for one of these on launch day, hopefully its not over $800.

Vega-Mac Pro?
Polaris 10-iMac?
Polaris 11 Baffin-MacBook Pro=yes
 
Joined
Feb 9, 2014
Messages
1
Mac
Classic Mac
Mobile Phone
If I say that I can boot to Sierra with my RX460 set as primary, although it doesn't have acceleration. Is that progress?
 
Joined
Dec 28, 2014
Messages
4
Motherboard
Asus Maximus VIII Ranger
CPU
i5 6600k
Graphics
Asus strix rx 470 4GB
Mobile Phone
Android
The R9 XXX name is only a cosmetic issue, it gets changed by the latest clover to RX 480 but doesn't effect performance.

Something you could try, Intel fake ID 0x04128086, and ig platform 0d220003. If you do this you should be able to inject ATI to get RX 480 name corrected. If you dont inject anything Intel or ATI and use these numbers the R9 xxx name will come up but your performance may improve.
When you get to clover boot screen, before you hit enter disconnect cable to CPU graphics or Igpu. Hit enter and if you get to log in screen the RX should be fully supported and run the highest benchmark scores. It may work for fcpx as well as long as you have the igpu with metal support by adding fake ID and ig numbers.

I use these#s on my g3258 Haswell pentium rig for igpu and it works well, not sure about the 4790k, but it's a Haswell.
i have changed it with the app called iHex and now is showing the correct name of my card...
 
Joined
Dec 28, 2014
Messages
4
Motherboard
Asus Maximus VIII Ranger
CPU
i5 6600k
Graphics
Asus strix rx 470 4GB
Mobile Phone
Android
The R9 XXX name is only a cosmetic issue, it gets changed by the latest clover to RX 480 but doesn't effect performance.

Something you could try, Intel fake ID 0x04128086, and ig platform 0d220003. If you do this you should be able to inject ATI to get RX 480 name corrected. If you dont inject anything Intel or ATI and use these numbers the R9 xxx name will come up but your performance may improve.
When you get to clover boot screen, before you hit enter disconnect cable to CPU graphics or Igpu. Hit enter and if you get to log in screen the RX should be fully supported and run the highest benchmark scores. It may work for fcpx as well as long as you have the igpu with metal support by adding fake ID and ig numbers.

I use these#s on my g3258 Haswell pentium rig for igpu and it works well, not sure about the 4790k, but it's a Haswell.
I've changed the name to my original card's name with the app iHex!
 
Joined
Feb 26, 2016
Messages
12
Mac
Classic Mac
Mobile Phone
Have someone managed to get 4K@60Hz using the RX460 via HDMI? RX460 is HDMI 2.0 capable, my monitor (LG 27UD68) too. I'm getting 4K@60 Hz on Displayport, but only 4K@30Hz on HDMI. I'm using original LG high speed HDMI cable.

Thanks!
 
Joined
Jul 8, 2016
Messages
61
Motherboard
Asus ROG Strix Z370-G Gaming WIFI
CPU
i7 8700K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Any news with last Sierra beta for RX 480 ?
 
Joined
Jul 8, 2016
Messages
61
Motherboard
Asus ROG Strix Z370-G Gaming WIFI
CPU
i7 8700K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
RX 480 8GB or Radeon 7970 3GB, which one is better for FCP ? which brand of RX 480 is more compatible with a hackintosh ?
 
Joined
May 15, 2016
Messages
4,873
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
Have someone managed to get 4K@60Hz using the RX460 via HDMI? RX460 is HDMI 2.0 capable, my monitor (LG 27UD68) too. I'm getting 4K@60 Hz on Displayport, but only 4K@30Hz on HDMI. I'm using original LG high speed HDMI cable.
I think Sierra only uses DP for the 60hz. @4K.

Thanks!
RX 480 8GB or Radeon 7970 3GB, which one is better for FCP ? which brand of RX 480 is more compatible with a hackintosh ?
As of late, the Gigabyte RX 480 has not been reported working. XFX, MSI, Sapphire, Powercooler, Asus and HIS have all provided Uningine benchmarks which can only be obtained with metal support. It depends on the size of your case too, the reference models are more slim and shorter than the multi fan models, and have a 6 pin versus multiple 6 pin or 8 pin designs if your power supply is limited.

The MSI Gaming is probably the heaviest duty board, its very solid. Saphire is like the EVGA (for Nvidia) of AMD cards, its lighter than most cards but performs well. My XFX reference has been able to keep pace with the multi fan, factory overclocked models (Uningine Valley Extreme HD= 1924) its clocked at 1266-1288mhz (XFX has a limited lifetime warranty). Some of the other Aftermarket cards are running at 1344mhz. Powercooler RED DEVIL is large with 3 fans and is up in the top ranks for benchmarks.

The 3 most reported cards are the Sapphire, XFX, and Powercooler. MSI, and ASUS just recently came onboard with support as reported by others. I had a MSI 470 working very well on the early stages but couldn't get the 480 to load, but that has changed just recently. MSI 470 was very smooth, glitch free, and quiet.

If you wait a few months Vega 10 may be a better option for max rendering. We don't even have the card yet and the Driver support is already in Sierra. I can't wait!
 
Last edited:
Joined
Dec 14, 2013
Messages
88
Motherboard
Asus ROG Strix Z390-E
CPU
i7-8700K
Graphics
RX 480
Mac
MacBook Pro
Mobile Phone
iOS
The R9 XXX name is only a cosmetic issue, it gets changed by the latest clover to RX 480 but doesn't effect performance.

Something you could try, Intel fake ID 0x04128086, and ig platform 0d220003. If you do this you should be able to inject ATI to get RX 480 name corrected. If you dont inject anything Intel or ATI and use these numbers the R9 xxx name will come up but your performance may improve.
When you get to clover boot screen, before you hit enter disconnect cable to CPU graphics or Igpu. Hit enter and if you get to log in screen the RX should be fully supported and run the highest benchmark scores. It may work for fcpx as well as long as you have the igpu with metal support by adding fake ID and ig numbers.

I use these#s on my g3258 Haswell pentium rig for igpu and it works well, not sure about the 4790k, but it's a Haswell.
Thanks, @Gigamaxx for the reply. I added Intel fake ID 0x04128086, and ig platform 0d220003 as you suggested and it didn't change anything. I removed Inject ATI and as you said the display in About This Mac is R9xxx (I'm okay with that as long as things work). When I Inject ATI it does display properly as RX 480, but I know that's just cosmetic.

When I run both monitors off the RX 480, the one on DisplayPort works perfect, and the one on HDMI is pixelated and rough. Both monitors have both DP and HDMI inputs, so when I switch the cables around, it makes no difference. HDMI does not work correctly, but DP does. I will have to go out and get a second DP cable I guess, which is fine. See screen shot below to see what it looks like on HDMI. EDIT: I don't have 4k monitors - both are 1080p high quality IPS displays with accurate color (Dell U2413 and HP LP2475w).

My bigger issue is that Final Cut Pro crashes as soon as I try to open a library. This has been an issue since upgrading to FCPX 10.3. FCPX 10.2.2 and 10.2.3 were working fine on my old R9 280x, even in Sierra. When I upgraded to FCPX 10.3 this problem started. I removed the R9 280x as a test, and FCPX works fine (albeit slowly) with IGPU and no graphics card installed. When I reinstalled my 280x, the displays never came back on. I tried everything I could think of and I think that card just failed, so I replaced it, hoping that would also fix my FCPX 10.3 problem. Now my new RX 480 shows the same behavior in FCPX 10.3. I really need to resolve that - I know others are running FCPX 10.3 with a RX 480, so I'm trying to hunt down the issue.

Any ideas of where to look? Can I provide my crash report, or something from Console, that those who are smarter than me can look at? I have reached the limits of what I can do on my own and I need help. Thanks!


Screen Shot 2016-12-01 at 11.42.07 AM.png
 

Attachments

Last edited:
Status
Not open for further replies.
Top