Contribute
Register

macOS Mojave Public Beta is Now Available

Status
Not open for further replies.
Joined
Sep 29, 2013
Messages
155
Motherboard
Gigabyte Z390 Aorus Ultra
CPU
i9-9900K
Graphics
UHD 630, RTX 2080 Super
Mobile Phone
iOS
I installed Public Beta 2 in Pentium G3258 using GTX960, Nvidia WebDriver 387.10.10.10.35.106 installed but not working , can someone help me?
I'm trying to install WebDrive 387.10.10.10.40.105 not compatible.
There are no working Nvidia Webdrivers for Mojave, either you wait for Nvidia to release one or use integrated graphics.
 
Joined
Sep 29, 2013
Messages
155
Motherboard
Gigabyte Z390 Aorus Ultra
CPU
i9-9900K
Graphics
UHD 630, RTX 2080 Super
Mobile Phone
iOS
I use Pentium G3258 so graphic integration does not support. Are there any natively graphics for Mojave?
I guess any of these are supported: AMD Graphics Cards

Not sure of Nvidia, many older cards (not 9xx or 10xx), has been supported natively up until High Sierra but for Mojave they would have to have support for Metal and I'm not sure of which do.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
15,090
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
I guess any of these are supported: AMD Graphics Cards

Not sure of Nvidia, many older cards (not 9xx or 10xx), has been supported natively up until High Sierra but for Mojave they would have to have support for Metal and I'm not sure of which do.
As far as I know, all the cards you linked to will be supported by Mojave.
 
Joined
Jul 28, 2012
Messages
231
Motherboard
Asus RoG Strix Gaming z370e
CPU
i5-8600K
Graphics
RX 580
I have it installed okay and all seems fine apart from lag in Safari.
Other than that, there is no HDA audio - I've played around with a few things and tried using AppleHDA.kext from 10.13.6 as well as native Mojave with exiting latest Lilo.kext and AppleALC.kext but reckon that therein lies the problem (not working with Audio ID 1),,, These kexts will need to be updated to support Mojave Native AppleHDA.kext before we have Realtek ALC sound. Other than this all seems to be in ordnung!
 
Last edited:
Joined
Jul 28, 2012
Messages
231
Motherboard
Asus RoG Strix Gaming z370e
CPU
i5-8600K
Graphics
RX 580
As far as I know, all the cards you linked to will be supported by Mojave.
RX 550 No problem apart from (seemingly) Display port recognition. HDMI and DVI working fine,,,,

>> Sorted by removing whatevergreen.kext
 
Last edited:
Joined
Jul 28, 2012
Messages
231
Motherboard
Asus RoG Strix Gaming z370e
CPU
i5-8600K
Graphics
RX 580
I have it installed okay and all seems fie apart from lag in Safari.
Other than that there is no HDA audio - I've played around with a few things and tried using AppleHDA.kext from 10.13.6 as well as native Mojave with exiting latest Lilo.kext and AppleALC.kext but reckon that therein lies the problem (not working with Audio ID 1),,, These kexts will need to be updated to support Mojave Native AppleHDA.kext before we have Realtek ALC sound. Other than this all seems to be in ordnung!
Sorted Audio problem finally - needed to remove kext patches. Rebooted and voila! All seems fine now. Not sure why inputs not showing though... will investigate this next boot.

Screen.jpg
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
15,090
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
How do you enter this boot arg in Terminal. I've tried several times and failed. I'm doing something wrong. Could you give the proper syntex. Thanks
Screen Shot 2018-07-16 at 8.15.00 AM.png
 
Status
Not open for further replies.
Top