Contribute
Register

macOS 10.13.4 Update

Joined
Nov 7, 2016
Messages
76
Motherboard
ASUS ROG Maximus VIII Hero Z170
CPU
i5-6600K
Graphics
GTX 1060
Mobile Phone
  1. iOS
o_Oo_O


Thanks RehabMan. I read your guide four times and I still got no clue. Only thing I understand is,that I have to connect a USB2 and a USB3 device to each port, check IOREG and make a note. Based on this I have to compile a SSDT.
Sorry, but I think for me it's definitely rocket science...couldn't even imagine how I can do all that coding and developer stuff - and
at the top,it's not my native languageo_O:banghead::crazy:
 
Last edited:
Joined
Apr 15, 2017
Messages
12
Motherboard
ASUS ROG Strix Z370I Gaming
CPU
i7-8700K
Graphics
Radeon VII
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iBook
Mobile Phone
  1. iOS
So before update i must only update the apfs file in "CLOVER/drivers64UEFI/" and replace whith the last apfs file, after that i can update via app-store or combo update, correct???
In my case that's all I had to do. Your setup might be different.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,309
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
o_Oo_O


Thanks RehabMan. I read your guide four times and I still got no clue. Only thing I understand is,that I have to connect a USB2 and a USB3 device to each port, check IOREG and make a note. Based on this I have to compile a SSDT.
Sorry, but I think for me it's definitely rocket science...couldn't even imagine how I can do all that coding and developer stuff - and
at the top,it's not my native languageo_O:banghead::crazy:

The guide is quite clear.
You will need to follow every detail.
 
Joined
Oct 10, 2017
Messages
28
Motherboard
ASUS Prime Z370-P
CPU
i5-8600K
Graphics
RX580 + UHD 630
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
This update is giving my trouble with my ASUS RX 580 8GB. I have black screen on boot up. its seeing and recognizing it, but I have to boot in cpu graphics, physically move the HDMI cable and then it initializes the card.
 
Joined
Sep 24, 2013
Messages
120
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
Vega
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. eMac
  2. iMac
  3. Power Mac
Mobile Phone
  1. iOS
o_Oo_O


Thanks RehabMan. I read your guide four times and I still got no clue. Only thing I understand is,that I have to connect a USB2 and a USB3 device to each port, check IOREG and make a note. Based on this I have to compile a SSDT.
Sorry, but I think for me it's definitely rocket science...couldn't even imagine how I can do all that coding and developer stuff - and
at the top,it's not my native languageo_O:banghead::crazy:
RehabMan is the best, and that guide is technical, but you might try this one:
https://www.tonymacx86.com/threads/quick-guide-to-generate-a-ssdt-for-cpu-power-management.177456/
Clearly this is different, but I believe it was part of my setting up my USB in Sierra.
 
Last edited:
Joined
Jun 21, 2010
Messages
272
Motherboard
Gigabyte Z490 Aorus Elite AC-F4 OC0.6.4
CPU
i5-10600K
Graphics
RX 580
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Because my HD630 was flickering no matter what I tried in 10.13.4 I ordered a graphics card (Sapphire Pulse RX 560 2GB). Had severeal problems with that device too. Heaviest one: A too old version of WhateverGreen.kext. With the newest one my RX 560 works. After half of the progress bar screen (4K UHD) goes black and some seconds later the OS X desktop pops up. No doubled entries of the card and its real name is shown in "About this Mac".
What still does not work is the HD630 with the RX 560 present (stays black). But this is not a big thing as I use the RX 560 now.
 
Joined
Aug 15, 2011
Messages
75
Motherboard
EVGA-Z370 FTW
CPU
i7-8700K
Graphics
PowerColor 5600 XT
Mac
  1. iMac
Mobile Phone
  1. Android
Finally I'm on 10.13.4

I put a USB patch, and most importante, a new lilu kext.
  • Name*: com.apple.driver.usb.AppleUSBXHCI
  • Find* [HEX]: 837d940f 0f839704 0000
  • Replace* [HEX]: 837d940f 90909090 9090
 
Joined
Sep 12, 2014
Messages
7
Motherboard
Gygabyte GA-Z270X-Ultra Gaming
CPU
Intel i7-7700K
Graphics
AMD Radeon RX 580 8 GB
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
New patch needed:
Code:
<key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>USB 10.13.4+ by PMHeart</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                g32UDw+DlwQAAA==
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Name</key>
                <string>com.apple.driver.usb.AppleUSBXHCI</string>
                <key>Replace</key>
                <data>
                g32UD5CQkJCQkA==
                </data>
            </dict>
        </array>


Thank you so much...BUT (shame on me) I am a total newbie. Can you please tell me how to patch? I'm using clover configurator and I do not know honestly how to make it usb 3 back to work.

sorry for my bad English..

thanks!
 
Top