Contribute
Register

macOS 10.13.4 Update

Joined
Dec 2, 2014
Messages
92
Motherboard
GA-Z97X-UD5H
CPU
i5-4690k
Graphics
GTX 970
Mac
Classic Mac
Mobile Phone
New patch needed:
Code:
<key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>USB 10.13.4+ by PMHeart</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                g32UDw+DlwQAAA==
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Name</key>
                <string>com.apple.driver.usb.AppleUSBXHCI</string>
                <key>Replace</key>
                <data>
                g32UD5CQkJCQkA==
                </data>
            </dict>
        </array>

Thank you!
 
Joined
May 24, 2017
Messages
5
Motherboard
GA-Z170M-D3H
CPU
i7-6700K
Graphics
GTX 1060 6GB
If you want to use Clover Configurator to fix USB3, use these values:

Name: com.apple.driver.usb.AppleUSBXHCI
Find: 837D940F 0F839704 0000
Replace: 837D940F 90909090 9090
Comment: USB3 Fix for 10.13.4+
MatchOS: 10.13.x

Many thank to everyone who shared this snippet in this thread. I just made it easier to use by those who feel themselves more comfort by using Clover Configuration instead of some text editor.

It's works fine and helped me to restore USB3. Of course the best option is to create custom Custom SSDT for USBInjectAll.kext

If I get a bit more time, I will try SSDT approach.
This helped! Thank you. USB3 is fixed on my rig.
 
Joined
Sep 18, 2017
Messages
113
Motherboard
H170N-wifi
CPU
I3-7100
Graphics
HD630
Mobile Phone
iOS
Correct, HD530.

I installed the latest CoreDisplayFixup.kext into L/E with KextBeast and after a reboot I was able to choose the correct resolution!

Thanks a lot! Now everything appears to be running smoothly and back to being pretty. :)
Hi Nyulak,

I have same specs like you but got freeze issue. Could you share your efi and bios configuration ?
 
Joined
Feb 10, 2018
Messages
8
Motherboard
Gigabyte GA-H170N-WIFI
CPU
i5-6500
Graphics
RX 590
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Hi Nyulak,

I have same specs like you but got freeze issue. Could you share your efi and bios configuration ?
I rarely check this thread, so I didn't see your question. I hope you solved it already, but I followed https://www.tonymacx86.com/threads/guide-el-capitan-on-the-skylake-h170n-wifi.178197/, which stated:
BIOS Settings
Press DEL during boot to access BIOS
  • In BIOS Features:
    • Fast Boot: Disabled
    • VT-d: Disabled
    • Windows 8/10 Features: Other OS
    • LAN PXE Boot Option ROM: Disabled
    • Storage Boot Option Contro: UEFI Only
    • Network Stack: Disabled
  • In Peripherals:
    • Initial Display Output: PCIe 1 Slot (if graphics card installed) or IGFX (otherwise)
    • XHCI Hand-off: Enabled
  • In Chipset:
    • VT-d: Disabled
I am not sure what you want from EFI.
 
Joined
Sep 18, 2017
Messages
113
Motherboard
H170N-wifi
CPU
I3-7100
Graphics
HD630
Mobile Phone
iOS
I rarely check this thread, so I didn't see your question. I hope you solved it already, but I followed https://www.tonymacx86.com/threads/guide-el-capitan-on-the-skylake-h170n-wifi.178197/, which stated:
BIOS Settings
Press DEL during boot to access BIOS
  • In BIOS Features:
    • Fast Boot: Disabled
    • VT-d: Disabled
    • Windows 8/10 Features: Other OS
    • LAN PXE Boot Option ROM: Disabled
    • Storage Boot Option Contro: UEFI Only
    • Network Stack: Disabled
  • In Peripherals:
    • Initial Display Output: PCIe 1 Slot (if graphics card installed) or IGFX (otherwise)
    • XHCI Hand-off: Enabled
  • In Chipset:
    • VT-d: Disabled
I am not sure what you want from EFI.
thank you. but i have upgraded to i3 7100 and the issue was gone.
 
Joined
Jan 6, 2018
Messages
28
Motherboard
SuperMicro C7Z370-CG-IW-Clover
CPU
i7-8700K OC @ 5.3 GHz
Graphics
GTX 1070 Ti
Mobile Phone
Android, iOS
I'm not asking for help, my Vanilla install runs great, I'm just curious where to get that mysterious XHCI-300 kext. Signature added, thanks for note.
If you were still wondering:

https://bitbucket.org/RehabMan/os-x-usb-inject-all/src/d8c2681580f4?at=master

As quoted on the page:

"The best way to download the config_patches.plist and other repo files is to download the project ZIP:"

https://github.com/RehabMan/OS-X-USB-Inject-All/archive/706fea51222eb73343d347db10cf48500333a7bd.zip
 
Joined
Jul 9, 2014
Messages
103
Motherboard
SuperMicro X9Dai
CPU
E5 2650 (x2)
Graphics
GT 740
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Thanks for this information. I have the same MOBO and a Coffee Lake CPU and so you just need to get into your EFI/config plist and put this in ?Are there any additional kexts to install? I noticed this problem after .4 as well in High Sierra.. I wonder if Mojave users will have the same drama?


New patch needed:
Code:
<key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>USB 10.13.4+ by PMHeart</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                g32UDw+DlwQAAA==
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Name</key>
                <string>com.apple.driver.usb.AppleUSBXHCI</string>
                <key>Replace</key>
                <data>
                g32UD5CQkJCQkA==
                </data>
            </dict>
        </array>
 
Joined
Apr 11, 2017
Messages
7
Motherboard
Asus prime H370M-plus
CPU
i5-8400
Graphics
GTX 1050 Ti
Mobile Phone
Android
New patch needed:
Code:
<key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>USB 10.13.4+ by PMHeart</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                g32UDw+DlwQAAA==
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Name</key>
                <string>com.apple.driver.usb.AppleUSBXHCI</string>
                <key>Replace</key>
                <data>
                g32UD5CQkJCQkA==
                </data>
            </dict>
        </array>
Please create one for me, I have asus h370m plus i5 8400 coffe lake and graphics card is GTX 1050ti Please i need mac un my pc
 
Joined
Oct 22, 2018
Messages
2
Motherboard
Z370 AORUS ULTRA GAMING WIFI
CPU
I7 8700
Graphics
EVGA GTX 1080Ti
Hi Everybody,

First, thank you so much to share tips and solutions. This place is amazing.

I still have trouble with that USB3 problem. I correctly install the patch (PMHeart) and it does appear in clover but my USB3 is still not working.
I can plug USB1 devices with success but my USB3 HD are not mounting.
It's been 30 min I am reading all the post of that tread and didn't find my answer.

Here is my config.plist if someone has any clue it would be really great. Thanks a lot in advance.
 

Attachments

Top