Contribute
Register

Solved > HELP! SSDT Patching on an Asus X555L

Joined
Jun 2, 2019
Messages
16
Motherboard
Asus X555L
CPU
i3 4xxxU
Graphics
HD 5500/930M
Mac
Mac mini
Mobile Phone
Android
I am trying to disable the dGPU on my Asus X555L (Geforce 930M) and I ran into a issue with SSDT-10 (there is the Method (_OFF, 0, Serialized) // _OFF: Power Off)
When I click "Compile" it gives me these errors even when i didnt make any changes
I attached the files bellow.
In the SSDT-9 there is the "Method (_INI, 0, NotSerialized) // _INI: Initialize"
 

Attachments

Joined
Nov 10, 2015
Messages
86
Motherboard
Clevo 970EF Defiance V-Clover
CPU
i7-8750H/HM370
Graphics
UHD630, RTX 2070, 1920x1080
Mac
MacBook Pro
Mobile Phone
iOS
I am trying to disable the dGPU
PR files missing...


However, to disable dGPU, put the attached file into clover/ACPI/patched folder
 

Attachments

Joined
Jun 2, 2019
Messages
16
Motherboard
Asus X555L
CPU
i3 4xxxU
Graphics
HD 5500/930M
Mac
Mac mini
Mobile Phone
Android
How can i tell that the dGPU is disabled
 
Joined
Nov 10, 2015
Messages
86
Motherboard
Clevo 970EF Defiance V-Clover
CPU
i7-8750H/HM370
Graphics
UHD630, RTX 2070, 1920x1080
Mac
MacBook Pro
Mobile Phone
iOS
Good...
Mark solved
Cheers
 
Joined
Jun 2, 2019
Messages
16
Motherboard
Asus X555L
CPU
i3 4xxxU
Graphics
HD 5500/930M
Mac
Mac mini
Mobile Phone
Android
It works. Thank you so much
 
Joined
Nov 10, 2015
Messages
86
Motherboard
Clevo 970EF Defiance V-Clover
CPU
i7-8750H/HM370
Graphics
UHD630, RTX 2070, 1920x1080
Mac
MacBook Pro
Mobile Phone
iOS
You welcome

Don't forget to add the below line even to _WAK method, otherwise the DGPU could be reactivated after a sleep.
Code:
\_SB.PCI0.RP05.PEGP._OFF ()
Mark the thread solved, it could be helpful for other users...
 
Joined
Jun 2, 2019
Messages
16
Motherboard
Asus X555L
CPU
i3 4xxxU
Graphics
HD 5500/930M
Mac
Mac mini
Mobile Phone
Android
You welcome

Don't forget to add the below line even to _WAK method, otherwise the DGPU could be reactivated after a sleep.
Code:
\_SB.PCI0.RP05.PEGP._OFF ()
Mark the thread solved, it could be helpful for other users...
I have disabled sleep
It caused some issues with my companies app
 
Top