Contribute
Register

HD5500 4K Black screen on internal display

Status
Not open for further replies.
Joined
Jan 14, 2023
Messages
5
Motherboard
Dell XPS 9343 - Clover UEFI
CPU
i7-5500U
Graphics
HD 5500, 3200x1800
Hi everyone!

I have installed Big Sur 11.6.8 on my DELL XPS 13 9343 with i7-5500U and 3200x1800 display. The display stays black and is not recognized, the backlight is active for a few minutes after booting.

My external monitor (2560x1440) works, connected via miniDisplayPort->DisplayPort.
I have tried different framebuffers, different device-ids, patching the EDID to 48 Hz, and patching different BusIds for con0.

Nothing I tried has made the internal display work, except using VESA mode without graphics acceleration.

Does anyone have ideas how to make the display work, or how to debug what is going wrong?
 

Attachments

  • CLOVER.zip
    7.6 MB · Views: 33
  • MacBookPro.ioreg
    19.9 MB · Views: 26
  • xrandr--props.txt
    5.3 KB · Views: 30
Have a look at this config.plist, it was created using Clover for a HP 350 G2 Broadwell laptop.

Serial etc. have been deleted, but the rest is as used to boot macOS.
 

Attachments

  • Broadwell-Clover-config.plist.zip
    2.9 KB · Views: 28
Thanks @Edhawk, unfortunately it didn't help.
I tried copying the PCI device section, then I tried using the whole configuration, but it is the exact same thing, the internal screen stays black. (I used the SMBIOS with newly generated serial no etc.)
I am losing hope for this device...
 
You may need to go through and test each of the Mobile framebuffers for the Broadwell IGPU. Below is a screenshot showing the numerous framebuffers that can be used with a Broadwell IGPU.

Screenshot 2023-01-17 at 17.28.00.png List of framebuffers taken from WEG FAQ

FAQ.IntelHD.en.md - Broadwell

Your i7-550U CPU/IGPU uses the device id 0x1616, so starting with those Mobile framebuffers using 0x1616000n would be logical. You can ignore the Desktop framebuffers.

Just remember you need to reverse swap the Hex-pairs when entering the framebuffer in your config. So, 0x16160002 would become 02001616 as a device property in your config.

Also remember to use the RestNvramEntry.efi driver from the OC boot screen before booting your system with a new framebuffer. So the previous framebuffer entry is removed from your system NVRAM.
 
It just won't work. I have tried literally every framebuffer in that list now, even the desktop ones. None of them worked for the internal display. With some, not even my external monitor worked - unsurprisingly.

I am giving up and will search for another laptop to try my luck with. Still, thank you for your time @Edhawk
 
Some of the issues you are facing with this XPS system may be down to it being a Dell system. They can require specific patches/entries in the config, before the system will work correctly. I think this is the same whether you are booting the system with OpenCore or Clover.

I wouldn’t give up just yet, let me see what I can find regarding this issue and Dell systems.
 
Try this OpenCore EFI based on OC 0.8.7, which I have configured for a Dell Broadwell laptop.

Try this EFI on a spare USB pen drive.
  1. When you get to the OC boot screen, press the spacebar.
  2. This will unhide a number of icons.
  3. Select the ResetNvramEntry.efi icon.
  4. This will clean your system NVRAM and allow you to boot with the OC settings.
  5. Your system should automatically reboot, this is fine and expected.
  6. Simply boot to your USB EFI again and this time boot macOS Big Sur.
See how this EFI works.

If you get stuck post a photo of the verbose text shown on the laptop's display.
 

Attachments

  • EFI.zip
    9.4 MB · Views: 61
Hi, I only saw this just now. Thank you for your work! I will try it out in a few days, when I am back home.
 
I tried booting the EFI from a USB drive, but I got:
OC: Failed to bootstrap SB NVRAM values - Invalid Parameter
Halting on critical error


I have reset the NVRAM in clover by pressing F11 and rebooting, but the same outcome.
 
Status
Not open for further replies.
Back
Top