Contribute
Register

HD4000 Graphics Support on Samsung NP530U4C

Status
Not open for further replies.
Joined
Apr 4, 2014
Messages
57
Motherboard
Samsung NP530U4C | IvyBridge
CPU
Intel Core i5-3317U | 1.7GHz
Graphics
Intel HD Graphics 4000 | 1366 x 768
Mac
Classic Mac
Mobile Phone
I recently got a new-ish Samsung laptop. These laptops (NP530U4C) use only Intel HD4000 graphics for internal display and NVIDIA GeForce GT 620M Graphics for the HDMI port. Usually the HDMI port works for viewing, like on the similar NP530U3C. Some people, however got the internal graphics (HD 4000) functioning with all acceleration, etc. using clover.

I finally got clover to install, boot, etc. I am having trouble getting any of the graphics to function using the HDMI port or screen. (USING Intel HD4000 graphics for internal display and NVIDIA GeForce GT 620M Graphics for the HDMI port)


  • I used the stock config file in the guide/tutorial, but the laptop screen backlight just turned on.
  • I used the config files for the NP530U3C but working only through the HDMI port, I am able to get a scribbled image.

Many individuals have had success with the U3C, can anyone assist with getting the U4C functioning? I do not know how to pursue from here. Is it due to a config.plist file error, or something else I am missing.


Any help is appreciated.:)




Details:
-Intel Core i5-3317U Processor
-HD4000 Graphics (Internal Screen 1366 x 768)
-NVIDIA GeForce 620 (HDMI)

-Clover 2830
-Mavericks 10.9.2
 
Joined
Apr 4, 2014
Messages
57
Motherboard
Samsung NP530U4C | IvyBridge
CPU
Intel Core i5-3317U | 1.7GHz
Graphics
Intel HD Graphics 4000 | 1366 x 768
Mac
Classic Mac
Mobile Phone
Any ideas anyone?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I recently got a new-ish Samsung laptop. These laptops (NP530U4C) use only Intel HD4000 graphics for internal display and NVIDIA GeForce GT 620M Graphics for the HDMI port. Usually the HDMI port works for viewing, like on the similar NP530U3C. Some people, however got the internal graphics (HD 4000) functioning with all acceleration, etc. using clover.

I finally got clover to install, boot, etc. I am having trouble getting any of the graphics to function using the HDMI port or screen. (USING Intel HD4000 graphics for internal display and NVIDIA GeForce GT 620M Graphics for the HDMI port)


  • I used the stock config file in the guide/tutorial, but the laptop screen backlight just turned on.
  • I used the config files for the NP530U3C but working only through the HDMI port, I am able to get a scribbled image.

Many individuals have had success with the U3C, can anyone assist with getting the U4C functioning? I do not know how to pursue from here. Is it due to a config.plist file error, or something else I am missing.


Any help is appreciated.:)




Details:
-Intel Core i5-3317U Processor
-HD4000 Graphics (Internal Screen 1366 x 768)
-NVIDIA GeForce 620 (HDMI)

-Clover 2830
-Mavericks 10.9.2

Did you set ig-platform-id = 0x01660003?
 
Joined
Apr 4, 2014
Messages
57
Motherboard
Samsung NP530U4C | IvyBridge
CPU
Intel Core i5-3317U | 1.7GHz
Graphics
Intel HD Graphics 4000 | 1366 x 768
Mac
Classic Mac
Mobile Phone
Did you set ig-platform-id = 0x01660003?

I did. I inserted a custom EDID, and then added the platform ID, added the back light Kext you created and still have not gotten the internal screen to work. The HDMI output is a mess also. See below.

20140903_203131.jpg

config.plist:

Code:
<dict>
    <key>SystemParameters</key>
    <dict>
        <key>LegacyBoot</key>
        <string>LegacyBiosDefault</string>
        <key>boot-args</key>
        <string>-v slide=0</string>
    </dict>
    <key>ACPI</key>
    <dict>
        <key>DropOemSSDT</key>
        <true/>
        <key>MinMultiplier</key>
        <integer>7</integer>
        <key>C3Latency</key>
        <string>0x00FA</string>
        <key>DsdtName</key>
        <string>DSDT.aml</string>
    </dict>
    <key>PCI</key>
    <dict>
        <key>HDAInjection</key>
        <string>No</string>
        <key>USBInjection</key>
        <true/>
        <key>InjectClockID</key>
        <true/>
        <key>USBFixOwnership</key>
        <true/>
    </dict>
    <key>KernelAndKextPatches</key>
    <dict>
        <key>AppleRTC</key>
        <true/>
        <key>AsusAICPUPM</key>
        <true/>
    </dict>
    <key>Graphics</key>
    <dict>
        <key>ig-platform-id</key>
        <string>0x01660003</string>

        <key>CustomEDID</key>
        <data>
AP///////wBMowAD/////wAWAQOAHxH/LwAAoFdJmyYQSE8AAAABAQEBAQEBAQEBAQEBAQEBnhtWeFAAGDAwICUANa4QAAAZAAAA/QAAPADZCAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAK4=
        </data>
        <key>InjectEDID</key>
        <true/>
        <key>GraphicsInjector</key>
        <true/>
        <key>PatchVBiosBytes</key>
        <array/>
    </dict>
    <key>GUI</key>
    <dict>
        
        <key>ScreenResolution</key>
        <string>1366x768</string>
        <key>HideEntries</key>
        <dict>
            <key>InternalUEFI</key>
            <true/>
            <key>OSXInstall</key>
            <true/>
            <key>WindowsEFI</key>
            <true/>
        </dict>
        <key>Mouse</key>
        <dict/>
        <key>Volumes</key>
        <dict>
            <key>Hide</key>
            <array/>
        </dict>
    </dict>
</dict>
</plist>
 
Joined
Apr 4, 2014
Messages
57
Motherboard
Samsung NP530U4C | IvyBridge
CPU
Intel Core i5-3317U | 1.7GHz
Graphics
Intel HD Graphics 4000 | 1366 x 768
Mac
Classic Mac
Mobile Phone
I am able to get it to boot although without acceleration when messing with the graphics menu in clover, but that is about it.

I can get the screen to function in the 1024 x 760 resolution with:

  • InjectEDID:[+] - selected and nothing else
  • InjectIntel:[+] - selected with either FBConfig set to 9 or FakeID: set to 0x01660003/4/9/a/b
  • LoadVideoBios:[+] - selected with nothing else
HDMI does not work with any of these modes and as I said, graphics acceleration does not work, nor does the full resolution.

The EDID and the resolution set in the config file do not appear to be working for some reason.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Not a valid use of FakeId. You do not need to use FakeID as your device is supported via the native id. What is your screen resolution?
 
Joined
Apr 4, 2014
Messages
57
Motherboard
Samsung NP530U4C | IvyBridge
CPU
Intel Core i5-3317U | 1.7GHz
Graphics
Intel HD Graphics 4000 | 1366 x 768
Mac
Classic Mac
Mobile Phone
Not a valid use of FakeId. You do not need to use FakeID as your device is supported via the native id. What is your screen resolution?

My screen resolution is 1366 x 768.
 
Joined
Apr 4, 2014
Messages
57
Motherboard
Samsung NP530U4C | IvyBridge
CPU
Intel Core i5-3317U | 1.7GHz
Graphics
Intel HD Graphics 4000 | 1366 x 768
Mac
Classic Mac
Mobile Phone
What I got from that was to use Clover Configurator, and I did so, with the same results. Any idea?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
What I got from that was to use Clover Configurator, and I did so, with the same results. Any idea?

Use the appropriate config.plist instead of the broken one you have.

Using Clover Configurator won't help unless you know what to change.
 
Status
Not open for further replies.
Top