Contribute
Register

Hackintosh gpu drivers issue gtx 1080 ti

Status
Not open for further replies.
Joined
Oct 1, 2016
Messages
15
Motherboard
MSI Z370 GAMING M5
CPU
i7-8700K
Graphics
GTX 1080 TI
Mobile Phone
  1. Android
#1
Hello there,

I've been trying to install my graphics drivers for quite a while now. I've been using the following tutorial: https://www.tonymacx86.com/threads/...er-on-high-sierra-black-screen-panics.234390/ due to the fact that this helped me about a year ago when I build my previous hackintosh.

I have followed every step (short summary: added nvda_drv=1 and use nvidia web in clover configurator boot flag and installed the nvidia web drivers) but now when i start my pc (without boot usb) i see the nvda_drv=1 boot flag in clover bootmenu but when I select my ssd on which mac os is installed i see a bunch of white text which is normal but then my pc randomly restarts. The text renders to fast for me to read the last lines

Does anyone have any idea on what I could try or how to fix this?

The last sentence of the logging is attempting restart (see attachments) i dont know if there is any use for this but its there
1548534826381.png
 
Joined
Jan 17, 2011
Messages
178
Motherboard
Asus Prime Z370-A
CPU
i7-8700K
Graphics
2xGTX 980 Ti, 1xGTX 970, UHD 630
Mobile Phone
  1. Android
  2. iOS
Did you remove:
  • NVWebDriverLibValFix.kext
  • NvidiaGraphicsFixup.kext
and update to newest lilu and whatevergreen kexts?

nvda_drv=1 is depricated
use NvidiaWeb in system parameters in clover config.
 
Joined
Oct 1, 2016
Messages
15
Motherboard
MSI Z370 GAMING M5
CPU
i7-8700K
Graphics
GTX 1080 TI
Mobile Phone
  1. Android
@beep Bo i havent thank you i will try this tonight
 
Joined
Oct 1, 2016
Messages
15
Motherboard
MSI Z370 GAMING M5
CPU
i7-8700K
Graphics
GTX 1080 TI
Mobile Phone
  1. Android
@beep unfortunately i didnt have time to try your solution. Im trying to install 10.13.3. I have managed to get this working on my old pc with nvda_drv=1 and this pc too has 10.13.3. So how can nvda_drv=1 be deprecated using the same os version, kexts and drivers?
 
Joined
Jan 17, 2011
Messages
178
Motherboard
Asus Prime Z370-A
CPU
i7-8700K
Graphics
2xGTX 980 Ti, 1xGTX 970, UHD 630
Mobile Phone
  1. Android
  2. iOS
@beep ... I have managed to get this working on my old pc with nvda_drv=1 and this pc too has 10.13.3. So how can nvda_drv=1 be deprecated using the same os version, kexts and drivers?

Nvidia drivers add the information what drivers to use in nvram (web drivers or apple drivers). Clover may automatically set "NvidiaWeb" to true in system parameters too.
 
Joined
Oct 1, 2016
Messages
15
Motherboard
MSI Z370 GAMING M5
CPU
i7-8700K
Graphics
GTX 1080 TI
Mobile Phone
  1. Android
Nvidia drivers add the information what drivers to use in nvram (web drivers or apple drivers). Clover may automatically set "NvidiaWeb" to true in system parameters too.
It could be me but i dont see how this is relevant
 
Joined
Oct 1, 2016
Messages
15
Motherboard
MSI Z370 GAMING M5
CPU
i7-8700K
Graphics
GTX 1080 TI
Mobile Phone
  1. Android
@beep I have not been able to find the kext NVWebDriverLibValFix so i didnt remove it. And i also didnt find nvidia graphic fixup kext because i didnt download and installed it myself. I installed the newest lilu and whatevergreen kext in efi > other using kext wizard. Then rebooted succesfully. Then installed nvidia web drivers and booted with use nvidia web (not nvda_drv1) but it resulted in the commonly known black screen. Any idea how to fix or what i could try?
 
Status
Not open for further replies.
Top