Contribute
Register

[Guide] Lenovo G50-80 80L0 and Catalina 10.15.2

Joined
Aug 6, 2020
Messages
28
Motherboard
Lenovo Lancer 5A2
CPU
i5 > Need model # > See Rules!
Graphics
HD 4400
I did as you asked using Clover Configurator by going to the NVRAM and Copy/pasting -f UseKernelCache=No, and then selecting Load Partition/Themes, then hit SAVE. Correct?
Same result...[sigh]
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,296
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I did as you asked using Clover Configurator by going to the NVRAM and Copy/pasting -f UseKernelCache=No, and then selecting Load Partition/Themes, then hit SAVE. Correct?
Same result...[sigh]
use xcode or plisteditpro to edit your config.plist

it goes in this section:
Code:
<key>Arguments</key>
        <string>kext-dev-mode=1 dart=0 nv_disable=1 -cdfon -igfxnohdmi</string>

so it would look like:
Code:
<key>Arguments</key>
        <string>kext-dev-mode=1 dart=0 nv_disable=1 -cdfon -igfxnohdmi -f UseKernelCache=No</string>
 
Joined
Aug 6, 2020
Messages
28
Motherboard
Lenovo Lancer 5A2
CPU
i5 > Need model # > See Rules!
Graphics
HD 4400
I first tried the text change using Clover Configurator (it's what I had). No change with the text upgrade. I Downloaded Xcode. and re-examined the Config.plist. Everything "looks" like a fragmented online list. Not at all straightforward as the text editor I had used. I checked the 2 edits you had mentioned above - they are indeed there in Xcode.

The verbose screen is still showing the "old" Voodoo kext.
It seems to be ignoring the USB stick, and booting off the laptop (erroneously). Odd, since I am selecting Install Mac OS as the Clover Start up disk. Is there any other way to force it to use the USB stick?
Also, here are the 2 pages from Xcode:
Screen Shot 2020-08-13 at 1.46.54 PM.png
Screen Shot 2020-08-13 at 1.47.23 PM.png
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,296
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I first tried the text change using Clover Configurator (it's what I had). No change with the text upgrade. I Downloaded Xcode. and re-examined the Config.plist. Everything "looks" like a fragmented online list. Not at all straightforward as the text editor I had used. I checked the 2 edits you had mentioned above - they are indeed there in Xcode.

The verbose screen is still showing the "old" Voodoo kext.
It seems to be ignoring the USB stick, and booting off the laptop (erroneously). Odd, since I am selecting Install Mac OS as the Clover Start up disk. Is there any other way to force it to use the USB stick?
Also, here are the 2 pages from Xcode:View attachment 484090View attachment 484091
having:
Code:
<key>InjectKexts</key>
        <string>Yes</string>
in your config.plist on your mounted efi on your usb installer should do the job

just to make sure you are mounting your usb installer? and making the changes in there? and also booting form your usb installer? (have to ask these questions... :) )
 
Joined
Aug 6, 2020
Messages
28
Motherboard
Lenovo Lancer 5A2
CPU
i5 > Need model # > See Rules!
Graphics
HD 4400
Here's what I am doing: I insert my USB drive into my Mac, it then mounts the Install MacOS Catalina drive that was created from Unibeast. I then open the folder on that USB drive, specifically the folder entitled Files, open that folder, and then double-click on EFI Mounter V3 .1. At that point, the EFI image is mounted on my desktop. I double-click on the EFI image, and it contains a folder entitled EFI. Inside that folder are two folders BOOT, and CLOVER. Inside the Boot folder is the config.Plist file as well as the Kexts Folder which is been the objects of our attention.
Am I doing something wrong?
Screen Shot 2020-08-13 at 3.23.25 PM.png
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,296
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Here's what I am doing: I insert my USB drive into my Mac, it then mounts the Install MacOS Catalina drive that was created from Unibeast. I then open the folder on that USB drive, specifically the folder entitled Files, open that folder, and then double-click on EFI Mounter V3 .1. At that point, the EFI image is mounted on my desktop. I double-click on the EFI image, and it contains a folder entitled EFI. Inside that folder are two folders BOOT, and CLOVER. Inside the Boot folder is the config.Plist file as well as the Kexts Folder which is been the objects of our attention.
Am I doing something wrong?View attachment 484105
yes, that is correct, just wanted to make sure :)

also you could boot form your usb stick and try reaching the macOS installer, you can use terminal to remove the kexts from /Library/Extensions

unless you can try and boot in safe mode?
 
Joined
Aug 6, 2020
Messages
28
Motherboard
Lenovo Lancer 5A2
CPU
i5 > Need model # > See Rules!
Graphics
HD 4400
How does one boot from the USB stick? Holding down the option key equivalent on the Lenovo had no effect.
If I get that far which kexts would I omit?
How do I boot in safe mode on a Hackintosh? Holding down the shift key in clover had no effect.
Everything takes me to an Apple Logo and progress bar that stalls at 90-95%.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,296
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
How does one boot from the USB stick? Holding down the option key equivalent on the Lenovo had no effect.
If I get that far which kexts would I omit?
How do I boot in safe mode on a Hackintosh? Holding down the shift key in clover had no effect.
Everything takes me to an Apple Logo and progress bar that stalls at 90-95%.
holding shift or control won't work, that is only for real macs

in your bios, check to make sure usb stick is first device to boot from

or some Lenovo requires pressing the F12 on startup and then choose the usb stick, from there try and boot the mac normally, if that doesn't work, then re try booting from usb and press space bar at the clover boot screen and choose safe mode

if that doesn't work then boot from usb, try and reach the macOS installer, and then have a search on your other computer on how to delete a kext in recovery mode

if that doesn't work then boot from usb, reach the installer, wipe your drive and fresh install macOS on your laptop

and when you have finished, delete multibeast as you won't be using that, and do not install kexts to your /Library/Extensions folder, keep them only in your EFI
 
Joined
Aug 6, 2020
Messages
28
Motherboard
Lenovo Lancer 5A2
CPU
i5 > Need model # > See Rules!
Graphics
HD 4400
Got to the HD with resetting the EFI-USB as start up, then used Fxn-F12. This got me to Clover with the USB drive AND HD drive showing up. BUT, the progress bar got stuck near complete again; Restarted again...same stuck progress bar.
Restarted again, and selected USB HDD (not EFI...), and this time only the Install Catalina is shown in Clover. Still with stuck progress bar.
Tried Space Bar - with EFI-USB, and plain USB options - same result.
Rebooted with the tiny button on left side and tried System Recovery. Same result.
I am attaching photos - no pathway to the USB drive.
So close - but so far!
 

Attachments

  • IMG_2897.JPG
    IMG_2897.JPG
    78.2 KB · Views: 31
  • IMG_2896.JPG
    IMG_2896.JPG
    72.8 KB · Views: 32
  • IMG_2894.JPG
    IMG_2894.JPG
    71.4 KB · Views: 31

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,296
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Got to the HD with resetting the EFI-USB as start up, then used Fxn-F12. This got me to Clover with the USB drive AND HD drive showing up. BUT, the progress bar got stuck near complete again; Restarted again...same stuck progress bar.
Restarted again, and selected USB HDD (not EFI...), and this time only the Install Catalina is shown in Clover. Still with stuck progress bar.
Tried Space Bar - with EFI-USB, and plain USB options - same result.
Rebooted with the tiny button on left side and tried System Recovery. Same result.
I am attaching photos - no pathway to the USB drive.
So close - but so far!
press space bar at the clover boot screen and choose verbose mode and then boot
 
Top