Contribute
Register

[Guide] Intel NUC7/NUC8 using Clover UEFI (NUC7i7Bxx,NUC8i7Bxx,etc)

Joined
Feb 21, 2010
Messages
570
Motherboard
Gigabyte Aorus Master Z390
CPU
i9-9900K
Graphics
Vega 64
Mac
MacBook Air
Mobile Phone
Android
Hi Leesureone, So I followed the guide you recommended using my existing clover bootable USB. I downloaded all the files and placed them in the relevant folders in clover. The Bios on the Nuc is the latest and configured as per the walk through. On inserting the USB into the Nuc and booting into clover and make the configurations I get as far as [Part 2] point 2. Once again I get the apple logo with an install bar on completion nothing happens, I don't get an install screen and can't access Disk Utility to format the internal M.2 drive.

Any ideas what could be going wrong? I've tried everything I can think of (apart from starting from scratch)?
You didn’t mention updating clover, make sure that’s been updated. If you have a Samsung 970 Evo plus M2 NVME drive you are going to have to update the firmware. Instructions for creating a bootable usb drive are on the Samsung website with the forward update.

Beyond that please post your EFI folder to see what is what. Thx
 
Joined
May 26, 2019
Messages
11
Motherboard
Intel NUC8i5BEK
CPU
i5
Graphics
Iris Plus 655
You didn’t mention updating clover, make sure that’s been updated. If you have a Samsung 970 Evo plus M2 NVME drive you are going to have to update the firmware. Instructions for creating a bootable usb drive are on the Samsung website with the forward update.

Beyond that please post your EFI folder to see what is what. Thx
Hi Leesureone, The attached zip is the EFI folder I'm using, I started from scratch and get to exactly the same point. FYI details of the machine, HD and RAM:
- Intel BOXNUC8I5BEK3 NUC Mini PC - (Black) (Intel Core i5 8259U, Intel Iris Plus Graphics 655, BareBone)
- Crucial CT16G4SFD824A 16 GB Memory (DDR4, 2400 MT/s, PC4-19200, Dual Rank x8, SODIMM, 260-Pin)
- Crucial CT500P1SSD8 P1 500 GB (3D, NAND, NVMe, PCIe, M.2, Solid State Drive)

Thanks for your help
 

Attachments

Joined
Feb 21, 2010
Messages
570
Motherboard
Gigabyte Aorus Master Z390
CPU
i9-9900K
Graphics
Vega 64
Mac
MacBook Air
Mobile Phone
Android
Okay, that helped. Your config.plist doesn't have the RTC fix in the ACPI/DSDT/Patches section which you need for bios version 55 and above. I've attached my entire EFI folder again if you want to just replace it or copy the config.plist from it and replace yours.
 

Attachments

Joined
May 26, 2019
Messages
11
Motherboard
Intel NUC8i5BEK
CPU
i5
Graphics
Iris Plus 655
Okay, that helped. Your config.plist doesn't have the RTC fix in the ACPI/DSDT/Patches section which you need for bios version 55 and above. I've attached my entire EFI folder again if you want to just replace it or copy the config.plist from it and replace yours.
Thanks for your help, I'll replace my config.plist with your file and report back when I've got it sorted.
 
Joined
Apr 10, 2018
Messages
2
Motherboard
NUC7i5BNH
CPU
i5 7260U
Graphics
Iris Plus 640
Hello everybody,

I try to install High Sierra on my NUC7i5BNH but it always fails.

I can start the installing process and it reboots (always).
Sometimes I can do the installation completely but after the Multibeast installation it never boots again.

First I had a SSD installed but it switched to APFS and so I couldt't work with it. Formatting in HFS wasn't possible any more.
Now I have a simple HDD with HFS inside.

When I switch on the NUC it takes about a minute then it shows the error codes:
-- (see jpg) ---
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: Block device not supportedSuccess
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: Block device not supportedSuccess
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: Block device not supportedSuccess
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: Block device not supportedSuccess
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: Block device not supportedSuccess
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: Block device not supportedSuccess
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: ApfsGptEntry is null
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: ApfsGptEntry is null
...
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: ReadDisk1 Error No Media
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: ReadDisk1 Error No Media
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: ReadDisk1 Error No Media
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: ReadDisk1 Error No Media

Any ideas?

Thank you.
 

Attachments

Joined
May 26, 2019
Messages
11
Motherboard
Intel NUC8i5BEK
CPU
i5
Graphics
Iris Plus 655
Okay, that helped. Your config.plist doesn't have the RTC fix in the ACPI/DSDT/Patches section which you need for bios version 55 and above. I've attached my entire EFI folder again if you want to just replace it or copy the config.plist from it and replace yours.
Hi, So I copied your config.plist file and was able to format the internal SSD and start the installation.

As per the guide it (Part 2 step 5) I have 2 options in clover (image attached) but the guide says 3rd entry on the right?

I tried using "macOS" (used the same name as the guide) and it's got to installing and I've ended up with the apple logo and a full installing bar.

I'm guessing, something has gone wrong? Any ideas? Should I try your EFI folder and start the process from scratch?

409559
 
Joined
Feb 21, 2010
Messages
570
Motherboard
Gigabyte Aorus Master Z390
CPU
i9-9900K
Graphics
Vega 64
Mac
MacBook Air
Mobile Phone
Android
Hi, So I copied your config.plist file and was able to format the internal SSD and start the installation.

As per the guide it (Part 2 step 5) I have 2 options in clover (image attached) but the guide says 3rd entry on the right?

I tried using "macOS" (used the same name as the guide) and it's got to installing and I've ended up with the apple logo and a full installing bar.

I'm guessing, something has gone wrong? Any ideas? Should I try your EFI folder and start the process from scratch?

View attachment 409559
Well, if you made it that far then at the screen above choose macOS to complete the installation set up. It takes a while to load...(you may not have a recovery portion which would make three total entries instead of the two you show, no major deal). Once that finishes you will have to install clover to macOS and then can copy my EFI folder as well over to your hard drive and try booting from that. It should work.
 
Joined
Feb 21, 2010
Messages
570
Motherboard
Gigabyte Aorus Master Z390
CPU
i9-9900K
Graphics
Vega 64
Mac
MacBook Air
Mobile Phone
Android
Hello everybody,

I try to install High Sierra on my NUC7i5BNH but it always fails.

I can start the installing process and it reboots (always).
Sometimes I can do the installation completely but after the Multibeast installation it never boots again.

First I had a SSD installed but it switched to APFS and so I couldt't work with it. Formatting in HFS wasn't possible any more.
Now I have a simple HDD with HFS inside.

When I switch on the NUC it takes about a minute then it shows the error codes:
-- (see jpg) ---
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: Block device not supportedSuccess
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: Block device not supportedSuccess
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: Block device not supportedSuccess
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: Block device not supportedSuccess
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: Block device not supportedSuccess
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: Block device not supportedSuccess
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: ApfsGptEntry is null
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: ApfsGptEntry is null
...
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: ReadDisk1 Error No Media
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: ReadDisk1 Error No Media
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: ReadDisk1 Error No Media
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: ReadDisk1 Error No Media

Any ideas?

Thank you.
It could be a few things but it looks like you are missing drivers, this guide doesn’t use multibeast and that could be the cause of your issue.
If I were you I would start over and follow the guide.


 
Joined
Dec 19, 2018
Messages
5
Motherboard
NUC7i7DNHE
CPU
i7-8650U
Graphics
UHD 620
Mac
iMac
Hey all,

I just noticed that after following the guide and having got my NUC7i7DNHE up and running perfectly, I noticed my iStatmenus does not show my CPU temperatures. I've been reading that you can build a version of VirtualSMC to show your fan speeds and CPU temperature in iStatmenus but cannot seem to find anything related to NUCs.

Any ideas where I went wrong? Alternatively is the guide just not that interested in showing CPU temps? (it's not absolutely necessary, I get that)
 
Top