Contribute
Register

[Guide] Intel NUC7/NUC8 using Clover UEFI (NUC7i7Bxx,NUC8i7Bxx,etc)

Joined
Feb 21, 2010
Messages
190
Motherboard
Asus ROG Strix Z390-I
CPU
i9-9900K
Graphics
RX 590
Mac
MacBook Air
Mobile Phone
Android
I updated to latest stable Clover and left Mac OS alone. When I select Mac OS at reboot, the screen clears and nothing happens. The same behavior if I try to boot Mac OS install from the USB drive just to see if I can get anything to work. Windows 10 boots without issues (of course). Any ideas?
Did you make sure to select the UEFI boot selections shown in the attached when installing? You can always run install again but double check the correct drivers and Kexts are still installed in your hard drive based EFI folder.
 

Attachments

Joined
Dec 9, 2018
Messages
24
Motherboard
Intel NUC8I3BEH1
CPU
i3-8109U
Graphics
Intel Iris Plus Graphics 655
Did you make sure to select the UEFI boot selections shown in the attached when installing? You can always run install again but double check the correct drivers and Kexts are still installed in your hard drive based EFI folder.
I totally did not :(. Ugh. How do I recover? I have an older MacBook Pro. Should I ensure the USB is setup properly there, hopefully boot via USB and then fix in clover installed on my Hackinstosh?

Also, I didn’t backup my config.plist. Did that get overwritten? I’ll try to check myself but I don’t have much time today.
 
Joined
Feb 21, 2010
Messages
190
Motherboard
Asus ROG Strix Z390-I
CPU
i9-9900K
Graphics
RX 590
Mac
MacBook Air
Mobile Phone
Android
I totally did not :(. Ugh. How do I recover? I have an older MacBook Pro. Should I ensure the USB is setup properly there, hopefully boot via USB and then fix in clover installed on my Hackinstosh?

Also, I didn’t backup my config.plist. Did that get overwritten? I’ll try to check myself but I don’t have much time today.
Yes, boot off the USB drive and then rerun the clover installer. Yes, your config.plist should have been saved.
 
Joined
Dec 9, 2018
Messages
24
Motherboard
Intel NUC8I3BEH1
CPU
i3-8109U
Graphics
Intel Iris Plus Graphics 655
Yes, boot off the USB drive and then rerun the clover installer. Yes, your config.plist should have been saved.
Ok when I tried to do this it would only let me into the Mac OS installer. How can I get actual OS from USB?
 
Joined
Feb 21, 2010
Messages
190
Motherboard
Asus ROG Strix Z390-I
CPU
i9-9900K
Graphics
RX 590
Mac
MacBook Air
Mobile Phone
Android
Ok when I tried to do this it would only let me into the Mac OS installer. How can I get actual OS from USB?
If you selected the USB drive on boot your existing installation of OSX should show. If not you may have to start over.
 
Joined
Dec 9, 2018
Messages
24
Motherboard
Intel NUC8I3BEH1
CPU
i3-8109U
Graphics
Intel Iris Plus Graphics 655
This worked, thanks Leesureone! I booted from the USB drive into Mac OS on my hard drive, then manually copied over the few missing driver64 files. I also cleared all folders from kext except "Other" and validated that my plist was unchanged in the upgrade (phew). Thx again
 
Joined
Feb 21, 2010
Messages
190
Motherboard
Asus ROG Strix Z390-I
CPU
i9-9900K
Graphics
RX 590
Mac
MacBook Air
Mobile Phone
Android
That’s how it’s done! Way to go!:headbang:
 
Top