Contribute
Register

[Guide] Intel NUC7/NUC8 using Clover UEFI (NUC7i7Bxx,NUC8i7Bxx,etc)

Joined
Feb 21, 2010
Messages
282
Motherboard
Gigabyte Aorus Master Z390
CPU
i9-9900K
Graphics
Vega 64
Mac
MacBook Air
Mobile Phone
Android
One more question, I was able to get my Vega 56 eGPU working last time. I tried with your folder. Everything works but when I plug in a thunderbolt device it just says no thunderbolt drivers loaded.
Do you have Thunderbolt set to "Legacy" in the bios? Also Hot Plugging doesn't work so your external GPU has to be plugged in before you power on.
 
Joined
Aug 1, 2013
Messages
8
Motherboard
Intel NUC8I7BEH
Graphics
Intel 655 / Vega 56
Mac
MacBook Pro
Mobile Phone
Android, iOS
Yep. It's set to legacy and it is plugged in before the system boots. Last time, it wouldn't detect it as a thunderbolt device but it still showed up under graphics. This time , no dice.
 
Joined
Feb 21, 2010
Messages
282
Motherboard
Gigabyte Aorus Master Z390
CPU
i9-9900K
Graphics
Vega 64
Mac
MacBook Air
Mobile Phone
Android
Yep. It's set to legacy and it is plugged in before the system boots. Last time, it wouldn't detect it as a thunderbolt device but it still showed up under graphics. This time , no dice.
I don't have an external GPU to test but Thunerbolt is native Mojave, there aren't any kexts or drivers to install to make it work. There maybe drivers needed for Thunderbolt devices I think, could be wrong. My external hard drives work so I don't have much advice for you except to google and see what others have done because I'm pretty sure there was another user on this forum who did.

This guy did it but no explanation of how, I know he had issues at first. What dock and GPU do you have?

 
Joined
Aug 1, 2013
Messages
8
Motherboard
Intel NUC8I7BEH
Graphics
Intel 655 / Vega 56
Mac
MacBook Pro
Mobile Phone
Android, iOS
I have a Sonnet breakaway box and a Vega 56. The same combo works just fine with my 2018 MBP. So the hardware works. I just have yet to figure out what I did the first time to make it work. One of things was to make sure the SMBIOS was set to Macmini8,1 which it is. It could be that the newer intel bios broke something because it worked with Bios 0056. I tried downgrading a couple of ways (removing the security jumper, power button method) no dice.
 
Joined
Feb 21, 2010
Messages
282
Motherboard
Gigabyte Aorus Master Z390
CPU
i9-9900K
Graphics
Vega 64
Mac
MacBook Air
Mobile Phone
Android
I have a Sonnet breakaway box and a Vega 56. The same combo works just fine with my 2018 MBP. So the hardware works. I just have yet to figure out what I did the first time to make it work. One of things was to make sure the SMBIOS was set to Macmini8,1 which it is. It could be that the newer intel bios broke something because it worked with Bios 0056. I tried downgrading a couple of ways (removing the security jumper, power button method) no dice.
Gotcha
 
Joined
Jul 23, 2011
Messages
80
Mac
MacBook Pro, Mac Pro
Classic Mac
SE
Mobile Phone
Android, iOS
Hi guys!

I decided to update things on my NUC7 running High Sierra, so I did:

Code:
git stash
git pull
make clean
make
make install_nuc7
./download.sh
./install_downloads.sh
Then I downloaded an installed the latest Clover. Checked for only EFI/Clover/kexts/Other to be existing. Updated (replaced) my config.plist with the config_nuc7.plist from the git repository and then copied in my details for SMBIOS from my old config.plist. After a restart and trying to boot from my drive with High Sierra (waiting to go Mojave a little longer) this happens:


So, I’m stuck in a loop. Any ideas?

Aha, wait a minute – I should have just done ”Updates to patch repositories” in @RehabMan 's first post in this thread, now I did the step where it says ”System updates”, is that why I can’t boot High Sierra anymore? :-/

Edit:
Managed to fix it. Running the Clover installer PKG removed some items from the EFI/CLOVER/drivers64UEFI folder, such as ApfsDriverLoader-64.efi and OsxAptioFixDrv-64.efi which seems vital to booting MacOS. Putting them back from the Clover PKG using the great software Suspicious Package made things work again.
 
Last edited:
Joined
Feb 21, 2010
Messages
282
Motherboard
Gigabyte Aorus Master Z390
CPU
i9-9900K
Graphics
Vega 64
Mac
MacBook Air
Mobile Phone
Android
Hi guys!

I decided to update things on my NUC7 running High Sierra, so I did:

Code:
git stash
git pull
make clean
make
make install_nuc7
./download.sh
./install_downloads.sh
Then I downloaded an installed the latest Clover. Checked for only EFI/Clover/kexts/Other to be existing. Updated (replaced) my config.plist with the config_nuc7.plist from the git repository and then copied in my details for SMBIOS from my old config.plist. After a restart and trying to boot from my drive with High Sierra (waiting to go Mojave a little longer) this happens:


So, I’m stuck in a loop. Any ideas?

Aha, wait a minute – I should have just done ”Updates to patch repositories” in @RehabMan 's first post in this thread, now I did the step where it says ”System updates”, is that why I can’t boot High Sierra anymore? :-/
You should be able to boot off your USB drive if you still have it. If not that's going to be your path to recovery so you can make corrections to what you overwrote.
 
Joined
Jun 10, 2019
Messages
1
Motherboard
NUC8i7
Graphics
Iris Plus 655
Hi guys,
I followed this guide back in December, updating to 14.5 progressively and have not had problems with the system, I have kept the same BIOS version since install. I noticed that @RehabMan 's files have not been updated in a while.

Reading the last few pages, I gather that everything related to Hackintosh is now out of date, so how should I get everything updated? I downloaded @Leesureone 's EFI folder from a couple of pages back, what order should I do things in, between Clover, Kext and others?

This is my first Hackintosh, and I am not even sure how I should update Kexts and Clover as Rehabman had many steps scripted. I tried to Google, but there seems to be many conflicting guides. What are the guides suitable for NUC8 to update Clover and Kexts?
 
Joined
Feb 21, 2010
Messages
282
Motherboard
Gigabyte Aorus Master Z390
CPU
i9-9900K
Graphics
Vega 64
Mac
MacBook Air
Mobile Phone
Android
Hi guys,
I followed this guide back in December, updating to 14.5 progressively and have not had problems with the system, I have kept the same BIOS version since install. I noticed that @RehabMan 's files have not been updated in a while.

Reading the last few pages, I gather that everything related to Hackintosh is now out of date, so how should I get everything updated? I downloaded @Leesureone 's EFI folder from a couple of pages back, what order should I do things in, between Clover, Kext and others?

This is my first Hackintosh, and I am not even sure how I should update Kexts and Clover as Rehabman had many steps scripted. I tried to Google, but there seems to be many conflicting guides. What are the guides suitable for NUC8 to update Clover and Kexts?
@jmjmjm, parts of this guide are outdated but the kexts and drivers64UEFI needed are the same. You can update clover directly through a download from Sound Forge or via the Clover Configurator app. Same for the kexts, you can google the kext and download directly from Github or wherever or again use Clover Configurator. Meanwhile if everything works then you don't have to update anything, your option.
 
Joined
Jun 2, 2011
Messages
23
Motherboard
NUC6 Skull Canyon
CPU
I7-6770HQ
Graphics
Iris Pro 580
Mac
MacBook Air
The guide is outdated now and not being maintained. You can’t use Rehabmans config.plist for bios version 56 and above, new machines come with version 71. It just doesn’t work anymore. Also Rehabmans version of clover is outdated and will not work above mojave 14.2. Download the newest version from sound forge and reinstall. On the page before this one I posted my EFI folder that you can use to replace yours after updating clover.
Just to be clear, the latest Clover with the latest BIOS will run Mojave 10.14.5?
 
Top