Contribute
Register

[GUIDE] General Framebuffer Patching Guide (HDMI Black Screen Problem)

Joined
Jun 29, 2020
Messages
5
Motherboard
Gigabyte GA-Z390 UD
CPU
i5-9400
Graphics
UHD 630
Mobile Phone
  1. Android
On-board HDMI ports no longer work in Catalina. See the large NOTICE at the top of Post #1.

So, there is only this variants for me :
a) Image on screen, but no video acceleration.
b) Use version < 10.15.x
c) No image on screen at all.

Is it correct ?
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,867
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
So, there is only this variants for me :
a) Image on screen, but no video acceleration.
b) Use version < 10.15.x
c) No image on screen at all.

Is it correct ?
Correct, but if you have an available PCIe slot, then an AMD GPU would be a good choice.
 
Joined
Dec 13, 2014
Messages
25
Motherboard
Lenovo ThinkCentre M710s SFF 10M7
CPU
Intel Core i5-7400
Graphics
Intel 630
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hello,

I can not make it work for me, I already tried all the BusIDs and the indexes in a patch .. could someone help me, I have a VGA in the laptop, the acceleration intel HD works. The laptop restarts normal but when connecting VGA there is no video, no signal. :(

When I connect the VGA none lights up.

Could someone give me an idea. I have Catalina.
 

Attachments

  • Screen Shot 2020-07-09 at 12.36.53 PM.png
    Screen Shot 2020-07-09 at 12.36.53 PM.png
    148.8 KB · Views: 26
  • Screen Shot 2020-07-09 at 12.36.45 PM.png
    Screen Shot 2020-07-09 at 12.36.45 PM.png
    125.3 KB · Views: 27
  • Screen Shot 2020-07-09 at 12.32.27 PM.png
    Screen Shot 2020-07-09 at 12.32.27 PM.png
    139.1 KB · Views: 26
  • WhatsApp Image 2020-07-09 at 12.33.23.jpeg
    WhatsApp Image 2020-07-09 at 12.33.23.jpeg
    62.5 KB · Views: 27
Joined
Nov 13, 2016
Messages
500
Motherboard
Gigabyte Z270M-D3H
CPU
i3-7350K OC 4.5GHz
Graphics
RX 580
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Classic
Mobile Phone
  1. iOS
VGA has never been supported on recent macOS versions (or any?)

I'd suggest plug into that nice HDMI port right next to it.

Hello,

I can not make it work for me, I already tried all the BusIDs and the indexes in a patch .. could someone help me, I have a VGA in the laptop, the acceleration intel HD works. The laptop restarts normal but when connecting VGA there is no video, no signal. :(

When I connect the VGA none lights up.

Could someone give me an idea. I have Catalina.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,354
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
VGA has never been supported on recent macOS versions (or any?)

I'd suggest plug into that nice HDMI port right next to it.
not for over 10 years!
 
Joined
Dec 13, 2014
Messages
25
Motherboard
Lenovo ThinkCentre M710s SFF 10M7
CPU
Intel Core i5-7400
Graphics
Intel 630
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Thank you very much for the help, I also have a lenovo M710s and if the VGA port works in Catalina . But of course all the hardware is not the same.

I will install in high sierra and try the laptop. Any news makes it known here and maybe someone will help you.
 
Joined
Sep 22, 2011
Messages
1,347
Motherboard
HP EliteDesk 800 G5 Mini
CPU
I9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Pipe and Flags are the 3rd and 5th columns in the screenshot you posted. We don't have to worry about these items though. Just focus on Index, BusID, and Type.

Maybe I'm misunderstanding this post, but Flags were critical to my system's ability to wake from sleep. Without specifying flags, my system would wake to dark screens and I was unable to remotely login. Some of my test results are here and my latest display sleep / wake findings are here.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,867
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Maybe I'm misunderstanding this post, but Flags were critical to my system's ability to wake from sleep. Without specifying flags, my system would wake to dark screens and I was unable to remotely login. Some of my test results are here and my latest display sleep / wake findings are here.
Those are good posts, particularly the experimentation with igfxonin=1.

We set Pipe to the same value for all ports to avoid reboot when HDMI cable is hot-plugged.

Regarding Flags, the default value in Hackintool is 0x3C7, which we keep intact. Because this is not something we change, I asked the poster to focus only on modifying Index, BusID and Type.
 
Joined
Sep 22, 2011
Messages
1,347
Motherboard
HP EliteDesk 800 G5 Mini
CPU
I9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Those are good posts, particularly the experimentation with igfxonin=1.

We set Pipe to the same value for all ports to avoid reboot when HDMI cable is hot-plugged.

Regarding Flags, the default value in Hackintool is 0x3C7, which we keep intact. Because this is not something we change, I asked the poster to focus only on modifying Index, BusID and Type.

Thanks for the quick reply! All makes sense. I am finding that my DP ports (using DP->DVI adapters) are hot-pluggable without specifying pipes.
 
Top