Contribute
Register

[Guide] Dell XPS 15 9560 MacOS 10.14.1 (all models)

Joined
May 20, 2018
Messages
84
Motherboard
Dell XPS-15 9560-Clover
CPU
i7-7700HQ / HM175
Graphics
HD 630 / 3840 x 2160
Mac
MacBook Pro
Mobile Phone
iOS
You must provide details on what is wrong with sleep.
It won't enter sleep at all, not after closing the lid, not after manually telling it to enter sleep. The screen goes black and the backlight on the keyboard turns off, but the battery keeps draining and the machine stays quite warm.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,205
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Still can't get sleep to work. Attached are debug files.
It won't enter sleep at all, not after closing the lid, not after manually telling it to enter sleep. The screen goes black and the backlight on the keyboard turns off, but the battery keeps draining and the machine stays quite warm.
FakePCIID_Intel_HD_Graphics.kext is generally not used anymore. Use WhateverGreen.kext instead.
Why is HS07 marked internal (UsbConnector=255) but nothing is attached?

AptioMemoryFix or AptioFixDrv usually recommended over AptioFix2Drv.
 
Joined
Sep 3, 2018
Messages
18
Motherboard
Dell XPS 15 9570
CPU
i9-8950HK
Graphics
HD 630, GTX 1050Ti (disabled), 4K Touch
Mac
MacBook Pro
Mobile Phone
iOS
Welcome to my XPS 15 9560 guide. This guide should work for most hardware configurations, but here is my configuration:​

  • CPU: i5-7300HQ @ 2.5GHz
  • 8GB RAM
  • Nvidia GTX 1050 / Intel HD 630
  • 1080p IPS display (See edit in pre-install for 4k display)
  • 1TB Samsung NVMe SSD
  • Broadcom BCM94352Z Dell DW1560 Wifi + BT card

What works:
  • Audio
  • Brightness + volume controls
  • HDMI + Thunderbolt 3 (TB3 at least works as a display output, not sure about other functionality)
What doesn't work:
  • SD card reader
  • Fingerrprint reader
  • Some trackpad gestures
  • dGPU (Nvidia Optimus not supported on MacOS)
Let's get started! My 1080p EFI.zip is at the bottom. Includes folder for Kexts that go in /clover/kexts/other, and /L/E. A version for 4k XPS 15's can be found below as well.
EDIT 11/04: All issues should be fixed. Updated Kexts to latest versions to support MacOS 10.14.1!

Pre-install:


First make sure your BIOS settings are in good shape. There are guides all over on correct BIOS settings to use.

Next, you will need the latest Download of MacOS Mojave. I suggest waiting for the official release of Mojave for inexperienced users but this will work with beta Mojave as well.

You will also need a minimum 8gb flash drive formatted in Mac OS Extended (Journaled) on GPT format.

You can use this command to format your drive:

Code:
diskutil partitionDisk /dev/*YOUR DISK* GPT JHFS+ MojaveInstallUSB 0b
Next you will need to install the Installer to the drive. For the Mojave is:
Code:
sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/MojaveInstallUSB --nointeraction
Next, download and install the latest version of clover from SourceForge.
  • Make sure you choose to install it to the USB!
  • Install for UEFI booting only
  • Install Clover to the ESP

Now you will need to install your kexts on the USB drive. The ones necessary for booting are located in the EFI folder. Just drag my EFI folder into the EFI partition on the USB drive and you should be good.

Go ahead and place everything in the zip on the non-EFI USB partition, including the EFI folder. You will use this to make your laptop bootable without the drive.

Now you are ready to install! Boot into the drive using f12 while booting. Select the UEFI version of the USB if available.

Installation:

Boot into the install at the clover panel.

At the installer screen, open up disk utility in the top right bar. This is where you will format your drive as APFS

WARNING: If you intend to dual/triple/whatever boot your system, I would create the partitions in Windows FIRST, and then just using Disk Utility to format the partition you want to install on. This is how I successfully Dual-booted with my existing Win10 install. If you don't have windows installed already or want to wipe it you can format and partition from DU.

Once you are formatted as APFS, go back to the installer screen and install to the drive.

After that is done, reboot and select "Boot *drive name* from USB" or whatever your equivalent is. Complete installation as normal.

Post-installation:

Now that you are on the desktop, open the USB and drag the .zip files onto the Desktop.

Move Clover Configurator and KextBeast to your Applications folder.

Launch Clover installer and install Clover to your main drive.

Next, open Clover Configurator and use it to mount your main drive's EFI partition. Drag your CLOVER folder from within the EFI folder on your desktop to the EFI folder on your main drive.

Next, put on the other kexts from "Other kexts" folder on your Desktop. Open KextBeast and install the Kexts to /L/E.

At this point, your should have a fully-functioning hackintosh! If there is an issue with this guide or files I attached HMU and I'll do my best to fix them. Before commenting though, make sure you read the Common Problems with Mojave thread.

- If the Dell dock does not work, try changing the SMBIOS to Macbook 9,1.

- If your audio still isn't working, run the ALCPlugFix script in the folder in a terminal window. Hopefully this will resolve any issues.

- If your graphics aren't working properly, try changing your intelGFX deviceID to 0x59120000.
Hey acdop100,

I've checked using ChronoSync into your zip files and both contents are identical beside their names being different.

I have a very similar machine running except for the processor (i9 - coffee lake) on Mojave OS but I can't get HDMI nor TB3 display output to work. Under System Profiler > Thunderbolt, it says: "No drivers are loaded." I have an USB-C port and a small adapter (CharJenPro USB-C 3.1 HUB/ADAPTER) and everything works except for HDMI and my CableCreation Type C to Mini DP Adapter, Thunderbolt 3 Compatible

What do I need to make this to work? I would like to be able to reuse my old Apple Cinema Display (ideally through USB-C to mini-DisplayPort) or using another HDMI monitor.

Thanks.
PM
 
Joined
May 20, 2018
Messages
84
Motherboard
Dell XPS-15 9560-Clover
CPU
i7-7700HQ / HM175
Graphics
HD 630 / 3840 x 2160
Mac
MacBook Pro
Mobile Phone
iOS
FakePCIID_Intel_HD_Graphics.kext is generally not used anymore. Use WhateverGreen.kext instead.
Why is HS07 marked internal (UsbConnector=255) but nothing is attached?

AptioMemoryFix or AptioFixDrv usually recommended over AptioFix2Drv.
Hi, I uninstalled the FakePCIID_Intel_HD_Graphics.kext and am using AptioMemoryFix. I'm sorry but I'm not sure what HS07 refers to... Debug attached
 

Attachments

Joined
Oct 1, 2012
Messages
2
Motherboard
XPS 9560
CPU
i7-7700HQ
Graphics
HD630 / GTX1050 / 1080P
Mac
MacBook Pro
Mobile Phone
iOS
Been trying to get this to work on my 9560 but so far I can't get passed the white apple logo with loading bar after I select installer from clover. Any pointers would be greatly appriciated. I have the 1080p with Samsung ssd.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,205
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Been trying to get this to work on my 9560 but so far I can't get passed the white apple logo with loading bar after I select installer from clover. Any pointers would be greatly appriciated. I have the 1080p with Samsung ssd.
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/

Also, your profile needs fixing. Please fix as per FAQ.... before your next reply.
 
Joined
Jun 27, 2017
Messages
25
Motherboard
Asus Prime X270-P
CPU
i7-7700K
Graphics
GTX 1050
Mobile Phone
Android
So the Nvidia GPU doesn't work at all? Or you have to use just the Intel gpu or the gtx?
 
Joined
Apr 20, 2014
Messages
65
Motherboard
XPS 15 9560
CPU
i5 7300HQ
Graphics
GTX 1050, Intel HD630, 1080p
Mac
MacBook Pro
Mobile Phone
iOS
So the Nvidia GPU doesn't work at all? Or you have to use just the Intel gpu or the gtx?
Since the GPU is run with NVidia Optimus, it isn't recognized by the MacOS system so only the intel iGPU is usable.
 
Joined
Jun 27, 2017
Messages
25
Motherboard
Asus Prime X270-P
CPU
i7-7700K
Graphics
GTX 1050
Mobile Phone
Android
Since the GPU is run with NVidia Optimus, it isn't recognized by the MacOS system so only the intel iGPU is usable.
Oh, that's a huge bummer. Guess I'll hold off on dual booting.
 
Top