Contribute
Register

[Guide] Dell XPS 15 9560 MacOS 10.14.1 (all models)

Feartech

Moderator
Joined
Aug 3, 2013
Messages
15,571
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Hi :) Thanks for the guide. I'm looking to dual boot (windows and mojave). I prepared the USB with clover and all your kexts but it doesn't show up in the bootable devices list when I press F12 at boot.

Could this be related to the fact that my Sata mode is still set to Raid on and not AHCI? Changing it to the latter breaks windows apparently :/
AHCI is needed
 
Joined
Sep 17, 2013
Messages
56
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
UHD 630
But how did the OP manage to dual boot with windows? Enabling AHCI instantly breaks windows, I just tried it :/
If you installed windows in raid mode. It won't have the drivers installed for AHCI mode. Thats why windows wont boot when you change to AHCI mode. You might need to reinstall windows in AHCI mode to get it to work.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,977
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
But how did the OP manage to dual boot with windows? Enabling AHCI instantly breaks windows, I just tried it :/
Re-install Windows.
 
Joined
Oct 22, 2017
Messages
14
Motherboard
Dell XPS 15 9560 4K
CPU
i7-7700HQ
Graphics
GTX 1050 | HD 630 @ eGPU: GTX 1080
Has anyone tried this with 10.14.2? I am unable to get 10.14.1 and stuck with 10.14.2
 
Joined
Jan 6, 2019
Messages
4
Motherboard
XPS 9560 4K , 1TB WD Black SSD
CPU
i7-7700HQ
Graphics
GTX-1050
Thanks for the guide. This is my first Hackintosh attempt and everything seems to be working fine. I can reboot fine without the install USB multiple times BUT if I run the kexts using kextsbeast, I can't reboot anymore. The OS get stucks while loading (after the Clover GUI). I've reinstalled the OS three times now and it does the same. Any ideas?
 
Joined
Jan 6, 2019
Messages
4
Motherboard
XPS 9560 4K , 1TB WD Black SSD
CPU
i7-7700HQ
Graphics
GTX-1050
Has anyone tried this with 10.14.2? I am unable to get 10.14.1 and stuck with 10.14.2
I got to boot fine with 10.14.2 but having issues with the kexts.
 
Joined
Jul 20, 2011
Messages
6
Motherboard
OSX
CPU
3.7
Graphics
amd hd 6870
Mac
Classic Mac
Mobile Phone
10.14.2 works ok
 
Last edited:
Joined
Oct 22, 2017
Messages
14
Motherboard
Dell XPS 15 9560 4K
CPU
i7-7700HQ
Graphics
GTX 1050 | HD 630 @ eGPU: GTX 1080
I installed it on 10.14.2 fine, but after installing all kext from other kexts folder my hackintosh wont boot... Please help

Edit: I tried another guide from blazinsmonkey and that one worked with 10.14.2.
 
Last edited:
Joined
Jan 11, 2019
Messages
23
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050
Mobile Phone
iOS
I installed it on 10.14.2 fine, but after installing all kext from other kexts folder my hackintosh wont boot... Please help

Edit: I tried another guide from blazinsmonkey and that one worked with 10.14.2.
The problem is FakeSMC in /Library/Extensions. Delete it and you're good, except that you won't see sensors data in HWMonitor.
 
Top