Contribute
Register

[Guide] Creating a Custom SSDT for USBInjectAll.kext

Joined
Oct 17, 2013
Messages
145
Motherboard
Dell Vostro 15
CPU
i5-7200U
Graphics
HD620, 1920*1080
Mobile Phone
iOS
Hi, i need an help to understand if i work correctly.

I've found the port usb3 and usb2 from IORegistryExplorer (I attach a screen).

As in the guide my usb2 is on HSxx and USB3 is on SSxx . I have 4 usb , 3 of this is also USB3.

I download the template of SSDT-UIAC-ALL.dsl and modify as reported on registry explorer. After reboot the port works but the mac reported as usb3 but with the speed of usb2 (480mb/s). If I use a usb3 pen drive on IORegistryExplorer it's active the relative port but HS and not SS.

It's correct or I have to modify other? Also , the initial patch I have to use to discovery the sub port on config.plist I can remove?
 

Attachments

Last edited:

msh

Joined
Oct 31, 2013
Messages
212
Motherboard
GA-Z97GAMING 5
CPU
i5-4690S
Graphics
RX Asus AREZ 550 2gb
Mobile Phone
Android
Hi, i need an help to understand if i work correctly.

I've found the port usb3 and usb2 from IORegistryExplorer (I attach a screen).

As in the guide my usb2 is on HSxx and USB3 is on SSxx . I have 4 usb , 3 of this is also USB3.

I download the template of SSDT-UIAC-ALL.dsl and modify as reported on registry explorer. After reboot the port works but the mac reported as usb3 but with the speed of usb2 (480mb/s). If I use a usb3 pen drive on IORegistryExplorer it's active the relative port but HS and not SS.

It's correct or I have to modify other? Also , the initial patch I have to use to discovery the sub port on config.plist I can remove?
You must sortedorder your SSDT-UIAC.aml in this case

Screenshot 2019-09-02 at 17.43.38.png
 
Joined
Oct 17, 2013
Messages
145
Motherboard
Dell Vostro 15
CPU
i5-7200U
Graphics
HD620, 1920*1080
Mobile Phone
iOS
You must sortedorder your SSDT-UIAC.aml in this case

View attachment 424208
Thank you!!! It’s worked! I’m only set this and now the usb3 it’s 5Gb/s !!!

But.... only to understand.... it’s normal to insert in order ? Or why I have to insert to load?
 
Joined
May 15, 2013
Messages
56
Motherboard
Asus Sabertooth X79
CPU
Xeon E5 1650 v2
Graphics
GT 740
I'm having USB power problems & instability on my GA-H77N-wifi board, i3-3225 3.3 ghz mini. Problem reporting files are attached. Thank you for any help.
 

Attachments

Last edited:

msh

Joined
Oct 31, 2013
Messages
212
Motherboard
GA-Z97GAMING 5
CPU
i5-4690S
Graphics
RX Asus AREZ 550 2gb
Mobile Phone
Android
Thank you!!! It’s worked! I’m only set this and now the usb3 it’s 5Gb/s !!!

But.... only to understand.... it’s normal to insert in order ? Or why I have to insert to load?
Rehabman says to do it in his guide. I can't explain why?
 
Joined
Oct 4, 2014
Messages
242
Motherboard
ASUS X299 Sage/10g
CPU
i9-10980XE
Graphics
Radeon VII
Hi, @RehabMan - I'm following your guide. FakePCIID and FakePCIID_XHCIMux kexts are causing my USB devices to completely stop working immediately on install.

10.13.6, x99

How do I troubleshoot this? Search turns up empty and I don't see this mentioned in the ReadMe.

Thanks
 
Joined
Jul 6, 2013
Messages
12
Motherboard
Gigabyte GA-Z97X-UD3H
CPU
i5-4690S
Graphics
HD 4000 / RX 570
Mobile Phone
iOS
Hi,

My system was behaving fine for quite a while and then started crashing upon waking from sleep. I had been using the port limit patch, not knowing it was not a good approach, and then found out about the USBInjectAll kext. I have built the kext, changing only the build version to 14.x, with a custom SSDT using just the (14) USB2 ports on the XCHI chip, and using -via_disable_ss to disable the (6) USB3 ports, and it still reboots when waking from sleep, after logging into an account..

I have an Apple USB keyboard with the two USB ports and am using them for both the bluetooth dongle and the logitech wireless mouse receiver. If I choose sleep from the login screen, the machine almost makes it back to the login screen, but I have an overlay on top of the login screen and have to reboot. The values for connector type on all 14 ports is a 3; 8 of them were specified as 0 in the SSDT.

I need help!

Thanks,
Sam
 

Attachments

Joined
Oct 28, 2010
Messages
131
Motherboard
Gigabyte Z390 Aorus Pro Wifi
CPU
i9-9900K
Graphics
RX570
Hi, @RehabMan - I'm following your guide. FakePCIID and FakePCIID_XHCIMux kexts are causing my USB devices to completely stop working immediately on install.

10.13.6, x99

How do I troubleshoot this? Search turns up empty and I don't see this mentioned in the ReadMe.

Thanks
Rehabman has not been active for several months.
 
Joined
Oct 4, 2014
Messages
242
Motherboard
ASUS X299 Sage/10g
CPU
i9-10980XE
Graphics
Radeon VII
Thanks. I'll go to the Hackintool thread for help on that

When you are near your machine, can you tell me re the PR11 and PR21 should they be showing on EH01/02? - I'm really trying to get an answer on this and any help is appreciated
Hi there @Humanate - did you ever find an answer? I am seeing the same thing.
 
Top