Contribute
Register

GTX 960 with Yosemite 10.10.2 only partially working

Joined
Mar 2, 2015
Messages
31
Motherboard
ASUS H97M+
CPU
i5 4590
Graphics
Asus Strix GTX 960
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
Mobile Phone
Symptoms

Everything seems to work fine until I try to do something graphics intensive. Unigine Valley Benchmark crashes upon hitting Run and right after the assets load. Same with the game Bastion, except it doesn't crash, it just hangs in a loading zone. Side notes: (1) I haven't gotten my audio to work yet, (2) I'm quite sure that my integrated graphics isn't working at all because my computer was in slideshow mode (laggy) until I installed the graphics card, and (3) I got the black screen problem when I tried repairing my SSD and repairing permissions on my SSD using Disk Utility – I eventually got it to boot again using the -no-zp flag but had to redo all my post installation drivers to get to my original stability.

My Installation

This is my first time doing hackintosh and the 960 seemed enticing. Here's my build:
Intel i5 4590
ASUS H97M PLUS
850 EVO SSD
ASUS STRIX GTX 960

To install Yosemite 10.10.2, I used unibeast. I followed the guide and did as it said with the BIOS settings. I finally got it to boot with the following flags: GraphicsEnabler=Yes PCIRootUID=1 -x -v
To make the SSD bootable (instead of the flash drive), it took a few trial and error tries with MultiBeast, but I eventually got it to work. It seems the PCIRootUID fix was essential. I'll upload the file .mb file when I get home if that will help.

To install my graphics card I followed the popular 750TI guide where you just add nvda_drv=1 to the kernal flags, installed the latest webdriver 343.02.02f02 , and set my BIOS to the PCIE for display. There wasn't an option to turn off integrated graphics in the BIOS.

Help? Can anyone spot where I may have gone wrong? Any tips at all would be much appreciated! I'll be sure to post a build success when I'm ready.
 
Joined
Mar 2, 2015
Messages
31
Motherboard
ASUS H97M+
CPU
i5 4590
Graphics
Asus Strix GTX 960
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
Mobile Phone
Here's my chameleon boot plist:
Code:
<?xml version="1.0" encoding="UTF-8"?><!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>EthernetBuiltIn</key>
    <string>Yes</string>
    <key>GraphicsEnabler</key>
        <string>Yes</string>
    <key>IGPEnabler</key>
    <string>Yes</string>
    <key>Kernel Flags</key>
        <string>kext-dev-mode=1 PCIRootUID=1 -v nvda_drv=1</string>
    <key>Legacy Logo</key>
    <string>Yes</string>
    <key>Timeout</key>
    <string>2</string>
        <key>HDEFLayoutID</key>
        <string>01000000</string>
        <key>UseKernelCache</key>
        <string>Yes</string>
        <key>HDAEnabler</key>
        <string>Yes</string>
</dict>
</plist>

And my multibeast settings:
Quick Start > Easy Beast
Drivers > Audio > Realtek ALCxxx > ALC887/888b Current v100302
Drivers > Disk > 3rd Party SATA
Drivers > Misc > ElliotForceLegacyRTC
Drivers > Misc > EvOreboot
Drivers > Misc > FakeSMC v6.14.1364
Drivers > Misc > NullCPUPowerManagement
Drivers > Misc > USB 3.0 - Universal
Drivers > Network > Intel > AppleIntelE1000e v3.1.0a
Bootladers > Chimera v4.0.1
Customize > Boot Options > Basic Boot Options
Customize > Boot Options > GraphicsEnabler=Yes
Customize > Boot Options > Kext Dev Mode
Customize > Boot Options > PCI Root ID Fix
Customize > Boot Options > User KernelCache
Customize > Boot Options > Verbose Boot
Customize > System Definitions > Mac Pro > Mac Pro 3,1
Customize > Themes > tonymacx86 Black

I tried Repair Disk Permissions again and it would restart to black screen again. It only lets me boot if I add the no-zp option. Here's what Disk Utility says
Repairing permissions for "SSD"
User differs on "private/var/db/displaypolicyd"; should be 0; user is 244.
Group differs on "private/var/db/displaypolicyd"; should be 0; group is 244.
Repaired "private/var/db/displaypolicyd"

Permissions repair complete
 
Joined
Mar 2, 2015
Messages
31
Motherboard
ASUS H97M+
CPU
i5 4590
Graphics
Asus Strix GTX 960
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
Mobile Phone
Success! Finally installed 10.10.2 and Windows 8.1 with the 960 working pretty fully. My process:
Used the Windows installer to repartition my SSD
Installed Windows 8.1
Followed the steps on post #13 by my savior, RehabMan here to fix the EFI partition so that Disk Utility can use it
Installed OS X following a combination of two 960 guides: TylerWorth's and spballer's

IMPORTANT: I originally tried to install without my graphics card plugged in, just using my internal graphics (intel HD 4600) which weren't working at all. This caused me to add boot flags that, in the end, I did NOT need. For one, GraphicsEnabler should be no. Secondly, iMac 14,2 helped me boot up instead of Mac Pro 3, 1. My final benchmark results will be posted in the main 960 thread.
 
Joined
Feb 9, 2015
Messages
81
Motherboard
MSI Z97 Gaming 7
CPU
i5-4460 3.2 GHz
Graphics
Asus Strix GTX 960 2GB
Mac
Classic Mac
Mobile Phone
  1. Android
Code:
<?xml version="1.0" encoding="UTF-8"?><!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>EthernetBuiltIn</key>
    <string>Yes</string>
    <key>GraphicsEnabler</key> *//Shouldn't be needed for Intel
        <string>Yes</string> //*
    <key>IGPEnabler</key> *// Shouldn't Need, is for Graphics injection on older cards. Not the one you have
    <string>Yes</string> //*
    <key>Kernel Flags</key>
        <string>kext-dev-mode=1 PCIRootUID=1 -v nvda_drv=1</string> *// Remove "PCIRootUID=1" "nvda_drv=1" Will do this I believe
    <key>Legacy Logo</key> *// Shouldn't be needed
    <string>Yes</string> //*
    <key>Timeout</key>
    <string>2</string>
        <key>HDEFLayoutID</key>
        <string>01000000</string>
        <key>UseKernelCache</key>
        <string>Yes</string>
        <key>HDAEnabler</key>
        <string>Yes</string>
</dict>
</plist>

And multibeast Yosemite 7.2.0

I choose this setting for Multibeast :
Quick Start > DSDT Free
Drivers > Audio > Realtek ALCxxx > ALC887/888b Current v100302
Drivers > Audio > Realtek ALCxxx > Intel 9 Series Motherboard Support
Drivers > Disk > 3rd Party SATA
Drivers > Disk > Intel Generic AHCI SATA < You don't need this unless your Bios doesn't support this I believe >
Drivers > Disk > TRIM Enabler > 10.9.4+ TRIM Patch
Drivers > Graphics > Intel 9 Series HD 4600 Graphics Fix
Drivers > Misc > FakeSMC v6.9.1315
Drivers > Misc > USB 3.0 - Universal
Drivers > Network > Intel > AppleIntelE1000e v3.0.4.1a
Drivers > System > AppleRTC Patch for CMOS Reset only need if you get a CMOS reset issue and have to redo your setting each time you boot in bios
Bootloaders > Chimera v3.0.1 <there will be a higher version then this>
Customize > Boot Options > Basic Boot Options
Customize > Boot Options > Generate CPU States
Customize > Boot Options > Hibernate Mode - Desktop
Customize > Boot Options > Use KernelCache
Customize > Boot Options > 1080p Display Mode
Customize > System Definitions > Mac Pro > Mac Pro 14,2
Customize > Themes > tonymacx86 Black


The multibeast was taking from an older thread with changes since the newest version has these built in unless stated otherwise. If you don't have a stable build I would attempt these setting honestly. Read the .plist code to find *// //* comment in theme that should be changed.
 
Joined
Mar 2, 2015
Messages
31
Motherboard
ASUS H97M+
CPU
i5 4590
Graphics
Asus Strix GTX 960
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
Mobile Phone
TylerWorth,

Sorry, all my mb settings and plist code has changed since the original post but thanks for the help! My plist is exactly yours, but my mb config is a little different. For one, I added in the FakeSMC plugins and HWMonitor app which does not work for my 960. I do have the strangest error though: I can't boot unless I interrupt the process so that I can type in extra args, but I don't type any more in I just hit enter. I do get these errors though right before it goes to my desktop:
GeForceSensors unknown / unsupported chipset
getCPUIDInfo: this is an unknown CPU model 0x3c
power management may be incomplete or unsupported.

The first error is because (educated guess) the FakeSMC/HWMonitor kexts can't yet identify the 960, so I'm anticipating an update. But you mentioned that your HWMonitor can see your 960's temp?? The latter error I'm not sure, but does this mean I need the NullCPUPowerManagement driver?
Screen Shot 2015-03-07 at 2.01.05 AM.png
Thanks!
 
Joined
Feb 9, 2015
Messages
81
Motherboard
MSI Z97 Gaming 7
CPU
i5-4460 3.2 GHz
Graphics
Asus Strix GTX 960 2GB
Mac
Classic Mac
Mobile Phone
  1. Android
TylerWorth,

Sorry, all my mb settings and plist code has changed since the original post but thanks for the help! My plist is exactly yours, but my mb config is a little different. For one, I added in the FakeSMC plugins and HWMonitor app which does not work for my 960. I do have the strangest error though: I can't boot unless I interrupt the process so that I can type in extra args, but I don't type any more in I just hit enter. I do get these errors though right before it goes to my desktop:
GeForceSensors unknown / unsupported chipset
getCPUIDInfo: this is an unknown CPU model 0x3c
power management may be incomplete or unsupported.

The first error is because (educated guess) the FakeSMC/HWMonitor kexts can't yet identify the 960, so I'm anticipating an update. But you mentioned that your HWMonitor can see your 960's temp?? The latter error I'm not sure, but does this mean I need the NullCPUPowerManagement driver?
View attachment 129365
Thanks!


Nice i am glad I had some of the right stuff. I didn't select the Fake plugin's for you because I was not thinking haha. But i Can tell you my Temps are not shown in the HWMonitor. I am still to assume the next update will fix this and I am anxious for that. I believe once that happens Ill be at 100%. I did not see a unknown GPU in my boot, it also goes to fast but I do have the power management may not be supported and I am still researching this as well! if anyone can shed some light that would be awesome!
 
Top