Contribute
Register

Fix NVIDIA Web Driver in macOS Sierra 10.12.6

Status
Not open for further replies.
Joined
Feb 17, 2013
Messages
3
Motherboard
ML
CPU
corei5
Graphics
HDintel
Mac
Classic Mac
Mobile Phone
Yes, you need to Edit the "Distribution" file within the package using the Flat Package Editor.
If you adjusted and updated the "Distribution" file and package correctly you will be able to install the Nvidia Web Drivers.
After you installed the Nvidia Web Drivers modify the NVDAStartupWeb.kext to force the older drivers to load.
See https://www.tonymacx86.com/threads/...2-3-16025a-beta-releases.212798/#post-1420204

I just do it. Really I can install the driver but now I have this message:

Captura de pantalla 2017-07-20 a las 21.07.42.png

Captura de pantalla 2017-07-20 a las 21.23.25.png
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,445
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
I just do it. Really I can install the driver but now I have this message:
Did you modify the NVDAStartupWeb.kext?
If you did, select NVIDIA Driver Manager > Graphics Drivers > NVIDIA Web Driver and reboot
 
Joined
Jul 20, 2017
Messages
5
Motherboard
Mac Pro 4,1 flashed to 5,1
CPU
8 core Xeon 2.93GHz
Graphics
NVidia GTX 1080
Mac
  1. Mac Pro
When we try and to fix this with the suggested terminal commands... there are a long series of operations which say "Operation not permitted" over and over and over again.

Is this a clue as to why the commands are not working for us?
Anyone?
I notice you are using a Mac Pro.... I've got the exact same problem and I'm also running on a genuine Mac Pro tower..... I'm wondering if this fix is only working for people running Hackintoshes?

j9.
 
Joined
Jul 20, 2017
Messages
6
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
I notice you are using a Mac Pro.... I've got the exact same problem and I'm also running on a genuine Mac Pro tower..... I'm wondering if this fix is only working for people running Hackintoshes?

j9.
could be...
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,445
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
When we try and to fix this with the suggested terminal commands... there are a long series of operations which say "Operation not permitted" over and over and over again.

Is this a clue as to why the commands are not working for us?
Anyone?
Did you disable SIP (System Integrity Protection)?
 
Joined
Feb 17, 2013
Messages
3
Motherboard
ML
CPU
corei5
Graphics
HDintel
Mac
Classic Mac
Mobile Phone
Did you modify the NVDAStartupWeb.kext?
If you did, select NVIDIA Driver Manager > Graphics Drivers > NVIDIA Web Driver and reboot

Ok. I just do it. Now the Nvidia web driver is up but the system don't detect correctly my gtx950.

Captura de pantalla 2017-07-20 a las 21.54.10.png
Captura de pantalla 2017-07-20 a las 21.53.37.png
Captura de pantalla 2017-07-20 a las 21.54.33.png
Captura de pantalla 2017-07-20 a las 21.55.29.png
I've Asus vx279 21,5".

Thx helping me
 
Joined
Jul 20, 2017
Messages
5
Motherboard
Mac Pro 4,1 flashed to 5,1
CPU
8 core Xeon 2.93GHz
Graphics
NVidia GTX 1080
Mac
  1. Mac Pro
Did you disable SIP (System Integrity Protection)?
That's one thing I didn't try that did actually occur to me too late in the day. (my machine is at my workplace and I'm at home now so can't try it until tomorrow).... Filet, perhaps you can try this and let us (me) know?
 
Joined
Jul 20, 2017
Messages
6
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Well...after turning off the SIP and restarting immediately brought the card back from the dead. But...do I have to keep the SIP off permanently? (or at least until there's a new driver)?
 
Joined
Dec 31, 2013
Messages
154
Motherboard
Z97
CPU
i7-4770K
Graphics
GTX 1070
Mobile Phone
  1. Android
It didn't work for me... Maybe it depends on Sys Def.. I'm using iMac14,2
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,445
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
Well...after turning off the SIP and restarting immediately brought the card back from the dead. But...do I have to keep the SIP off permanently? (or at least until there's a new driver)?
Until there's a new driver.
 
Status
Not open for further replies.
Top