Contribute
Register

Asus X299 - Support

Joined
Apr 22, 2012
Messages
35
Motherboard
Asus Rog Rampage VI Extreme Omega X299
CPU
i9-10920X
Graphics
Radeon VII
@Shlonakzeen , I saw and read your severals post about your XHCI issue, I uploaded yours EFI but I was working on an other subject.
Unfortunately your work did not paid, but perhaps for some reasons.
There are many many kexts on your EFI folder, and I suspect there are not all useful.
So may you must start from scratch and adopt only the necessary kext to have your system working.
As you can see on the screen shot above on my fully working configuration there are not so many kexts;
You must start with only XHCI-X299-series-injector.kext and also add I your config.plist on USB :
AddClockID --->Yes
FixOwnership ---> Yes
Inject ---> Yes
Here are the tow kexts I use , see what happen with HCI-X299-series-injector.kext and after with ASUS-X299-XHCI.kext together .
it's late tonight here tomorrow I'll take a look at your progress.

View attachment 447958

Edit :
-
you must also verify your bios settings for USB/XHCI
- just keep on Acpi patched the SSDTs that are correctly loaded
Hi
many thanks for your kind efforts and time
I have slimmed down kexts , and SSDTs and tried your USB kexts but couldn't get any ports under XHCI@14
Asus Rog Omega latest BIOS has no option under USB configuration to enable XHC Handoff . There is an option of ( mouse and keyboard simulation - enable / disable ) I tired on both setting no luck , with it enabled it makes mouse very un responsive.

As it is new build , it is running Windows 10 Pro smoothly and all USB ports working there. So its not a hardware issue , I guess .
My BIOS setting is copy past of KGP guide

Don't know what to do else ?
 
Joined
Mar 18, 2017
Messages
735
Motherboard
Asus Prime X299 Deluxe
CPU
i9-7940X
Graphics
2x Vega 56
Mac
iMac, Mac mini
Mobile Phone
iOS
Hi
many thanks for your kind efforts and time
I have slimmed down kexts , and SSDTs and tried your USB kexts but couldn't get any ports under XHCI@14
Asus Rog Omega latest BIOS has no option under USB configuration to enable XHC Handoff . There is an option of ( mouse and keyboard simulation - enable / disable ) I tired on both setting no luck , with it enabled it makes mouse very un responsive.

As it is new build , it is running Windows 10 Pro smoothly and all USB ports working there. So its not a hardware issue , I guess .
My BIOS setting is copy past of KGP guide

Don't know what to do else ?
realy perplexing your issue : Some users have reported it is working look here #8
 
Joined
Jul 20, 2014
Messages
503
Motherboard
X299 Creator
CPU
i9-10900X
Graphics
RX 5700 XT
Tracing back to Kgp guide :

It is recommended to put the Thunderbolt on PCIE16_2 slot :
Hello
I think Thunderbolt on PCIE16_2 slot is recommended for X299 Sage/10G but may be not all Mobo. Non?
Thanks for your effort on Thunderbolt !!
Much appreciate
 
Joined
Mar 18, 2017
Messages
735
Motherboard
Asus Prime X299 Deluxe
CPU
i9-7940X
Graphics
2x Vega 56
Mac
iMac, Mac mini
Mobile Phone
iOS
Hello
I think Thunderbolt on PCIE16_2 slot is recommended for X299 Sage/10G but may be not all Mobo. Non?
Thanks for your effort on Thunderbolt !!
Much appreciate
Yes, you're right : I'm bad here: for Prime Deluxe : PCIE16_3 : I will edit. ( just checked on DSDT)
 
Joined
Nov 20, 2013
Messages
116
Motherboard
Asrock X299 TAICHI XE
CPU
i9 7940x
Graphics
Nvidia GTX 1080 TI FE
Mac
iMac, Mac Pro
Classic Mac
iMac
Mobile Phone
Android
Anyway, the motherboard though doesn't seem to be a good fit for a XE processor, thus I am shopping for something else and I have realized how difficult the old gen x299 are difficult to find. I have spotted an used Asrock Taichi XE, but I could not find much online about its compatibility with MacOs. Should I get it or stick to Asus?
I have 2 Taichi XE boards, one with 7940x and the other with 9900x. Running fine on Mac OS 10.13.6
HS cause I am on NVIDIA GPU. The board is good for X299, but be careful buying used one.
 
Joined
Feb 17, 2011
Messages
87
Motherboard
ASUS X299 Prime Deluxe
CPU
i7-7820X
Graphics
ASUS Strix Vega 64
Mac
MacBook Pro
Mobile Phone
iOS
Hi there!
I'm using my machine with 10.14.6 at the moment and everything is running fine. What do I have to consider if I want to upgrade to Catalina? Are there any known issues?
 
Joined
Apr 22, 2012
Messages
35
Motherboard
Asus Rog Rampage VI Extreme Omega X299
CPU
i9-10920X
Graphics
Radeon VII
realy perplexing your issue : Some users have reported it is working look here #8
Hi
After refreshing BIOS and clean install , Hackintool can now pick up USB 3.1 gen2 ( although different USB controller ). However , XHCI still not activated and not showing ports as per IOReg

Thanks
 

Attachments

Last edited:
Joined
Apr 17, 2012
Messages
98
Motherboard
Asus X299 Prime Deluxe
CPU
i9-7960x
Graphics
Vega 56
For our X299 platform, some progress has been made to have Thunderbolt fully working, but at the moment we still can't see the partially materialized Thunderbolt device tree.
Intensive work has been done here Thunderbolt Volunteers Needed and here TEST BENCH: Thunderbolt Interim Update by @CaseySJ and also by @Elias64Fr ( if i can be allowed to cite their hard work here ).

So to the rest of my post all credits have been mentioned above :

I tried to adopt their SSDT for my X299 configuration :

For the moment has I mentioned we still can't see the partially materialized Thunderbolt device tree :

View attachment 447897

But the problem remains here :

View attachment 447867

View attachment 447868

Here, the IOReg is as expected :
View attachment 447869

In DBS2 too :

View attachment 447870

If there are volunteers here to try to continue the work, they are welcome.

I share here the SSDT adopted from the thread I mentioned (my Thunderbolt is on RP17)
Just want to thank you for all of your hard work! I'll be following along. Not sure what I can do to help - I am intermediate with SSDT's at best - but with some instruction, I would love to contribute!
 
Joined
Apr 17, 2012
Messages
98
Motherboard
Asus X299 Prime Deluxe
CPU
i9-7960x
Graphics
Vega 56
Has anyone attempted a W-3175x build out of curiosity?
I wonder how much it would differ from a KGP build...
 
Joined
Mar 29, 2011
Messages
711
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
Has anyone attempted a W-3175x build out of curiosity?
I wonder how much it would differ from a KGP build...
I think the main difficulty is usually an MSR lock. Not insurmountable, though. Perhaps the X11SRM would be a good choice.

C621 is close enough to X299 to use KPG's guide, I think. And any Xeon W is probably a better choice than the other LGA3647 options (i.e., avoid Skylake-SP).
 
Top