Contribute
Register

An iDiot's Guide To iMessage

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,496
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Joined
May 20, 2020
Messages
2
Motherboard
Dell
CPU
i5-4300u
Graphics
Intel HD
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Thought I'd post my experience on this. New to hackintosh, followed this to the tee, but I kept getting that code issue. I don't understand why some people don't have this problem, but I did. Anyhow, I rang Apple for support and it took three technicians to get to where they would allow access to my account. I'm assuming it means the code couldn't be found with known serials and that it is whitelisted on my Apple ID. What is interesting is I did this on a Friday and it wasn't until Tuesday that it started working. The troubleshooting they wanted me to do was ridiculous.

Apple: "Upgrade to Catalina"
Me: "uh, I don't know how to that, it's beyond my area of expertise"
Apple: "Create a new user and try that"
Me: Long pause. "Didn't work"
Apple: "Try signing into another device"
Me: "Yeah, works on my other MacBook and iPhone"
Apple: "Let me escalate"

In the end, it eventually worked. Even with a screenshot of my unknown serial. Just play dumb and follow their script. Wasted an hour and a half of my life. LOL.
 
Joined
Sep 28, 2014
Messages
41
Motherboard
AsusTek Z10PE-D16-WS
CPU
2x E5-2697v3
Graphics
RX 5700XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Centris
  2. Performa
  3. Power Mac
  4. Quadra
Mobile Phone
  1. Android
  2. iOS
Finally got it working using this thread!! Thanks.
All was fine except my Ethernet was not “Built in” for a change.
Unchecked FixLAN in CloverCfg, killed connections and started again. en0 built in, didn’t get chance to log into iMessage, it just did it on boot. Sweeeeet. Thanks again.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,496
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Hello everyone i am new to hackintosh community i have successfully installed mac os catalina on my dell e6440 i7 4610M and i cloud app store are working fine but i am not able to use imessage and face time by following this guide o was able to get inside imessage but after that it asked my to sign in again saying your imessage account is not signed in and after that i got

This is not intended as a help thread, requests for help will be deemed off-topic and removed.
For help with iMessage refer to the comprehensive How to Fix iMessage Guide thread.
 
Joined
Jan 8, 2019
Messages
6
Motherboard
Dell - Need model # > See Rules
CPU
i5-3475S
Graphics
RX 470
If the two copies are the same you may reconnect to the network and proceed to set up iMessage.
Is there an error in the guide? I didn't find the part where you had to disconnect from the network. I also followed the guide, but iMessage still doesn't work.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,496
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Is there an error in the guide? I didn't find the part where you had to disconnect from the network.

Screenshot 2020-12-15 at 21.31.27.png



I also followed the guide, but iMessage still doesn't work.

You and the many others like you are the reason why I no longer write guides.

The Guide said:
This is not intended as a help thread, requests for help will be deemed off-topic and removed.
For help with iMessage refer to the comprehensive How to Fix iMessage Guide thread.

Please read and comply with the rules, in particular the one regarding profiles.
Link to profile - Just three items - Motherboard (or prebuilt system), Processor (CPU) and Graphics.
 
Joined
Apr 17, 2020
Messages
10
Motherboard
HP EliteBook 840 G3
CPU
i5-6300U
Graphics
HD 520
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
This guide is outdated, we are in 2021, current macOS version 11.1 and Clover is deprecated and OpenCore is the current EFI tool. Should someone create or edit this guide on 2021 tools?
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,496
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Should someone create or edit this guide on 2021 tools?
Feel free to go ahead with that.

The OpenCore instructions include details of how to set up for Apple services.
 
Joined
Jun 15, 2015
Messages
78
Motherboard
MSI Z170A Krait
CPU
i7-6700K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Guys...I think I've found the last puzzle...

Through all these years, I've only activate iMessage twice.
One time it worked for no reason, but later after few months it stopped to work again.
Another time was that I tried with my real iMac 2011 SN/MLB/UUID, it worked immediately.
But I kinda feel it unsafe for my iMac and improper to use that old SMBIOS for my skylake system.

Anyhow, I've been following this tutorial and many others such as using MAC address as last 12 digits of UUID.
But none of them works.
So I've been wondering, this ain't some difficult guide. Why there are there people reporting working while others come up with totally opposite story.
Until last week, my client sent me an invoice pic through iMessage to my iPhone.
iMessage is not that popular in my country and I was previously a dedicated Android user.
That was the very first time me using iMessage with other people with real Apple device.

Strange thing happened few days after, when I logged in my newly built Hack, iMessage started to work!
I was in disbelieve so I proceeded to log in my XPS 9570 Hack, another success!
What surprised me is that my XPS is not even using a broadcom wireless card.
It is an Intel AX200 patched by AirportItlwm.kext. Everything just suddenly starts to work.
I didn't clear log cache, no Apple ID log out/in.
My SN code was straight randomly created with OC configurator.
I didn't even regenerate them before trying to log in my XPS and I'm sure it failed previously.

So if anyone never success and always comes up with customer service code.
Try log in your Apple ID on a real Apple device then use iMessage or FaceTime service with other device with different ID.(Maybe requires that ID has working iMessage)
I'm guessing maybe what we've been missing is that randomly generated ID needs to be certified by Apple server.
Doing above process is one way.
Real Apple SN codes were already certified in factory so they always work.
And I believe many of Hack users were Android only users like I used to be or just never use iMessage.
Hope my experience helps.
 
Top