Contribute
Register

AMD RX580

Status
Not open for further replies.
Joined
Oct 15, 2011
Messages
965
Motherboard
ASUS Gryphon Z87
CPU
i7-4770K
Graphics
HD 4600 & RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Apple
Joined
Dec 23, 2013
Messages
112
Motherboard
ASRock Z370M-iTX/ac
CPU
i5-8400
Graphics
RX570
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
i have intentionally removed some parts of the SMBIOS (serial...)

I don't use the CPU Video at the moment.
I am not too sure why but I don't think I can help you. Maybe someone here who has more experience with using both igfx and a 580 can better help you, sorry.

I only have some knowledge with using AMD video cards.
 
Joined
Oct 15, 2011
Messages
965
Motherboard
ASUS Gryphon Z87
CPU
i7-4770K
Graphics
HD 4600 & RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Apple
I am not too sure why but I don't think I can help you. Maybe someone here who has more experience with using both igfx and a 580 can better help you, sorry.

I only have some knowledge with using AMD video cards.
I don't use the onboard iGPU. I just use the Sapphire RX580 Nitro+

I am curious:
What is you setup ?
do you use any Graphic related Kext ?
Is sleep fully working ?

@ ALL why do you use sleep at all on a desktop maschine?
computers boot that fast these days ?
 
Joined
Dec 23, 2013
Messages
112
Motherboard
ASRock Z370M-iTX/ac
CPU
i5-8400
Graphics
RX570
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I don't use the onboard iGPU. I just use the Sapphire RX580 Nitro+

I am curious:
What is you setup ?
do you use any Graphic related Kext ?
Is sleep fully working ?

@ ALL why do you use sleep at all on a desktop maschine?
computers boot that fast these days ?
My setup is in my sig/profile. That will be changing this week though.

I use the Sapphire RX570 Nitro+ and sleep fully works. I use both Lilu and WhateverGreen kexts in my EFI/Kexts/Other folder (the latest ones).
 
Joined
Aug 26, 2011
Messages
44
Motherboard
Asus Z9PE-D8 WS
CPU
2x E5-2667 v2
Graphics
Vega 64 Liquid Cool
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
First you simple need to enable radeon DeInit.

The official apple driver fully supports rx580 only with part numbers 113-4E353BU-O4E or 113-4E3531U-O4V . So if you have this card you lucky man cos apple support this card by their eGPU Developer Programm. If not you need to simple fake your card ass officail supported:
The easiest way (not required flashing) is dump your video bios (clover,atiwinflash etc.) then open it with Hex editor to find your id (f.e. is mine is 113-1E3660U-05R) : Снимок экрана 2018-02-04 в 21.33.14.png
we need only first two parts:113-1E3660U, and convert it to base64 : (here https://conv.darkbyte.ru,mine is MTEzLTFFMzY2MFU= ) . Original id presented in ATI9500Controller.kext binary is 113-4E353BU( base64 MTEzLTRFMzUzQlU= ) so let make kext patch for clover :
Code:
<dict>
                <key>Comment</key>
                <string>RX 580 Identification</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                MTEzLTRFMzUzQlU=
                </data>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Name</key>
                <string>AMD9500Controller</string>
                <key>Replace</key>
                <data>
                MTEzLTFFMzY2MFU= <<Here you need to insert your id in base64.
                </data>
            </dict>
This patch also can be applied to another Polaris 20 card (470,480,570,580). The result is
Снимок экрана 2018-02-04 в 21.53.12.png . Have grate sore in compute :
https://browser.geekbench.com/v4/compute/1962358
 

Attachments

  • Снимок экрана 2018-02-04 в 21.33.14.png
    Снимок экрана 2018-02-04 в 21.33.14.png
    9.9 KB · Views: 537
Last edited:

BoomR

Moderator
Joined
Dec 18, 2011
Messages
1,260
Motherboard
Gigabyte Z490 VISION D
CPU
i9-10850K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Apple
  2. Performa
  3. Power Mac
  4. Quadra
Mobile Phone
  1. Android
The easiest way (not required flashing) is dump your video bios (clover,atiwinflash etc.) then open it with Hex editor to find your id (f.e. is mine is 113-1E3660U-05R)

Thanks for sharing this great tip. Is there any chance you could share "exactly" how you dumped your video bios? What method did you use? For example, how does someone dump their video bios using Clover? Do you use UEFI shell & then some shell command to do this?

I have Gigabyte AORUS RX580 with 8GB. It works perfect out of the box, but it would be nice to have this showing properly in "About this Mac" - mine currently shows this:
Aorus RX580.png

Thanks for your help!
--B
 
Joined
Aug 26, 2011
Messages
44
Motherboard
Asus Z9PE-D8 WS
CPU
2x E5-2667 v2
Graphics
Vega 64 Liquid Cool
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thanks for sharing this great tip. Is there any chance you could share "exactly" how you dumped your video bios? What method did you use? For example, how does someone dump their video bios using Clover? Do you use UEFI shell & then some shell command to do this?

I have Gigabyte AORUS RX580 with 8GB. It works perfect out of the box, but it would be nice to have this showing properly in "About this Mac" - mine currently shows this:
View attachment 310966

Thanks for your help!
--B
I used atiwinflash in windows. You can tap F1 at clover disk selection and it has button for dump ( i am forgot,may be F7). And it will dump it to EFI/CLOVER/ROMS
 
Joined
Aug 26, 2011
Messages
44
Motherboard
Asus Z9PE-D8 WS
CPU
2x E5-2667 v2
Graphics
Vega 64 Liquid Cool
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Excellent - I will look into this. BTW, I wonder if I use a different system definition if I would get better GB results? I am using iMac 18,3, and my score with RX580 is about 10,700 under your score:
https://browser.geekbench.com/v4/compute/1962419
I think fake id will upgrade your score. For system definitions I don't know. I am using mac pro because of the same chipset.
 
Joined
Jan 22, 2018
Messages
37
Motherboard
Asus z370f
CPU
i7 8700k
Graphics
rx 580
I can't make rx 580 Asus work any help ...only with igpu all work perfect..when I change to pcie apple logo stuck and reboot
 
Status
Not open for further replies.
Top