Contribute
Register

[90% Success] El Capitan AsRock H97M-ITX w/ GTX 960 - Troubleshooting a Variety of Small Issues

Joined
Dec 8, 2015
Messages
3
Motherboard
Asrock H97M-ITX
CPU
Intel Core i5-4690
Graphics
Asus GTX 960
Mac
MacBook Pro
Classic Mac
Mobile Phone
Hey guys, so I've been interested in Hackintoshes for quite a while, and a mac user from practically the womb. Anyways, after much research (and achieving a relatively stable income), I embarked upon my first hackinmac. I was actually really surprised on how little issues I've had, especially since I got highly-functionable Hack out of my first try.

Here are my parts again:

Mobo: ASRock H97M-ITX/AC LGA 1150
CPU: Intel Core i5-4690
Memory: 1 stick of 8GB Crucial Ballistic DDR3 1600 MHz
Graphics: Asus GeForce GTX 960 2GB
Storage: Samsung 850 EVO 120 GB SSD
Case: Fractal Designs Core 500

Here I'll try to remember, to the best of my ability, what I did to get this first install going: I fiddled with a few boot args and I can't promise an exactly correct, step-by-step guide:

1. Used UniBeast to create a UEFI Capitan installer without any injection or any other modifications on a 16gb USB.
2. Disconnected GPU from PCI slot.
3. Plugged USB into USB 2.0 slot on Mobo (though I don't recall ever having issues with it in a 3.0 slot subsequently)
4. Booted into ASRock UEFI. Disabled virtualization (It's under advanced settings>CPU). Selected Clover as the first boot device (there were four, identical clover options listed in the UEFI for some reason, I just picked the first one). I think these were the only two things I had to change... I think.
5. Rebooted. Clover popped up. Here's where my memory gets shady, and if I do a fresh install, I'll make sure to take better notes. Without any args, I got a KP within a few seconds of the Mac installer starting up (in the black screen before language selection). I believe the only two args I added next were -no-zp and nv_disable=1 (though with my GPU removed, I don't even know if that was necessary).
6. Formatted my SSD with Disk Utility following standard settings.
7. Installed OSX w/o any hiccups.
8. Rebooted and selected boot from HFS drive in clover.
9. I can't remember if I got a KP in my first boot from the SSD.
10. Here is what I remember running through MultiBeast:
  • UEFI Boot Mode
  • Realtek ALC892
  • Fake SMC, Plugins and HWMonitor
  • Atheros E2200 Ethernet
  • Clover UEFI
  • iMac 14,2 System Definition (from this guide)
11. Tried to change UEFI to boot from Mac OS X. Got the "Please insert a boot device" black screen.
12. Rebooted and changed back to using USB Clover.
13. Everything was working at this point, besides Audio and Clover. Downloaded NVIDIA Web Drivers and installed them.
14. Shut down and plugged in GTX 960.
15. Rebooted, no issues with GPU (though when I did a test game of League later that day, I got some really bad FPS loss and stuttering halfway through a game? A later game had no issues...)

At this point I was feeling pretty good, and since this is a new computer, I wanted to go ahead and get Windows installed so I'd have a stable OS to revert to as I tried to perfect my Mac install. And this is where things started going down the ****ter.

I have a Windows 7 iso on my old laptop, so I burned this using Boot Camp to another USB. I tried to reboot and when I selected the UEFI on my USB I got the black, blinking underscore screen of death. Thinking this might have been an issue with the .iso, I tried another one, once again making it from my MBP. Tried again to boot it up, no such look. At this point, I went back to boot to OS X from my Unibeast USB and, oddly enough, clover read three different Windows boots on the other USB (Windows Install, Windows efimgr [I think that's what it was], and Windows CD boot). My Mobo UEFI never had any of these as boot options... I tried all three. The Windows install went back to blinky, black death screen (no luck even when I let it sit for 15 minutes), Windows efimgr didn't launch anything and Windows CD boot asked me to press any key and then nothing happened, even after waiting for a long time again.

Then, I tried burning a new Windows .iso from my Hack (since I had to fiddle with some .plists on my MBP to get it to burn to a USB). Rebooting into this, I ran into the exact same issues as before: no detection by my Mobo and same three options in Clover. No luck on booting into the Window installer.

So, there's my first big problem: I can't install Windows. This might be completely unrelated to Hackintoshing... but if anyone has any ideas, let me know. I've tried changing a variety of things in my BIOS (legacy USB support, moving the USB to another port) and I've tried three separate .isos confirmed to boot from other PC's. Currently I'm trying to burn into the USB I originally had Capitan on.

After trying all day to get Windows installed, and failing spectacularly, I decided to spend some time fixing some of my Hack issues. After trying some of the basic methods to fix my install of Clover onto my EFI (copying and pasting from my USB, manually downloading and installing in on my Hack) I found Donkey's post about multiple ASRock mobo's having this problem. So, I downloaded Mint Linux and used unetbootin to put it onto the USB my Windows install was previously on. I rebooted and... the beast of the first problem came back. I can select the USB's UEFI as a boot option on my BIOS, but it boots to the same black, blinking cursor of death.

So, here's my list of things that are not working:

  • Audio (Realtek AC892) - MultiBeast nor the script from the Big List of Solutions worked
  • Wifi Card (though I'm not that concerned about this yet)
  • Booting w/o USB (the big one)
  • Installing other OS's (once again, not the focus of this website, but any help would be greatly appreciated)

I've got some other stuff I'm going to try, but if anyone has some tips, I'd greatly appreciate them.

I'm gonna try the following solutions and I'll be sure to update this post with their results:

  1. The other ALC script
  2. Putting windows on the other USB. If that works then I'll also try putting the Linux .iso on there too to fix my Clover boot.
  3. I guess if the previous doesn't work, I might need to start from scratch and do a fresh install as well as resetting my mobo. At least that way I'll actually be able to offer specific instructions for others trying to do a similar build!

Update 1: Swapping USB's did not work. Is this because when you make a windows install using boot camp, it's only bootable from a mac? Wondering if I should try to make the usb using just Disk Utility and not Boot Camp using GPT and FAT. Guess that's what I'll try!

Update 2:
Attempting to do the above using unetbooting and by manual adding mbr.bin to the USB drive. Also, a stiff beverage is helping too.

Update 3: So to the best of my albeit small knowledge, I guess I'm trying to do something rather silly... Since i don't have access to a Windows computer, it's kinda hard to make a usb install that's bootable on any computer w/o mac... right? I guess that's why I'm having issues with both the linux and windows boot... Gonna ply some more beverages.

Update 4: Further down the rabbit hole we go. Adding mar.bin's doesn't seem to be working. Though the unetbootin boot loader loaded, there was no windows install to load. What happens if I make a GUID usb windows install and then replace the efi with like, say, REFIT?

Update 5: Audio (through headphones, but not through HDMI) is working and I no longer need the USB to boot! Wahoo! I followed these steps right here to get it fixed. Still no luck on Windows. I think the bigger issue here is why the heck I don't have anyone around me that uses Windows... gonna do some soul searching on that one.
Update 6: Noticed the USB 3 ports weren't working. Rehabman's fix right here worked.
 
Joined
Sep 11, 2012
Messages
12
Motherboard
Asus Z170M-PLUS
CPU
Intel Core i3 6100
Graphics
Sapphire Nitro+ RX570 8GB
Mobile Phone
iOS
You're having the same problem with booting without the USB?
Yeah, I still need to use the USB drive to boot. Gonna try the method that you posted in Update 5. Audio for me isn't working, but I have a DAC so it doesn't matter. Got a new WIFI card, waiting for my bluetooth dongle to arrive. No issue with USB3 for me. :lol:
 
Top