Contribute
Register

X299 Big Sur Support

Joined
Jun 13, 2018
Messages
715
Motherboard
Prime X299-A II
CPU
i9 9980XE
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. Android
  2. iOS
Curious, when I was using v11.6 my startup times were only 45 seconds. Now with v12.0.1 my startup time is 1:50 min. Is this typical? Not a big deal, as once my system starts up, it's pretty much running the whole day and I never put it to sleep. At the end of the day that's when I shut it down for the evening.
Got a Samsung boot drive? They have issues with Monterey
 
Joined
Sep 30, 2020
Messages
97
Motherboard
Asus Prime X299-DELUXE
CPU
i9-7980XE
Graphics
RX 6900XT
Got a Samsung boot drive? They have issues with Monterey
Yes, I do use Samsung straight across the board. My main drive is the Samsung 960 Pro M.2 NVMe 1TB. Oh well, no big deal, just have to wait an extra min. Thanks for letting me know. Hopefully they will have an update on the OS that will correct this. Thank you for your reply.
 
Joined
Sep 30, 2020
Messages
97
Motherboard
Asus Prime X299-DELUXE
CPU
i9-7980XE
Graphics
RX 6900XT
By the way is there now a page for X299 Monterey Support?

EDIT: Never mind, I found it.
 
Last edited:
Joined
Jul 24, 2013
Messages
31
Motherboard
asus x299 Deluxe
CPU
i9 7900x
Graphics
6900 XT
Mac
  1. iMac
Unfortunately I don't I just used the BIOS settings that was instructed here and that's pretty much it. There is some pre-set OC but not much. Honestly, these machines are fast enough for my needs anyway with using Premier, Audition, Photoshop and Illustrator that don't need much OC'ing.
sorry for the slow reply. Things have been busy and I've just noticed this. I was actually trying to slow it down to the standard turbo as it's running too hot. I'm not sure what the standard settings are though...
 
Joined
Jul 24, 2013
Messages
31
Motherboard
asus x299 Deluxe
CPU
i9 7900x
Graphics
6900 XT
Mac
  1. iMac
I'm up and running on Big Sur with a 7900x and a 6900 XT. I'm getting strange happenings when starting up from cold though. Sometimes, it's fine. However, on some occasions, the monitors go into standby just before the Apple logo appears. The way to fix it seems to be to switch-off and switch-on until it boots properly.

Something else that I've noticed (which may or may not be related to the main issue above) is about the RBG on the case I'm using. It's a Be Quiet dark base 900 Rev 2 with a wireless phone charger on the top. When I'm charging the phone, the RGB flickers on and off and changes colour. The charger also doesn't work when I'm gaming on the PC partition and everything is at load.

Like I say, these 2 things may not be connected, but I've started to wonder whether the PSU is strong enough for the 7900x and 6900 XT. It's a Corsair 850W. I'm not experiencing crashes once it's up and running.

Does anyone have any thoughts?

Thanks,

Nick
 
Joined
Jul 20, 2014
Messages
882
Motherboard
AsRock X299 Creator-1.50
CPU
i9-10900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
hello
I Need Help for USB port Mapping on Asrock Fatal1ty X299 Professional Gaming i9
I use USBinjectAll.kext and XHCIportlimit Quirk

There is 3 USB controllers
Capture d’écran 2021-12-01 à 11.23.49.png

I rename (XHC2 &XHC3) the 2 ASMEDIA Controllers with SSDT
But Hackintool does not see the ports of ASMEDIA controllers
What would I do ?

Here what I have discovered :
Fatal1ty X299 Professional Gaming i9 USB BackPanel.jpgFatal1ty X299 Professional Gaming i9 USB Internal.jpg

The MacOS USB Port limit is 15 per USB controller isn't it ?
Can I build a Kext with Hackintool only for the X299 USB Controller and having the ASMEDIA controllers still working ?

On the other hand IORegistry show some ports ... but with not usual names (related to XHCI???)
Capture d’écran 2021-12-01 à 12.23.17.png

Thanks
 
Last edited:
Joined
Mar 18, 2017
Messages
1,042
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
hello
I Need Help for USB port Mapping on Asrock Fatal1ty X299 Professional Gaming i9
I use USBinjectAll.kext and XHCIportlimit Quirk

There is 3 USB controllers
View attachment 535987
I rename (XHC2 &XHC3) the 2 ASMEDIA Controllers with SSDT
But Hackintool does not see the ports of ASMEDIA controllers
What would I do ?

Here what I have discovered :
View attachment 535990View attachment 535991

The MacOS USB Port limit is 15 per USB controller isn't it ?
Can I build a Kext with Hackintool only for the X299 USB Controller and having the ASMEDIA controllers still working ?

On the other hand IORegistry show some ports ... but with not usual names (related to XHCI???)
View attachment 535992
Thanks

Seems OK with the Hackintool mapping : one of your internal USB header isn't used HS03/HS04 so can be ignored.

After : for the internal two USB 3 headers : you know which one is connected on your PC case and for the USB-C internal header at the middle of the tow USB3 headers maybe it not connected on your PC case too.

So on your IOREg no reason to see XHCI device that didn't no appear.

You can verify by connecting one by one USB stick on your USB ports and see on IOReg

Attach you USBports.kext from Hackintool and your IOReg , I'll see this evening and repport.;)
 
Joined
Oct 4, 2018
Messages
561
Motherboard
Gigabyte C246-WU4
CPU
E-2278G
Graphics
WX7100
Mac
  1. MacBook Pro
  2. Mac mini
The MacOS USB Port limit is 15 per USB controller isn't it ?
Can I build a Kext with Hackintool only for the X299 USB Controller and having the ASMEDIA controllers still working ?
Yes, the limit applies per controller. I never bother mapping additional USB controllers, as they are well below their 15-port limit.
Why do you rename these two controllers by the way? That should not be necessary.
 
Top