Contribute
Register

USB Fixes

Status
Not open for further replies.
Joined
Nov 27, 2015
Messages
11
Motherboard
gigabyte ga-h81m-s2h
CPU
intel core i5 4460
Graphics
palit gtx 750ti
Mac
Classic Mac
Mobile Phone
tried to to kexts files but nothing works. 2 of my usb on the back of pc works (usb2)
got 4 more usb3 on the back that doesnt.
2 usb3 oon the front work.

what should be my next move?
 
Joined
Oct 25, 2015
Messages
14
Motherboard
Gigabyte GA-Z97-D3H
CPU
Intel Core i7-4790K
Graphics
Gigabyte GTX 960
Mac
Classic Mac
Mobile Phone
If that doesn't work, please report back.
Reporting back. My Gigabyte Z97-D3H is using 6 x USB2 and 6 x USB3 ports. USB2 devices work in any of the ports, but only one port works with actual USB3 devices via USB3 port (via header port, not back panel port). Great to have one USB3 port working great I suppose, but the idea of purchasing an PCI USB3 card when I have 5 available USB3 ports just plain makes me angry. It has always been this way, before and after these kext additions.

I do miss Yosemite's USB3.0 support, but El Capitan is more stable for me.
 
Joined
Apr 14, 2012
Messages
8
Motherboard
OS X 10.10.3
CPU
i3@3.4 Ghz thrd gen processor
Graphics
Asus 650 GTI 1024 Mb
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
Hello to all, with the help of the instructions to me are a function of two USB 2.0 ports. USB 3.0 does not work, I even while loading the system repeatedly reset the system. My board is Asus P8H61/USB3, i3 3240 @ 3.40 GHz, 8GB Kingston 133 MHz. Any idea how to stop the reset system performance. Sorry for my english

thank you all
 
Joined
Mar 27, 2013
Messages
41
Motherboard
Gigabyte GA-B75M-D3P
CPU
i7-3770
Graphics
GTX 760
tried to to kexts files but nothing works. 2 of my usb on the back of pc works (usb2)
got 4 more usb3 on the back that doesnt.
2 usb3 oon the front work.

what should be my next move?

Try and rebuild your plist from config_patches.plist template from the USBInjectAll repository. Worked for me, all usb's now work inlcuding usb 3.0 except that 2.0 devices don't seem to be recognised in usb3 ports.
 
Joined
Oct 19, 2014
Messages
42
Motherboard
Hewlett-Packard 2AF3 1.0
CPU
Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz Haswell-DT
Graphics
Nvidia GeForce GTX 1050 OC 2GB
Mobile Phone
  1. iOS
I have this MOBO Hewlett-Packard 2AF3 Intel Core i7-4770 with chipset Intel Z87 Lynx Point. Could I use this fix? thanks
 
Joined
May 18, 2015
Messages
5
Motherboard
ASUS Z97 PRO WI-FI (ac)
CPU
i7-4790K
Graphics
GTX 970 G1 GAMING
Mac
Classic Mac
Mobile Phone

Attachments

  • Screen Shot 2015-12-03 at 20.34.13.png
    Screen Shot 2015-12-03 at 20.34.13.png
    264.6 KB · Views: 247

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,014
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi RehabMan,
I read again the guide.I first found out that I have more than 15 USB ports.
I tried to exclude the doors HS, SS and SSP, but failed to identify two USB3 ports.
Using IOreg, I noticed that these are under RP07@1C,6 (see the attachments) and I do not know how to proceed.
Anyone can help me?

Thanks,

Dario

No idea without seeing ioreg (you have the wrong area selected).
 
Status
Not open for further replies.
Top