Contribute
Register

updated to Mojave, no quick look or preview jpg, help AMD rx 580

Joined
Sep 16, 2012
Messages
24
Motherboard
GA-Z77-DS3H
CPU
i5-3570K
Graphics
RX 580
Mac
MacBook, MacBook Air, Mac mini
Mobile Phone
iOS
I had the same problem only in Mojave
(I installed Mojave fresh with Radeon RX 560 and no Lilu and no WhatEverGreen.kext in Clover/kexts/other. No edit in config.plist.)
Worked - but .jpg with quick look does not.

---> Found: https://github.com/vulgo/NoVPAJpeg/releases

1. download, unzip
2. copy latest Lilu and downloaded "NoVPAJpeg.kext" to dektop
3. use KextBeast to copy to ./Library/Extensions (I do not copy them to EFI Clover kext!!)
4. restart

You are done! = Quick look show all .jpg
Thanks for this!!! I was able to get Quick Look JPEG space-bar previews working by following those 4 steps precisely. Before I used Clover Configurator, and it didn't work. The Whatevergreen thing just confused me, the boot option you have to use isn't documented on the page for some reason.
 
Joined
Dec 5, 2013
Messages
171
Motherboard
Z97X-UD5H
CPU
i5 4690
Graphics
GTX 760
Mac
MacBook, MacBook Pro
Mobile Phone
iOS
Thanks for this!!! I was able to get Quick Look JPEG space-bar previews working by following those 4 steps precisely. Before I used Clover Configurator, and it didn't work. The Whatevergreen thing just confused me, the boot option you have to use isn't documented on the page for some reason.
This is not recommended by the author of the kext !! from his github page :

NoVPAJpeg.kext is deprecated.

In case its functionality is needed, use WhateverGreen.kext and add the following boot arguments:

shikigva=32 shiki-id=Mac-7BA5B2D9E42DDD94
Haven't try his way, still trying to set headless IGPU instead, but the kext is not the way to go now :)
 
Joined
May 12, 2016
Messages
3
Motherboard
GA-Z170X-Gaming 3-EU
CPU
i5-6600
Graphics
EVGA GeForce GTX 750 Ti
Mac
MacBook Pro, Mac mini
Thanx Itwas ! Fortunately I tried the macpro 6.1 SMBIOS and it solved the problem. CPU works fine with sleep and everything. So I guess I won't need the IGpu fix... for now ;) Thanx again !
Thanx! macpro 6.1 SMBIOS solved my problem too.
 
Joined
Sep 30, 2019
Messages
7
Motherboard
up4 x79
CPU
i7
Graphics
660ti
To fix Preview, either (1) enable IGPU and configure it to be headless or (2) try iMacPro1,1 system definition and disable IGPU. I never tried this with Z270, but I think it should work.

can you or someone tell me how to disable the IGPU?
i have imacpro 1,1 and everything works fine except the preview for MOV files in finder. Thats the only thing Id like fixed. but I dont want to lose hardware acceleration by going to other system profiles
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
11,180
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
can you or someone tell me how to disable the IGPU?
i have imacpro 1,1 and everything works fine except the preview for MOV files in finder. Thats the only thing Id like fixed. but I dont want to lose hardware acceleration by going to other system profiles
Disable it in BIOS.
 
Joined
Apr 6, 2012
Messages
3
Motherboard
Gigabyte GA-Z68A-D3H
CPU
i5-2500K
Graphics
HD 6870
Mac
iMac
Classic Mac
Apple, iMac
Changed my profile from iMac14,2 to MacPro6,1. using Clover Configuration > SMBIOS > then changed the profile from the profile selector to MacPro6,1 profile and save changes. This fixed the issue instantly, after a quick computer reset. Nothing else is needed.

Screen Shot 2019-11-23 at 8.29.15 AM.png
 
Top