Contribute
Register

[Success] Xeon E5-2680 V4 ES Chip, GTX 950, Asrock x99 Extreme6 / Dual Boot Win10+El Cap 10.11.6

Status
Not open for further replies.
Joined
Feb 3, 2016
Messages
1
Mac
Classic Mac
Mobile Phone
dnanob's build: Intel Xeon E5-2680 V4 Engineering sample chip - ASrock X99 Extreme6 - 16 GB Corsair DDR4-2400 - EVGA GTX 950 SC+ - 2x Samsung 850 Evo 120 GB SSDs

Components:

ASrock X99 Extreme6 motherboard
http://www.newegg.com/Product/Product.aspx?Item=N82E16813157567

EVGA GTX 950 SC+
http://www.newegg.com/Product/Product.aspx?Item=9SIA2F84BD0552

2x Samsung Evo 850 SSD
http://www.newegg.com/Product/Product.aspx?Item=9SIA12K2EV4048

16 GB (2x8) Corsair LPX DDR4-2400 Memory
http://www.newegg.com/Product/Product.aspx?Item=9SIA1K63TD6891

Intel Xeon E5-2680 V4 Processor (couldn't find Engineering Sample version on newegg)
http://www.newegg.com/Product/Product.aspx?Item=9SIA62V4HT1263

NZXT S340 case
http://www.newegg.com/Product/Product.aspx?Item=N82E16811146197

NZXT Hale82 v2 700w Power supply
http://www.newegg.com/Product/Product.aspx?Item=N82E16817116024

CPU Cooler: Cooler Master 212 EVO
http://www.newegg.com/Product/Product.aspx?Item=N82E16835103099


Comments:

First of all, I'm not an hackintosh expert - this was trial and error basically. There really isn't a reason I built this machine, just for fun/learning purposes and sell later. First day, it won't even boot up because I had an old BIOS version that didn't support V4 Xeon chips. so I had to take the BIOS chip itself to a guy, who has a chip flashing machine (don't remember its name), and update it with latest version.. Then, I had a fully working system (whew!). A few months later, I decided to make it a hackintosh. I have spent almost a whole month trying to get at least to El Capitan setup. Then, it all went smooth and clean. Both Ethernet ports were working at first startup. Video acceleration and audio didn't work. I used voodoohda for audio and Nvidia web driver for VGA. Turbo boost is not working (I think it's because I'm using Haswell kernel patch), speedstep is working. Later, I decided to make it dual boot Windows 10 + El Cap. This was really easy because I have a dual SSD setup (one for Windows and one for OS X).

I had to use iMac 14,2 SMBIOS to get video acceleration working
I had to use FakeCPUid 0x0306A0 --> Ivy Bridge. Otherwise setup and ssd wont boot.
I used Brumbaer's patch for 5960X Haswell-e

Summary:

What's working:
  • Audio (VoodooHDA, haven't looked too much into this)
  • Video Accel. (Nvidia web drivers & cuda driver)
  • HDMI/DVI ports
  • Speedstep
  • Both ethernet ports
  • USB 3.0 ports
  • Pretty much everything to make it a really enjoyable Mac experience
  • Dual boot is working perfectly

What's not working:

  • Turbo boost
  • USB 2.0 ports

Benchmark and other screenshots:

I know I'm not getting the score I'm supposed to, but still pretty decent. Yes, it has a very slight overclock - from 2.20 Ghz to 2.26.





 
Joined
Jan 23, 2011
Messages
176
Motherboard
Aorus Z370 Gaming 3
CPU
i7 8700
Graphics
GTX 1080Ti / Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey bro goodmornig i try too with
Intel Xeon E5-2667 v4
can u sare your config.plist please ?
 
Joined
Aug 3, 2015
Messages
6
Motherboard
ASUS X99M-WS
CPU
xeon E5-2686-v4
Graphics
nvidia GTX 1080Ti
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. eMac
  2. iBook
  3. iMac
  4. Power Mac
  5. Quadra
Mobile Phone
  1. Android
  2. iOS
hi, dnanob
Would you please share your installing steps to us ?
I am trying to setup a Hackintosh like yours within many troubles.......
kindly thanks~

koei
 
Status
Not open for further replies.
Top