Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Mar 24, 2012
Messages
12
Motherboard
TS140
CPU
E3-1245v3
Graphics
HD4600 (integrated)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
kseel89



take a new BIOS battery

After about 2 hours I've got it to re-flash the BIOS again. I'm flashing it with F9b now. Hopefully, I can get into the BIOS settings after this is done...

Actually, I did test the battery with a voltage meter and it's a strong 3.17+v or so

Edit: My board does not like the F9h BIOS version. F9b works though. I re-downloaded F9h and checked the hash just to make sure the file wasn't corrupt or something, but it doesn't work for me. Also, I saw some strange stuff with F9h - the BIOS date when it finished installing was something weird like 101/10/110 (not sure the exact numbers, but it didn't look like real dates).

Maybe some boards don't like F9h.
 
Last edited:
Joined
May 15, 2020
Messages
1,301
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Maybe some boards don't like F9h.
try F9g, someone published it in the forum. I'm using it and there's no problem, and I'm not the only one using it, just try it
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,926
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi Casey,

Thank you so much for making EFI for me. I tried with your EFI, and still experiencing similar issues (with SSDT-EC on, the output shows some component loaded successfully but still stuck at some point). However, with/without SSDT-EC on, it gave different output. I have attached two photos, the first one is with SSDT-EC on, the second one is without SSDT-EC on.

Currently, I have three PCI-E devices: Gigabyte RX 5700XT, Fenvi T919 (which claims plug-and-play with MacOS, but I haven't plug Bluetooth USB into the motherboard, and I will plug it in once I got the internal USB splitter from Amazon), a 10GBE NIC came with the motherboard (from what I learned from its driver on Windows, it is the same as other ASUS's 10GBE NIC using an Aquantia 10GBE chip, which should be working with MacOS, but we will see). On BIOS setting, I disabled Fast Boot, VT-d, CSM, Thunderbolt (will work on this once I get MacOS installed properly), Intel SGX. But there is no CFG Lock option on ASUS Bios setting, so I think I have to set True on AppleCpuPmCfgLock and AppleXcpmCfgLock in my plist file. For the options I enabled, I enabled Above 4G decoding, Hyper-threading, XHCI Hand-off, and iGPU memory preservation with 64MB. I connect my display to RX 5700XT with a displayport cable. I have also attached my DSDT file below if it helps.

Output with SSDT-EC on:
View attachment 473994

Output with SSDT-EC off:
View attachment 473995
Hello @wwanxh,

Here are some additional suggestions for the Asus Z490 ProArt Creator:
  • Use OpenCore 0.5.9 and latest Lilu, WhateverGreen, AppleALC, VirtualSMC
    • Latest WhateverGreen, for instance, supports the Comet Lake iGPU device-id
  • Ensure that Ethernet drivers (for 10Gbit and 1Gbit) are installed. It doesn't hurt to include the Aquantia 10Gbit kext.
    • Because 10Gbit is on the PCIe card, also try removing that card during installation.
  • Check the Dortania OpenCore setup guide because it has recently been updated for Comet Lake on OC 0.5.9.
    • Double-check Booter Quirks and Kernel Quirks
  • If SSDT-EC helps, then certainly keep it.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,926
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hello Casey

well I am located in India and I think these are all beta version let me give it a try with this one and update you.
Well I am In India and I was not getting any information about the bios on official website of gigabyte last updated bio I can see is F9B that's why I am not aware about the other versions
Hello @luvlastcall,

Firmware F9h is available from TweakTown by clicking here. It has been installed successfully by many, but of course BIOS updating always incurs some risk. Note that any action you take is 100% your responsibility because (a) we don't make the motherboard, (b) we don't sell the motherboard, (c) we don't test and qualify the motherboard, etc. Therefore we cannot guarantee that everyone with the same motherboard will experience the same behavior.

If you update the firmware, then configure BIOS parameters again starting always with Load Optimized Defaults. And there's no need to unlock MSR 0xE2 because it will be unlocked by default.
 
Joined
May 15, 2020
Messages
1,301
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Inqnuam
beyerdynamic DT 1770 Pro
and have dt 770 pro and
audi technika


and I hear audio distortion everywhere over the boxes were mouse noises at the beginning to detect dan I pin three on the xlr cable and the mouse noises are gone but the kinister is still there and easily audio dropouts in the recording can do that on power supply be quiet dark power pro 11 550w liegn because there is a triple plug installed and with the mac mini only the 2 without earth do that?

i think you have 2 problems
the first one is about CPU usage
the second is about the ground connection

remove all unnecessary accessories from your computer, like Hard drive that you don't use, usb drive and all things like that.

set your buffer size to maximum in your DAW and make a test
check if your plugs have ground connector
verify if your house is connected to ground for real
separate your computer power connection from your audio interface power: connect them to 2 different power lines, for example your computer you can connect it in your room and the audio interface in another room

try recording without your display on: click to record in your DAW then switch off your monitor and unplug the power cable

also try record in Windows to be sure the problem is not about macOS configuration
 
Last edited:
Joined
May 15, 2020
Messages
1,301
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
@CaseySJ Hello Sir!
A question about OpenCore.
(i'm using NDK-OpenCore-0.5.8 for Designare Z390 - NVRAM.zip with my custom Thunderbolt DROM)
How to update kexts in OpenCore? Just replace the old versions of kexts with the new ones? Nothing to change in config.plist or somewhere else?

I want to update macOS from 10.15.4 to 10.15.5, in my case what i need to do please?
 
Joined
Feb 7, 2014
Messages
33
Motherboard
Gigabyte Designare Z390
CPU
i5 9600K
Graphics
2x RX580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Random question: Is anyone using dual thunderbolt displays daisy chained off the Thunderbolt3 to Thunderbolt2 adapter? I have this setup for my MBP, wondering if the same works after the Flash of the Thunderbolt chip... I ask because there is only 1 DisplayPort in on this MB.
Thanks.
 
Joined
Feb 11, 2018
Messages
85
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
UHD 630
inqnuam

I don't even need to open the daw, it already crackles in the uad console without a daw, only a large membrane mic brown phanther but I have also confirmed and determined 4 different apollos tested apollo twin apollo mk 2 apollo x
RME Madiface XT same problem I think it is because of the power circuit let me come to an electrician
 
Top