Contribute
Register

[SUCCESS] Big Sur on ASUS UN65U VivoMini + i5 7200U

Joined
Apr 7, 2020
Messages
11
Motherboard
Asus VivoMini UN65u
CPU
i5 7200U
Graphics
Intel HD Graphics 620
Mac
  1. Mac mini
Mobile Phone
  1. Android
The Asus UN65U is a desktop mini PC that uses laptop components to keep the size and power requirements down.

Motherboard: ASUS UN65U VivoMini
CPU: Intel Core i5-7200U @2.5GHz-3.1GHz
GPU: Intel HD Graphics 620 1536 MB
Audio: Conexant CX20751/2 @ Intel Sunrise Point-LP PCH - High Definition Audio
RAM: 2x16GB Kingston 2133 MHz DDR4
HDD: Samsung 840 SSD 250GB
Ethernet: Realtek PCI GbE Family Controller
WiFi: Intel Dual Band Wireless AC 7265
About.png


Kexts I used for installation:
Airportitlwm.kext
AppleALC.kext
Lilu.kext
RealtekRTL8111.kext
SMCProcessor.kext
SMCSuperIO.kext
VirtualSMC.kext
WhateverGreen.kext

Boot flags (Using OpenCore 0.6.3):
keepsyms=1 alcid=3

What works:
WiFi: Airportitlwm 1.2 alpha works
LAN: Realtek 8111 works
USB: All USB slots (2.0 & 3.0 and front USB) working
Bluetooth: works
Sleep: works
iMessage: works
FaceTime: works with a Wyze Camera v2 flashed as a webcam
Graphics: Intel HD 620 seems to work fine w/ DP and HDMI and reports metal support. Currently driving a 2K HP Monitor over DP
Audio: Audio jack in back and DP/HDMI audio work properly

What doesn't work:
Nothing - as far as I can tell everything works correctly.

Quirks:
Video: When I boot up the screen will display properly for ~5 seconds, then the screen will turn off for about 15s while the SSD light blinks furiously, then the screen will reappear and everything will work great. The same thing happens when recovering from sleep. No idea what is going on, but I figure it is just an extra 15s of boot/wake up. Video looks good - transparency is fine and the drift screensaver looks good with no stuttering.

EFI Structure
I used Open Core 0.6.3 and the latest kexts downloaded on Nov 16. I tried using the normal guides but kept getting kernel panics. I wound up downloading 4 different EFI folders and piecing together the config.plist entries and kexts until it was working. This is based off of the iMac18,1 as that seems the closest match for the 7200U/HD620 which never shipped in a mac.

I installed Windows 10 on a separate drive and am able to dual boot using the Open Core GUI boot screen.

Airportitlwm 1.2.0 alpha is the first version that has been stable on this box. It now recovers from sleep and connects to 2.4 and 5Ghz networks with no problems. I get around 95mbps download w/ 13ms ping which is enough for casual use.

See attached EFI folder for details. Use ProperTree to edit the config.plist and GenSMBIOS to get a new iMac18,1 serial number, motherboard serial number, and UUID in PlatformInfo. Also, the current PlatformInfo->Generic->ROM is set to 11223344 5566 which isn't going to work well with iMessages, etc. - update it to match your MAC address.

Install
I was originally running Catalina with a year old version of Clover, but when I tried to update it for Big Sur Beta everything blew up. It seemed like a better idea to get a clean Open Core install than keep trying to hack together Clover.
I downloaded the Big Sur 11.0.1 GA release and used createinstallmedia to make a USB boot stick installer. I replaced the EFI folder on the USB drive with this one and booted up, formatted the drive as APFS and installed. Once installed I updated the EFI on the SSD with this. Fairly painless except for the 20-30 attempts with different combinations of other EFI folders I downloaded ...

Thanks!
I figured that enough people posted their stuff that I ought to give back - hopefully this will help someone out.

Thanks to everyone for their contributions!

EFI Changes:
11/19/2020 I removed IntelMausi, NoTouchID, and NVMeFix and reuploaded the fixed EFI because they don't seem to be needed for a UN65U.
11/25/2020 Changed APPL,ig-platform-id to <05001C59> since that seems to work better for VM65 and it works equally well for UN65U.
 

Attachments

  • EFI.zip
    67.1 MB · Views: 896
Last edited:
Joined
Nov 19, 2020
Messages
9
Motherboard
Asus VM65
CPU
i5 7200U
Graphics
Intel HD 620
100500 thx to you!)))
At VivoMini VM65(same configuration) work like a charm!))
But under macOS 10.15.6 not work OOB WiFi & BT.
Trying to update to 11.0.1 right now. Hope it'll fix.
Anyway grand thx!!!
 
Joined
Nov 19, 2020
Messages
9
Motherboard
Asus VM65
CPU
i5 7200U
Graphics
Intel HD 620
After block AppleIntelLpssI2CController in the plist.conf success upgraded to 11.0.1)
WiFi work OOB, BT - nope.. Looking for issue)
 
Joined
Apr 7, 2020
Messages
11
Motherboard
Asus VivoMini UN65u
CPU
i5 7200U
Graphics
Intel HD Graphics 620
Mac
  1. Mac mini
Mobile Phone
  1. Android
The Airportitlwm.kext needs a different version for Catalina, the one in the attached EFI is only for big sur. Not sure what the BT difference is between un65u and vm65. There are comments on the openintel github that say there might be issues with BT as a result of the wifi driver, but it doesn't seem like that is your problem - but you could try disabling it just to make sure.
 
Joined
Nov 19, 2020
Messages
9
Motherboard
Asus VM65
CPU
i5 7200U
Graphics
Intel HD 620
The Airportitlwm.kext needs a different version for Catalina, the one in the attached EFI is only for big sur. Not sure what the BT difference is between un65u and vm65.

Yep, it same. But...)
 
Joined
Nov 19, 2020
Messages
9
Motherboard
Asus VM65
CPU
i5 7200U
Graphics
Intel HD 620
Which kext uses for BT support? Airportitlwm.kext too?
 
Last edited:
Joined
Apr 7, 2020
Messages
11
Motherboard
Asus VivoMini UN65u
CPU
i5 7200U
Graphics
Intel HD Graphics 620
Mac
  1. Mac mini
Mobile Phone
  1. Android
No, for me BT works fine without Airportitlwm.kext. My adapter details (from Windows device manager) are
Not sure what is making it work - it just worked for me.

What Bluetooth adapter does the vm65 report?

Do you also get the 15-20 second black screen on bootup? Not sure how to fix that.

As an aside, it looks like IntelMausi, NoTouchID, and NVMeFix are not needed so I removed them from the EFI above. BT still works for me even without them.
 
Last edited:
Joined
Apr 7, 2020
Messages
11
Motherboard
Asus VivoMini UN65u
CPU
i5 7200U
Graphics
Intel HD Graphics 620
Mac
  1. Mac mini
Mobile Phone
  1. Android
Depending on what Bluetooth adapter is in your vm65, you may need to use
I notice that it lists 8087/0a2a, but everything works for me without it.
Possibly it might solve your issues?

This issue implies there are problems with Intel bluetooth and itlwm, although it seems to work great for me (I use 5Ghz Wifi, but I have not seen problems with 2.4 either).
 
Joined
Apr 7, 2020
Messages
11
Motherboard
Asus VivoMini UN65u
CPU
i5 7200U
Graphics
Intel HD Graphics 620
Mac
  1. Mac mini
Mobile Phone
  1. Android
Made a couple small changes to the attached EFI to fix "No schema for DummyPower" error on boot and enable Conexant CX20751/2 audio via audio jack in back and DP/HDMI via AppleALC. As far as I can tell everything is working correctly.

The only remaining issue is the ~15s temporary black screen during boot, but that is pretty easy to live with. Very happy with Open Core!
 
Joined
Nov 19, 2020
Messages
9
Motherboard
Asus VM65
CPU
i5 7200U
Graphics
Intel HD 620
Depending on what Bluetooth adapter is in your vm65, you may need to use
I notice that it lists 8087/0a2a, but everything works for me without it.
Possibly it might solve your issues?

This issue implies there are problems with Intel bluetooth and itlwm, although it seems to work great for me (I use 5Ghz Wifi, but I have not seen problems with 2.4 either).
Thx, I'll try.
So what about 15sec delay - I have two interfaces (DP/HDMI).
When HDMI connected after boot screen goes to sleep until switch off/on. It don't wakeup itself.
If DP connected - the same issue, but have a different - It goes in sleep mode forever and ever. Only one solution - switch to HDMI and work with 1080p max (
 
Last edited:
Top