Contribute
Register

[Success] Asus Z87 Maximus VI Hero Build - OS X Yosemite (with Chameleon)

Status
Not open for further replies.
Joined
Jun 25, 2014
Messages
85
Motherboard
MSI Z390-A PRO
CPU
i5 8400
Graphics
R9 380
Mobile Phone
  1. iOS
[Success] Asus Z87 Maximus VI Hero Build - Yosemite - El Capitan - Sierra

dr.kkarun’s Build: Core i5-4670K - Asus Maximus VI Hero - 8GB RAM -
Intel HD 4600 + AMD Radeon R9 380

115053-img-0002.jpg
Components

Mac OS X 10.10 Yosemite
https://itunes.apple.com/WebObjects/MZStore.woa/wa/viewSoftware?id=915041082&mt=12

Asus Maximus VI Hero LGA 1150 Intel Z87 ATX Motherboard

http://www.amazon.com/dp/B00CXIVEA2/

Intel Core i5-4670K Haswell LGA 1150

http://www.amazon.com/dp/B00CO8TBOW/

G.SKILL RipjawsZ Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 2400 Desktop Memory (running at 1600 MHz 1.5V 8-9-8-24-2N)

http://www.amazon.com/dp/B0088JQY7I/

Samsung 840 EVO series 120GB SSD

http://www.amazon.com/dp/B00E3W15P0/

Western Digital Blue 1TB 7200 RPM Internal Hard Drive
http://www.amazon.com/dp/B0088PUEPK/

Cooler Master HAF 912 combat ATX Mid Tower Computer Case

http://www.amazon.com/dp/B00BCXF6O4/

Seasonic X series 750W 80 PLUS GOLD Certified Modular Power Supply compatible with Haswell

http://www.amazon.com/dp/B002VAFDQS

Asus VS247H-P 23.6-Inch Full-HD LED-Lit LCD Monitor

http://www.amazon.com/Asus-VS247H-P-23-6-Inch-Full-HD-LED-Lit/dp/B005BZNDS0

TP-LINK TL-WN881ND PCIe Wireless card

http://www.amazon.com/dp/B0079XWMEI/

Cooler Master Hyper 212x CPU cooler

LG optical DVD drive


Logitech C615 webcam

Logitech wireless keyboard K270

Logitech wireless mouse M510

http://www.amazon.com/Logitech-910-001822-M510-Wireless-Mouse/dp/B003NR57BY

Comments
The core components (which influence Mac OS compatibility) are the same which I used for Mavericks build. I prefer Chameleon/Chimera over Clover for Mac OS X installation. For Yosemite, i used Chameleon. In Mavericks, I were not able to enable graphics during installation, as my board needs Azul kext binary patch. But in Yosemite, I could use graphics during installation. Unlike mavericks, bootflag kext-dev-mode=1 is needed in Yosemite in order to load unsigned kexts. Other steps are almost similar to mavericks installation. The following steps worked for Asus Maximus VI Hero (HDMI only, z87 board) with HD4600 Graphics.

References:
Post#5 -
Migration to Clover UEFI (with HDMI audio)
Post#9 - Dual Boot Mac OS X Yosemite and Windows 8.1 in same hard drive using Clover UEFI
Post#22 - Migration to iMac 11,3 system definition and 13 digit MLB for working iMessage and FaceTime
Post#33 - Adding GIGABYTE AMD R9 380 4GB - Yosemite (OOB) & El Capitan (workaround needed)
Post#54 - Installing macOS Sierra
Post#60 - Installing macOS High Sierra

Things you need before proceeding:
1. Yosemite installer application from the Mac App Store
2. UniBeast 5+
3. MultiBeast for Yosemite
4. Chameleon Bootloader (+ i386 folder)
5. Chameleon Wizard
6. Kext Wizard
7. Hex editor (optional)

Create UniBeast flash drive
Follow the tonymacx86’s guide to create UniBeast installer flash drive.
http://www.tonymacx86.com/445-unibeast-install-os-x-yosemite-any-supported-intel-based-pc.html

Modifications to default UniBeast flash drive

  • This build closely matches iMac 14,2. You can get SMbios.plist for iMac 14,2 from MultiBeast or Generate SMbios.plist for iMac 14,2 using Chameleon Wizard. Whatever method u chose, make sure that the generated serial number does not have alphabets 'I' and 'O'. As far as i know real Mac serial numbers don't have these values.
  • If you don’t have SSDT for power management, then generate it using the following terminal commands (needs internet). If you are not using clover, then SSDT will be necessary for better power management.
    Code:
    curl -o ~/ssdtPRGen.sh https://raw.githubusercontent.com/Piker-Alpha/ssdtPRGen.sh/master/ssdtPRGen.sh
    Code:
    chmod +x ~/ssdtPRGen.sh
    Code:
    ./ssdtPRGen.sh
    If u plan to overclock, then add -turbo ? to the code. For e.g: ./ssdtPRGen.sh -turbo 4200
org.chameleon.Boot.plist for Yosemite installation
<key>Boot Banner</key>
<string>No</string>
<key>DropSSDT</key>
<string>Yes</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>Graphics Mode</key>
<string>1920x1080x32</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>IntelAzulFB</key>
<string>10</string>
<key>Kernel Flags</key>
<string>-v kext-dev-mode=1</string>
<key>Legacy Logo</key>
<string>Yes</string>

Install chameleon to the UniBeast flash drive. Copy and replace the SMbios.plist and org.chameleon.Boot.plist in the UniBeast drive with the plists you created. If the Extra folder is hidden, then try the following commands in terminal.
Code:
chflags nohidden /Volumes/USB/Extra
Code:
chflags nohidden /Volumes/USB/Extra/*
where USB= name of the unibeast flash drive.
Also copy the SSDT.aml to the Extra folder.

BackUp files needed for installation
Backup the following files to UniBeast flash drive (in a new folder) or a separate storage drive (preferably formatted in HFS+ format, as Mac OS doesn’t recognize NTFS and Fat32 formats in safe mode)
1. Yosemite installer app (from applications - as u can recreate Yosemite installer flash drive with Clover/UniBeast if something goes wrong)
2. MultiBeast for Yosemite
3. Chameleon wizard
4. Kext wizard
5. Hex editor

UEFI Bios settings
Shutdown your computer. Unplug all USB peripherals except UniBeast flash drive and Keyboard/Mouse receiver. (Optional- Disconnect all SATA drives except one for installation). Restart your PC and enter UEFI BIOS.
* Reset to Optimized Defaults
* Advanced —> USB configuration —> Legacy USB support -> Auto
* Boot -> Fast Boot -> Disabled
* Boot -> Secure Boot —> OS Type -> Other OS
* Save and reset
On Restart, press F8 and enter UniBeast flash drive.

Installing Yosemite
At the chameleon boot screen, type the boot flag -f, and then enter USB. If you get kernel panic or can’t get to installer, then add -x in addition to -f. Rest of the installation is same as per tonymacx86’s guide. During restart, enter Yosemite hard drive with boot flag -x. Complete registration in safe mode. Run MultiBeast with the following settings.
MultiBeast Configuration for Yosemite
115068-multibeast-yosemite.png
Note: I chose Chimera and basic boot options, because modules and boot plist are needed for ALC1150 installation.

Copy SMbios.plist and SSDT.aml from UniBeast flash drive to Extra folder in Yosemite hard drive. Open chameleon wizard and edit boot plist according to your preference (see below for my boot plist).
org.chameleon.Boot.plist
108944-final-boot-plist.png
Note:
For Desktop HD 4600 graphics (Haswell integrated graphics), Recommended boot flags are
Chameleon GraphicsEnabler=Yes, IntelAzulFB=10
Chimera GraphicsEnabler=No, IGPEnabler=Yes

You should configure org.chameleon.Boot.plist accordingly.

Now Extra folder will have the following 5 items.
1. Modules
2. org.chameleon.Boot.plist
3. SMBios.plist
4. SSDT.aml
5. Themes

TP-Link TL-WN881ND fix for Mac OS X
Copy IO80211Family.kext from S/L/E to desktop. Add the device id to info plist.
Path: IO80211Family.kext/Contents/PlugIns/AirPortAtheros40.kext/Contents/Info.plist
To unhide the info.plist, use the following command.
chflags nohidden (drag ‘Contents’ folder into terminal window)/Info.plist
Add (or edit) any one of the following strings to info.plist in the appropriate location, where similar strings are present.
<string>pci168c,2e</string> or <string>pci168c,30a4</string>
For Clover: DSDT Patch - AddDTGP + FixAirport

Framebuffer Edit [optional]
Though Azul kext binary patch is not necessary for this board for normal booting in Yosemite, hex editing is needed in order to solve 'no display' issue after switching off and on the monitor (extended duration). Copy AppleIntelFramebufferAzul.kext from S/L/E to desktop. Move the binary file inside it to desktop.
Path: AppleIntelFramebufferAzul.kext/Contents/MacOS/AppleIntelFramebufferAzul
Open the binary file using hex editor. Press command+F. Search for 0300220D. Then do the following changes. Save the changes. Restore binary file in original location (inside azul kext).

Original After Edit
0300220D 00030303 00000002 00003001
00000000 00000060 99140000 99140000
00000000 00000000 01050900 00040000
87000000 02040A00 00040000 87000000
03060800 00040000 11000000 FF000000
01000000 40000000 02040000 01010000
0300220D 00030303 00000002 00003001
00000000 00000060 99140000 99140000
00000000 00000000 01050900 00040000
01000000 02040A00 00040000 05000000
03060A00 00080000 06000000 FF000000
01000000 40000000 02040000 01010000


Notable Changes after this edit:
* Connector type - HDMI (00 08 00 00) [IOJones- under AppleIntelFramebuffer@2]
* Port number - 0x7 (previously 0x0) [IOJones- under AppleIntelFramebuffer@2]
* Delay value - 06 [hex editor as shown above]
* Television - Yes [under System Information]
With this framebuffer edit, connector using fFrameBufferIndex 02 will be disabled. Display will be through HDMI connector at fFrameBufferIndex 03 (AppleIntelFramebuffer@2 under IOJones) due to longer delay. Since my mobo has only HDMI connector, i have used this edit. This framebuffer edit will support HDMI audio. See Update:3 at bottom of this post for more details.
Credits to PikeRAlpha for his database on framebuffer under Pike's Universum.
Install these two kexts (Azul kext and IO80211Family kext) using kext wizard and rebuild kext cache.

Restart. Press F8 and select UniBeast flash drive. At the chameleon boot screen, enter Yosemite hard drive. If everything goes fine, then you may proceed to installing Bootloader and Extra to EFI partition. Note: For audio, you may need to do some changes under ‘System Preferences/Sound’. Refer this post.

108943-graphics.png

Installing Bootloader and Extra to EFI
If everything works, then you may proceed to install Bootloader and Extra to EFI. Follow the tonymacx86’s guide.
http://www.tonymacx86.com/401-install-bootloader-extra-efi-partition.html

If you want to install Chameleon instead of the Chimera from UniBeast drive, then do the following.
1. Install Chameleon to a separate flash drive (or) just download i386 from chameleon download page.
2. Copy the i386 folder inside FlashDrive/usr/standalone to desktop.
3. Replace the cd (change directory) command in STEP 3 of the guide with
Code:
cd ./Desktop/i386
Finally, Repair permissions and Rebuild cache using kext wizard. Eject UniBeast flash drive & Restart.

* Sleep, audio, wifi, FaceTime work fine.
* I have installed FileNVRAM v1.1.3 in Yosemite hard drive. As expected, nvram.plist is not generated on reboot. ROM and MLB generation failed as can be seen in iMessage_debug output. Hence i didn't try iMessage. Need to wait for FileNVRAM update.
Geekbench 3 score
156248-geekbench-el-capitan.png
(i5 4670k overclocked to 4.3 GHz & 8 GB G.Skill RipjawsZ at 1866 MHz, 1.5v, 9-10-9-27-2N timings)

TIPS
* After finishing installation, go to keychain access -> preferences and click ‘Reset My Default Keychain’. This may help in avoiding FaceTime/iMessage registration error.
* To prevent OCSPD from downloading at full bandwidth, go to keychain access and open preferences. Under certificates, set OCSP and CRL to off.
* Chipmunk/ slow-motion audio problem with Logitech C615 webcam:
While using FaceTime in recent versions of yosemite, audio sounds like chipmunk in my hackintosh. At the other end, i sound like monster (slow motion voice). Unplugging and Plugging in webcam on every boot will solve the issue, but annoying. In Audio MIDI setup, under Logitech Camera, changing the sample rate from '16000 Hz' to '32000 Hz' or '48000 Hz' will solve the issue but reverts back to 16000 Hz on every boot, hence need to be changed on every boot. Muting the Internal Microphone (under 'Built-in Input' in 'Audio MIDI setup') along with the sample rate change for Logitech Camera solves the issue in my case.
146860-audio-midi-setup.png


Update:1 [11/07/2014] Firmware upgrade for Samsung 840 EVO
Samsung SSD 840 EVO Performance Restoration Software (ISO CD-ROM Image) installation is recommended for Samsung 840 EVO users. This will update firmware from EXT0BB6Q to EXT0CB6Q and do performance restoration in two steps. Burn it to a CD using Disk utility. Restart, press F8, enter CD and update firmware. Clover users with UEFI booting may need to enable CSM in bios in order to boot into CD. Samsung claims this firmware update to be solving 'drop in read performance of old data' issue in Samsung 840 EVO. Yet to be confirmed.

Update:2 [11/18/2014] Update to 10.10.1 using Clover UEFI
Turned off wifi. Applied update and Restart. Addressed the following issues.
* Applied Device ID fix for TP-Link TL-WN881ND (see post#5 for clover patch)
* Optional: Did Azul kext edit using Hex editor (see post#5 for clover patch)
* Restart. Checked DPCIManager for Ethernet/wifi status [en0/en1]. Checked 'iMessage Debug' output (same as before update). Then enabled wifi.
* Audio - 'RealtekALC/patch in place' method (needs internet). Already had Audio id-1 in config.plist.
* Repaired disk permissions for Yosemite volume in Disk Utility. Rebuild kext cache. Restart.
For TRIM support & HDMI audio, see clover patch in post#5
Note: Since MultiBeast 7+ for Yosemite will install AppleIntelE1000e as a separate kext (unlike Multibeast 6.5.0 for mavericks, which will install AppleIntelE1000e.kext inside PlugIns of IONetworkingFamily.kext), OS X update 10.10.1 will not affect this kext. Hence, no need to install Network driver after update.

Update:3 [12/30/2014] HDMI audio with chameleon
M6H board requires the following for HDMI audio. Needs native or patched AppleHDA.kext.
  1. org.chameleon.Boot.plist edit (for onboard audio in addition to HDMI audio)
  2. Framebuffer edit
  3. AppleHDAController.kext patch
  4. SSDT edit
1.) Mount EFI and add HDAEnabler=Yes, HDEFLayoutID=01000000 to boot plist using Chameleon wizard if not present already and Restart (in order to detect ALC1150). This will enable onboard audio in addition to HDMI audio. I used RealtekALC patch for onboard audio. No need for any module to be present inside Extra.
2.) Since i had already done manual framebuffer binary edit (described above) using hex editor in order to solve "No Display" issue, i skipped this step.
3.) Can be done using audio_hdmi_hd4600-hda-100_patch.command.
4.) AMI-no_p0p2-HD4600-AMD-Nvidia-A1 worked for me. Since I already had SSDT.aml (ssdtPRGen.ph) inside Extra, I used the downloaded SSDT-1.aml as it is without name change. Mount EFI and add this.
On Restart, U will have both onboard audio and HDMI audio.

Thanks to tonymacx86 for the guides and software for Hackintosh build.
The attached SSDT.aml can be used for 'i5 4670k' build (non-overclocked).
 

Attachments

  • SSDT.aml
    1.7 KB · Views: 343
Last edited:
Joined
Aug 17, 2011
Messages
2
Mac
Classic Mac
Mobile Phone
I can't get my system to reboot with out the USB. Did I need to format my Yosemite drive with Master Boot Record?
 
Joined
Jun 25, 2014
Messages
85
Motherboard
MSI Z390-A PRO
CPU
i5 8400
Graphics
R9 380
Mobile Phone
  1. iOS
Joined
Jun 25, 2014
Messages
85
Motherboard
MSI Z390-A PRO
CPU
i5 8400
Graphics
R9 380
Mobile Phone
  1. iOS
Migration to Clover UEFI Bootloader:
After waiting so long for FileNVRAM update, I decided to try clover.
Followed the guidelines of Jaymonkey.
  • Did a fresh install of yosmite 10.10 using clover (UEFI boot) in a separate hard drive (Samsung 840 Evo 250 GB)
  • I chose a different non-registered serial number (using magic wand in clover configurator). Make sure the serial number does not have 'I' and 'O'.
  • Under smUUID, i entered uuid generated from terminal command 'uuidgen'. Replaced the last 12 digits with my ethernet mac address (ROM value)
  • For Board serial number (MLB value), i entered the 12 digit iMac serial number along with 5 random alphanumeric characters at the end (totally 17 digits)
  • Installed FakeSMC (& plugins), AppleIntelE1000e v3.1.0 from multibeast 7.0.1
  • I did the hex edit for framebuffer azul kext (optional), device id fix for IO80211Family kext as mentioned in post#1
  • Had to avoid FixLan and FixAirport in order to make en0 (ethernet) and en1 (wifi) as built-in under DPCI Manager. Infact, I had deselected all those fixes (Old way & New way) under ACPI in clover configurator
  • Installed audio using 'RealtekALC/patch in place' method (needs native AppleHDA.kext). Inject Audio_ID in clover configurator beforehand. I used Audio_ID:1
After finishing installation, I logged into FaceTime and iMessage using my Apple ID (different from the one i used with chameleon). Both FaceTime and iMessage generated same customer code. After entering details, i received a call from Apple customer support within 10 secs. I described the issue. She repeatedly said the serial number to be invalid and asked me to check again. I had to tell her my serial number for more than 10 times. As expected, she didn't seem to be convinced with my serial number. I told the same serial number whenever she asked. During the conversation, she asked for the bill details, apple id. After my excuses for not having the bill, she solved the issue finally.

Now both FaceTime and iMessage are working fine. Loving it.
Full credits to Jaymonkey.
Note: This method won't fix iMessage anymore since late November 2014. Follow iMessage guide for updates. Have tried iMac 11,3 system definition with 13 digit MLB with success. Refer post#22.

Clover Patch:
Add following details in KextsToPatch under 'Kernel and Kext Patches' in Clover configurator. Values in config.plist will be same for infoplist patch (TP-Link), but different for kext patch (Framebuffer Azul, AppleHDAController & Trim support)

TRIM support (for any non-APPLE SSD) TP-Link TL-WN881ND
Name IOAHCIBlockStorage AirPortAtheros40
Find 4150504C452053534400 pci168c,2a (or) pci106b,0086
Replace 00000000000000000000 pci168c,2e (or) pci168c,30a4
Comment ur choice ur choice
InfoPlistPatch leave it unchecked select

Choose one matching pair for TL-WN881ND, since both hex should be of same length (size)

Framebuffer Binary patch [optional] - will support HDMI audio
Name AppleIntelFramebufferAzul
Find 01050900000400008700000002040A000004000087000000030608000004000011000000
Replace 01050900000400000100000002040A00000400000500000003060A000008000006000000
Comment ur choice
InfoPlistPatch leave it unchecked


Patches for HDAcontroller for HDMI audio:
Name AppleHDAController AppleHDAController
Find 3D0B0C0000 3D0C0A0000
Replace 3D0C0C0000 3D0C0C0000
Comment ur choice ur choice
InfoPlistPatch leave it unchecked leave it unchecked


119944-kexts-patch.png
These patches will work in future updates of yosemite as long as Apple does not change these values in its kexts.​
Note: For Trim support, i used a different value (see picture above), since i have Samsung SSD. For correct name, see 'Model' of SSD under SATA/SATA Express in System Report. Convert first 9 characters (including space) to hex and add two zeros to the end. Give importance to Uppercase and lowercase for letters.
APPLE SSD --> 4150504C4520535344
Samsung S --> 53616D73756E672053

HDMI audio:
For HD4600 HDMI audio in M6H board, u need the following (provided 'Inject Intel' is already applied)

  1. SSDT/DSDT patch (DropTables for SSDT may be required)
  2. Framebuffer edit (through config.plist edit)
  3. Audio ID : 1 (in config plist)
  4. Kext patches for AppleHDAController (described above)
1.) Since i am using clover for SSDT generation, no SSDT is present inside EFI/CLOVER/ACPI/patched. Hence, i renamed the downloaded SSDT-1.aml to SSDT.aml, and add it to EFI/CLOVER/ACPI/patched. AMI-no_p0p2-HD4600-AMD-Nvidia-A1.zip worked for me. Under DropTables for SSDT (in clover configurator), add the following:Signature:"SSDT", Key:"TableId", String:"SaSsdt ". Need to add a space after SaSsdt. If u r using a custom SSDT.aml (ssdtPRGen.sh) and using Drop OEM, then there is no need to add "SaSsdt " under DropTables. In that case, downloaded SSDT-1.aml could be added without any name change.
2.) Since, i have already added kext binary patch for framebuffer in order to solve 'no display' issue, i didn't do the 2nd step.
3.) Already had audio id-1 in config plist.
4.) Added 2 patches for AppleHDAController under KextsToPatch (described above)

118657-ssdt-hdmi-audio.png


Realtek patch in place
method will enable onboard audio. Realtek patched kext will support HDMI audio.
For wifi, may need to reboot twice in order to load IO80211Family.kext (First time without caches). But this does not work for me. For fresh installation, I found it difficult to load IO80211Family.kext without manual infoplist edit. Hence i installed the edited kext. On restart, the kext loads. Then on applying 10.10.1 update, the clover patch works. No need to do infoplist edit again.

I have attached my config.plist (minus SMBios section)

Refer to Update:1 in post#1 for updating firmware & restoring performance of Samsung 840 evo SSD.
 

Attachments

  • config.plist
    4.2 KB · Views: 417
  • Sound output.png
    Sound output.png
    76.9 KB · Views: 407
Last edited by a moderator:
Joined
Jun 26, 2013
Messages
10
Mac
Classic Mac
Mobile Phone
Is there a noob friendly version of this guide somewhere on this forum? :p
 
Joined
Jun 26, 2013
Messages
10
Mac
Classic Mac
Mobile Phone
I'll give it a shot this weekend.

My setup is as follows:

4670K
Maximus VI Hero
Radeon 7970
16GB

Now I have an SSD but it has no partitions. It has Windows on it. Would you recommend installing Mac to it as well? (after I've created a partition on it ofc).

My other HDDs are a Seagate 2TB and a WD 500GB.
 
Joined
Jun 25, 2014
Messages
85
Motherboard
MSI Z390-A PRO
CPU
i5 8400
Graphics
R9 380
Mobile Phone
  1. iOS
@ asknask
I have a working dual boot configuration of Yosemite and Windows 8.1 on my SSD using Clover UEFI. There are tons of guides out there. But I tried it in a simple way. I first installed yosemite and then installed windows 8.1 in GUID partition scheme. Diable CSM (compatibility support module) in BIOS if not done already. This step is not mandatory. But this will prevent non-UEFI versions of hard drive/ flash drive from being detected.
1.) Create yosemite installer using clover UEFI settings (need access to mac) and windows installer using rufus (in a windows PC). Select 'GPT partition scheme for UEFI computer' under partition scheme in rufus.
2.) Change the bios settings, and boot into yosemite installer flash drive (by pressing F8). At the installer screen, open disk utility and create 2 partitions using GUID partition scheme.
1st partition - Mac OS Extended (Journaled). Name it according to ur preference.
2nd partition - Free space
3.) Finish mac os installation as per the guide. Solve common issues like audio, graphics, wifi, etc.
Then, format EFI partition to FAT32, and install clover using UEFI settings. Edit config plist according to ur system. Eject yosemite installer flash drive, Restart and see if everything works.
4.) Insert windows installer flash drive and Restart. Enter rufus flash drive. At the installer screen, select unallocated space and create New partition (Leave 5 GB if wanna create recovery partition). Installer will create two partitions - one for MSR (reserved) & one for installation. Click 'Next' and finish installation. Windows will install its boot files in EFI partition in a folder named 'Microsoft'. After finishing installation, Change boot priority in BIOS, so that ur UEFI SSD (not Windows Boot Manager) is in 1st priority. Now u will be able to boot into both OS using clover. No need to do additional steps or tweaks.
5.) Boot into mac os, Mount EFI partition (using clover configurator / EFI mounter / Terminal). Take backup of 'Microsoft' folder inside EFI. If something goes wrong, u can reformat EFI partition as FAT32, install clover, replace config.plist, copy SSDT.aml and then copy 'Microsoft' folder (Windows boot files) into EFI folder inside EFI partition.
115026-dual-boot.jpg
Note: Windows installer will create 100MB EFI partition, while Disk Utility will create 200MB EFI partition.Thats why i installed Mac OS X first, formatted EFI to fat32, installed clover and then installed windows.

If u need FaceTime/imessage, then u should follow Fix iMessage guidelines while creating config plist.
 
Last edited by a moderator:
Joined
Nov 14, 2014
Messages
5
Motherboard
Throne - Maximus VI Hero
CPU
i5-4670K
Graphics
Gigabyte GTX 760 OC 4GB
Mac
Classic Mac
Mobile Phone
  1. Android
Hi there Dr. Kkarun,

So, I got everything working to a point, meaning that when I get to the part for the SSDT.aml file, it spits an error back in Terminal that reads as follows.

-------

Bugs > https://github.com/Piker-Alpha/ssdtPRGen.sh/issues <


System information: Mac OS X 10.9.4 (13E28)
Brandstring 'Intel(R) Core(TM) i5 CPU M 520 @ 2.40GHz'


Warning: The brandstring has an unexpected length!


Error: Unknown processor model ...
Aborting ...
Done

--------

There was no SSDT.aml generated so I'm assuming that this is an actual failure and not an error message I can ignore. I'm using a Macbook Pro 6,2 with a 2.4 GHz i5 with 4GB of RAM for the flash drive creation parts.

My main system details are very similar to what you've used in this guide minus the SSD.

Rosewill Throne Case
Intel Core i5 4670K
8 GB of G-Skill Ripjaw X 1866
Gigabyte GTX 760 4GB
Asus Maximus VI Hero

Both hard drives are WD Blue 7,200 RPM drives, my main is a 1TB with Windows 7 Pro, the second is a 160GB that's partitioned for the OSX install.


Despite that bit, I still got it to boot off of the flash drive, got it to the installation part, but when I went to partition the hard drive I was installing OSX on, I didn't select the GUID Partition for the installation and it kicked back an error.

So I repartitioned it and went back to try and begin the installation again, and I got a kernel panic cpu 0 caller error, with an error code I neglected to write down, but it can be found in other posts here on the tonymacx86 forums. From memory it looked similar to this one :
panic (cpu 0 caller 0xffffff80002dc19e) though it's definition code may be different.

Also, when I shut my computer down and took the flash drive out, and re-inserted it into the MacBook, the org.chameleon.boot.plist had been erased some how. Is that to be expected after running the installation or is it an issue I should be concerned with?

Lot to answer, and I appreciate any insight you can give me in to this. So far your method is the only one posted that's worked with the Maximus VI Hero or at the very least my build specifically.

Thanks
 
Status
Not open for further replies.
Top