Contribute
Register

Succesful Mojave on p8z77-v deluxe / i7-3770 (details)

Joined
Apr 17, 2019
Messages
2
Hi!

I thought I would share with you all my experience because it didn't work at first and I searched for this setup and could not find anything that helped. ASUS p8z77-v Deluxe with i7-3770.

Ok. Went through everything on https://www.tonymacx86.com/threads/unibeast-install-macos-mojave-on-any-supported-intel-based-pc.259381/

Here are the details on what I had to figure out on my own:

1st: Make sure the flash drive is GPT (or guid). The disk utility on macos doesn't always show the option for some reason. My first install on flash drive did not boot at all. So I inserted the flash drive on my windows pc and saw it was MBR so I changed the partition scheme to GPT (using minitool partition wizard free). Did the flash drive creation process again and now it boots! Ps. I also used legacy boot this second time around just to try, maybe this helped too, although I don't think that was it since this motherboard does support UEFI boot.

2nd: Motherboard:
I updated the BIOS to the latest from asus website (version 2104 at https://www.asus.com/Motherboards/P8Z77V_DELUXE/HelpDesk_BIOS/ ). If you can't get it to work on your current bios maybe updating helps, just download the file, put it on a flash drive, boot the system, go to the last page on the bios advanced settings, select ez flash, select the file and hit enter.
On the motherboard there are two switches, one for TPU and another for EPU. I switched both off.
BIOS settings I changed after resetting to default are as follows. Maybe not all of them were really necessary. (The settings listed on the guide are not all available).

Advanced mode> Advanced Tab:
USB Configuration > Intel xHCI Mode : Enabled and EHCI Hanf-Off : Enabled
Onboard Devices Configuration > Marvell Storage Controller : Disabled

Boot tab:
Fast Boot : Disabled
Secure Boot > Os Type : Other OS

3rd: Ok I'm on the clover screen. Tried booting the installation several times and it did not work. I tried changing several settings inside clover. The installation only worked liked this: leave the clover options alone, select the boot installation, press space bar, enable safe mode AND DISABLE the nvidia VESA (nv_disable=1) thing. Everything else is unchecked (only safe mode checked). Then select boot with selected options and hit enter. The apple logo will appear and the system will reboot back to the flash drive's clover and now there is an option to boot macos from the hard drive, select that, hit space bar, do the same options as before. Now it successfully goes into macos just fine.

Screen has no lag, no bugs. Didn't test audio. USB 3 ports do not work.

Funny things (didn't happen as it was described on the guide):
I had NO installation dialogues AT ALL. It just simply installed on the one hard drive there was available. That HDD was already empty (no files) and I don't know what format was it.
When it boots it has the same account name configured as the mac I used to create the flash drive had. So you will need to know that person's password to be able to log in. Funny thing it is NOT their current login password! That didn't work, so I tried other passwords I know he's used on other macs and that worked. It is not either his icloud password. It somehow used an account name and password from another mac, go figure, I have no clue.
It also has installed a few apps he had on that mac, this is not a clean install.

4th: MultiBeast: Restart the system and this time do not use safe mode, but do disable the nvidia thing. Run MultiBeast. There I used these:
Legacy boot mode - just to be sure since the flash drive worked fine on legacy mode. (Again just citing this because it might be an issue)
Audio>AppleALC - tested the audio again after install and reboot and it works. (note I had not tested it before)
USB>3rd Party USB 3.0 and Remove XHCI USB Port Limit - USB 3 ports now work.
Did not select anything else.
Turn off.
Remove the installation flash drive.
Boot.
Do not let it automatically boot the macos after a few seconds, press spacebar and uncheck the nvidia thing again (I'm not willing to try leaving that on now that everything works lol). Now next times you boot it will already have everything unchecked you can allow it to auto boot.

WiFi is still unavailable. I don't know which network driver from multibeast do I need. I will search this and post a reply and edit the original post as soon as I figure out which one.

To do list to update later:
1- I will add an AMD RX 590 (which I believe is supposed to work natively on Mojave).
2- Repeat the whole installation on a new SSD.
3- Get working the WiFi and network cable.
4- Start fresh with a new account and without the software that came installed.

Also, as this computer gets real-life-use (video and photo production using final cut x and adobe stuff), I will come back and tell is anything wrong or everything is 100%. Within a few weeks from now.
 
Joined
Apr 17, 2019
Messages
2
Ok, I can't delete the thread so I will leave it here for now...

Turns out the HDD I used was one that was previously used on an actual MAC. So this is where all the weirdness came from. Bottomline it works, but the only thing it did was somehow turn the previous installation of a mac mini into a hackintosh.

I will try everything again from scratch and then update. lol.... don't judge, we have a LOT of hard drives laying around here.
 
Last edited:
Joined
Sep 21, 2013
Messages
3
Motherboard
Asus P8Z77-V Pro (2104)
CPU
Intel i7 3770K
Graphics
EVGA GTX 680 SC Sig2
Mac
Classic Mac
Mobile Phone
Does sleep/wake work for you?
 
Top