Contribute
Register

Stork's Gene Build > ASUS MAXIMUS VIII GENE Z170 - i5-6600K - MSI Vega 56

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,629
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Applied the 10.13.4 Security update. The Nvidia driver System Preference Pane nagged me about updating to the newest driver which I did. While awaiting for the driver to be updated, I noticed that the Security Update applied new audio and I lost audio. So, I didn't click on the driver's Reboot button. I ran MultiBeast just reappliing the ALC1150 audio:
Drivers > Audio > Realtek ALC1150
Build
Install​

Before rebooting, I applied the following command in the Terminal for good measure:
sudo touch /System/Library/Extension​

and then I clicked on the driver installer's Reboot button. Now, Everything works as it should. :thumbup:
 
Last edited:

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,629
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Updated the BIOS to the latest version which was released 3801 as of April 26, 2018 although the 3801 internal date is March 14, 2018.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,629
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Finally got around to updating my build description (Post#1). I just replaced the GTX 1060 I was using to test the newest Nvidia driver (...30.107) to see if they fixed the wake-up from sleep glitchiness. (Yes, they did.)

Gene now has a Nvidia GTX 1080 Founders Edition graphics card that I bought last month from Nividia's online store for ~$550 USD (plus shipping and tax). :clap: I couldn't resist the price since the current prices at Amazon and Newegg are/were at the time $735+ USD. Graphics are handled sooo much quicker, and the GTX 1080 FE hands two monitors, one of which is a Dell 4K monitor, without showing any pain.

Some days you're the bug and some days you're the windshield. :thumbup:
 
Joined
Feb 25, 2014
Messages
22
Motherboard
ASUS ROG Maximus VIII GENE LGA 1151
CPU
Intel Core i7 6700k
Graphics
Gigabyte GTX 1050 Ti
Stork, I have a very similar build with the same motherboard and I'm having issues detecting my Keyboard and Mouse when I get to the Apple Language selection screen. Any suggestions?
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,629
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Stork, I have a very similar build with the same motherboard and I'm having issues detecting my Keyboard and Mouse when I get to the Apple Language selection screen. Any suggestions?
Are your keyboard and mouse USB or wireless? If USB, make sure they are plugged into the USB 3 stack under the PS/2 plug and/or the Ethernet plug.
 
Joined
Jan 27, 2018
Messages
55
Motherboard
ASUS x299 Deluxe
CPU
i9-7940x
Graphics
Vega 64
Mac
iMac, MacBook Pro
Hey Stork,

congratulations on the build guide, it worked brilliantly for me. I'm on Intel 530 with no dedicated GPU installed and I'm getting a reboot loop/ MoBo code 30 if I put the computer to sleep. Do I need to mess with Lilu and IntelGraphicsFixup?

Thanks,

Dan
 
Last edited:

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,629
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Hey Stork,

congratulations on the build guide, it worked brilliantly for me. I'm on Intel 530 with no dedicated GPU installed and I'm getting a reboot loop/ MoBo code 30 if I put the computer to sleep. Do I need to mess with Lilu and IntelGraphicsFixup?

Thanks,

Dan
I don't know since I've always used a dedicated graphics card in my newer builds. A quick search in the Graphic forum section came up with this thread which indicates that you will need Lilu and IntelGraphicsFixup > https://www.tonymacx86.com/threads/is-intel-hd-530-working-without-intelgraphicsfixup-on-high-sierra.249470/.

Good luck!
 
Joined
Jul 5, 2017
Messages
6
Today, my H90 Corsair cpu cooler/fan decided to stop playing nicely with the Asus QFan control in the BIOS.

At startup, the CPU fan just didn't spin. If I go to the Monitor tab, I can disable the Qfan control altogether which makes the fan run at 100% all the time (kinda annoying). But if I put the CPU fan control on any of the other options (DC, Auto, PWM), the fan stops completely.

This system has been stable for months. I am still running BIOS 3401. Any thoughts? I was thinking I could work around it by downloading corsair's independent Corsair Link software, but I can't download it on Mac OS.
 
Joined
Apr 6, 2016
Messages
3
Motherboard
ASUS Maximus VIII Gene
CPU
i5 6400
Graphics
HD 530
Mac
MacBook Pro
Mobile Phone
iOS
First: Thanks Stork; your guide got my first Hackintosh build up and running a few years back. You're a treasure.

I just wanted to note that I've successfully updated to the Mojave beta from this build (using Mac native update process). Some notes:

Updated clover before attempting.
High Sierra was running on a NVMe m.2/ SATA HDD Fusion before update. Update process converted the Fusion drive to APFS as expected and seems to be working fine.

Edit: That fusion is still working fine. But if you happen to have two HDDs and an SSD and a fetish for Fusion; read on.
I had the two HDDs and single SSD in a separate fusion setup as one of my backup drives. Don't judge; I had a couple of spare 6TB drives lying around. I thought I'd see if I could get an AFPS fusion running on the three of them. An AFPS fusion drive has a container that spans two disks, so I figure why not three? In Corestorage you just create an LVG from the three (diskutil cs create nameofdevice diskxSx diskySy diskzSz) and then create a corestorage volume on the group. APFS has a similar command for creating a fusion drive (diskutil APFS createContainer diskxSx diskySy) which creates a container across the two disks and treats the faster drive preferentially for system and often-accessed files (unverified, but it purports to and I'll trust it). But you can't add a third disk/volume to that command as you would in corestorage or you get a "too many disks" error.
So I wondered about how to circumvent that. You can't seem to create an APFS formatted Corestorage volume on a Corestorage LVG. You can create and APFS formatted 3-disk JBOD RAID using raid assistant, but there's nothing that suggests that behaves like a fusion drive.
So I figured I'd try creating a JHFS+ formatted RAID from the two 6TB drive, then make an APFS Fusion container across the SSD and the RAID volume...
Well, the machine crashed at that point and has yet to restart. I'll go troubleshoot it now, but my advice is maybe don't be crazy like me and try to APFS Fusion a RAID array with an SSD.

Had to rerun Multibeast with just IntelMausiEthernet selected, which got ethernet working fine.

Lost audio. Took ages to get it working again. Installed most recent Lilu.kext and AppleALC.kext. This requires that AppleHDA.kext is stock and unpatched.
You may have to go to your config.plist/clover cofigurator and disable kext patches related to HDA.
Set Audio inject to "2" (1 is removed in Mojave).
In config.plist>Acpi I disabled the patch "rename HDAS to HDEF"
I may have got rid of other cruft from previous audio fixes. I was in over my head with this but got there in the end.

Once Mojave is out of beta and supported by Unibeast/Multibeast I'll probably do a clean install, but for now it's working enough for my purposes. Haven't tested handoff/messages/icloud etc as I don't use them on this machine.

Edit: Carbon Copy Cloner has a Beta out for Mojave, but it isn't quite there yet for cloning Mojave installations. (As of Aug 19).

ASUS Maximus VIII Gene
Intel HD 530 integrated graphics
Intel Core i5 6400 @2.7Ghz
16GB Corsair ram @2667Mhz
WD Black NVMe M.2 SSD 250GB + Seagate Barracuda Pro 10TB = 10.25Tb Fusion drive
 
Last edited:
Top