[solved] HD 4400 Graphics not working correctly

Discussion in 'High Sierra Laptop Support' started by speedyrazor, Jul 31, 2018.

  1. speedyrazor

    speedyrazor

    Joined:
    Oct 12, 2012
    Messages:
    182
    Motherboard:
    HP Probook 4540s
    CPU:
    i5-3230m
    Graphics:
    HD 4000
    Mobile Phone:
    iOS
    Jul 31, 2018 at 11:34 AM #1
    speedyrazor

    speedyrazor

    Joined:
    Oct 12, 2012
    Messages:
    182
    Motherboard:
    HP Probook 4540s
    CPU:
    i5-3230m
    Graphics:
    HD 4000
    Mobile Phone:
    iOS
    Hi, I have a Dell XPS 13" 9333 with HD 4400 graphics. I have a lot of stuff working, and some stuff not:

    Working:
    Wifi (BCM94352Z)
    Bluetooth
    Trackpad

    Not Working:
    Graphics (glitchy, only showing 7MB)
    Sound
    Touch Screen (Synaptics)

    I am a bit stuck, at least with Graphics and sound, if someone could assist please, I would really appreciate it.
    Problem reporting logs attached.
     

    Attached Files:

  2. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    185,283
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Aug 1, 2018 at 8:30 PM #2
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    185,283
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Your ACPI configuration is wrong.
    See guide:
    https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/
     
  3. speedyrazor

    speedyrazor

    Joined:
    Oct 12, 2012
    Messages:
    182
    Motherboard:
    HP Probook 4540s
    CPU:
    i5-3230m
    Graphics:
    HD 4000
    Mobile Phone:
    iOS
    Aug 13, 2018 at 8:16 AM #3
    speedyrazor

    speedyrazor

    Joined:
    Oct 12, 2012
    Messages:
    182
    Motherboard:
    HP Probook 4540s
    CPU:
    i5-3230m
    Graphics:
    HD 4000
    Mobile Phone:
    iOS
    OK, all redone from scratch. Most is all good, this is where I am (debug logs attached):

    Working:
    Wifi (BCM94352Z)
    Bluetooth
    Trackpad
    Graphics

    Not Working:
    Sound
    Touch Screen (Synaptics)

    Not sure if graphics is correct, as Safari wont play m3u8 streams (missing plugin). What am I missing please?

    Regards.
     

    Attached Files:

  4. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    185,283
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Aug 13, 2018 at 5:10 PM #4
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    185,283
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Your ioreg shows working graphics (QE/CI).
    See FAQ for other topics:
    https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
     
  5. speedyrazor

    speedyrazor

    Joined:
    Oct 12, 2012
    Messages:
    182
    Motherboard:
    HP Probook 4540s
    CPU:
    i5-3230m
    Graphics:
    HD 4000
    Mobile Phone:
    iOS
    Aug 15, 2018 at 10:41 PM #5
    speedyrazor

    speedyrazor

    Joined:
    Oct 12, 2012
    Messages:
    182
    Motherboard:
    HP Probook 4540s
    CPU:
    i5-3230m
    Graphics:
    HD 4000
    Mobile Phone:
    iOS
    I think I have the most of it working (debug logs attached):

    Working:
    Wifi (BCM94352Z)
    Bluetooth
    Trackpad (no gestures though)
    Graphics
    Sound (although, if no sound for a while, I get a crackle / tick as sound plays, only at start of sound playing)

    Not Working:
    Touch Screen (see below)
    Sleep / wake

    I can see the touchscreen attached to the USB, but it's not working:

    Code:
    USB 2.0 Bus:
      Host Controller Driver:    AppleUSBEHCIPCI
      PCI Device ID:    0x9c26
      PCI Revision ID:    0x0004
      PCI Vendor ID:    0x8086
    
    Hub:
      Product ID:    0x8000
      Vendor ID:    0x8087  (Intel Corporation)
      Version:    0.04
      Speed:    Up to 480 Mb/sec
      Location ID:    0x1d100000 / 1
      Current Available (mA):    500
      Current Required (mA):    0
      Extra Operating Current (mA):    0
      Built-In:    Yes
    
    Synaptics Large Touch Screen:
      Product ID:    0x0af8
      Vendor ID:    0x06cb  (Synaptics Inc.)
      Version:    0.02
      Speed:    Up to 12 Mb/sec
      Manufacturer:    SYNAPTICS
      Location ID:    0x1d130000 / 2
      Current Available (mA):    500
      Current Required (mA):    144
      Extra Operating Current (mA):    0
     

    Attached Files:

  6. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    185,283
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Aug 15, 2018 at 10:49 PM #6
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    185,283
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Your USB configuration is not correct.
    See guides linked from the FAQ.

    Note: The fact that you renamed XHC->XHC1 is a mistake.
     
  7. speedyrazor

    speedyrazor

    Joined:
    Oct 12, 2012
    Messages:
    182
    Motherboard:
    HP Probook 4540s
    CPU:
    i5-3230m
    Graphics:
    HD 4000
    Mobile Phone:
    iOS
    Aug 22, 2018 at 10:36 PM #7
    speedyrazor

    speedyrazor

    Joined:
    Oct 12, 2012
    Messages:
    182
    Motherboard:
    HP Probook 4540s
    CPU:
    i5-3230m
    Graphics:
    HD 4000
    Mobile Phone:
    iOS
    OK, I have removed the XHC->XHC1 rename, and followed the 'Creating a Custom SSDT for USBInjectAll.kext' guide, created my custom SSDT-UIAC.aml, but still I don't seem to have USB injecting correctly. Using 'FakePCIID_XHCIMux.kext' I have:

    Code:
    SSP1 > USB3 Right
    SSP2 > USB3 Left
    PR11 > Internal Hub
    HP11 > USB2 Right
    HP12 > USB2 Left
    HP13 > Synaptics Large Touch screen
    HP15 > Webcam
    HP16 > BCM20702A0
    I edited the SSDT-UIAC-ALL.dsl, complied, renamed to SSDT-UIAC.aml and placed in ACPI/patched, removed -uia_ignore_rmcf, but still remains the same. I have attached new debug logs.
    Thanks.
     

    Attached Files:

  8. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    185,283
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Aug 23, 2018 at 3:25 AM #8
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    185,283
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Your ioreg still shows XHC1. UsbInjectAll.kext requires XHC.

    Your ACPI/patched content is wrong. See guide:
    https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/
     
  9. speedyrazor

    speedyrazor

    Joined:
    Oct 12, 2012
    Messages:
    182
    Motherboard:
    HP Probook 4540s
    CPU:
    i5-3230m
    Graphics:
    HD 4000
    Mobile Phone:
    iOS
    Aug 25, 2018 at 7:46 AM #9
    speedyrazor

    speedyrazor

    Joined:
    Oct 12, 2012
    Messages:
    182
    Motherboard:
    HP Probook 4540s
    CPU:
    i5-3230m
    Graphics:
    HD 4000
    Mobile Phone:
    iOS
    OK, I hope I have got rid of XHC1, I have recreated my custom SSDT-UIAC.aml, but still in IORegistryExplorer I can see the
    Synaptics Large Touch screen is not happy, every time I touch the screen I see a new 'crossed out' Synaptics Large Touch screen entry in PCIO/AppleACPIPCI/EH01/PR11/IOUSBHostDevice/AppleUSB2OInternalHub/HP13.
    Obviously I am still doing something wrong, but unsure of what that is. I have attached new debug logs.
     

    Attached Files:

    Last edited: Aug 25, 2018
  10. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    185,283
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Aug 29, 2018 at 7:42 PM #10
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    185,283
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Your touchscreen may not be supported. Probably best to simply disable it by eliminating the HP13 port.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice