Contribute
Register

[Solved] Hard disk not shown in bootloader screen after reboot of successful installation of Sierra.

Status
Not open for further replies.
Joined
Sep 20, 2010
Messages
29
Motherboard
GA-X58A-UD3R V2.0 (FH)
CPU
Intel Core i7 (First Gen)
Graphics
ATI Radeon HD 5700 Series
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi,

Tried following this guide to do a fresh install of Sierra. I had chosen Legacy Boot option while creating Unibeast USB. Could boot from USB and install Sierra successfully. Restarts into Clover bootloader screen but my hard disk - where I have installed Sierra - is not shown in the hard disk list. There are no other hard disks or any other connections to the desktop.

My build is GA-X58A-UD3R (Ver 2.0), Firmware FH (latest) with 2 Crucial Ballistix Tactical 8 GB RAM sticks (total 16 GB), AMD Radeon HD 5700, Samsung 1TB HD.

The version of the Unibeast 7.1.1.

Any help will be deeply appreciated. Thanks in advace.
 
Last edited:
Joined
Mar 10, 2016
Messages
964
Motherboard
Asus Z87 Pro WLAN
CPU
i7-4770K
Graphics
HD 4600 // GTX 980
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi,

Tried following this guide to do a fresh install of Sierra. Could boot from USB and install Sierra successfully. Restarts into Clover bootloader screen but my hard disk - where I have installed Sierra - is not shown in the hard disk list. There are no other hard disks or any other connections to the desktop.

My build is GA-X58A-UD3R (Ver 2.0), Firmware FH (latest) with 2 Crucial Ballistix Tactical 8 GB RAM sticks (total 16 GB), AMD Radeon HD 5700, Samsung 1TB HD.

The version of the Unibeast 7.1.1.

Any help will be deeply appreciated. Thanks in advace.
Have you implement HFSPlus.efi in EFI/Clover/drivers64UEFI?
 
Joined
Jul 25, 2012
Messages
6,711
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi,

Tried following this guide to do a fresh install of Sierra. Could boot from USB and install Sierra successfully. Restarts into Clover bootloader screen but my hard disk - where I have installed Sierra - is not shown in the hard disk list. There are no other hard disks or any other connections to the desktop.

My build is GA-X58A-UD3R (Ver 2.0), Firmware FH (latest) with 2 Crucial Ballistix Tactical 8 GB RAM sticks (total 16 GB), AMD Radeon HD 5700, Samsung 1TB HD.

The version of the Unibeast 7.1.1.

Any help will be deeply appreciated. Thanks in advace.

  • You can try by Clearing CMOS by removing the coin battery for a 1 minute and reinserting it and rebooting. [See uploaded image]
  • On Powering on "Load Optimized Default BIOS and then reboot"
  • Press Del key >Enter BIOS setup
  • Make sure you readjust the Year , Month , Date and Time to the current.
  • Make all the required BIOS setup option for the Sierra Booting as you had done before.
  • Make sure you can see your Target Sierra HDD and Sierra USB installer in the BIOS Boot Options and for the present boot, select the Sierra USB installer as the first boot device
  • Try booting into CLOVER Boot Manager screen and then make sure you have the right Boot flags in Options>Boot Args: -v dart=0 kext-dev-mode=1 (examples)
  • Now try to boot with your Sierra HDD and see if you can reach the Desktop.
  • Once on the desktop if you have not installed CLOVER Bootloader , required kexts and the System Definitions on the Sierra System Disk , do so using Multibeast 9.01 for Sierra
  • Using Clover Configurator downloaded , Mount the Efi Partition of the System Disk and edit the EFI>EFI>CLOVER>config.plist in CC-V to make the disk bootable with all the needed Boot flags.
 

Attachments

  • Clear CMOS.png
    Clear CMOS.png
    91.9 KB · Views: 112
Joined
Sep 20, 2010
Messages
29
Motherboard
GA-X58A-UD3R V2.0 (FH)
CPU
Intel Core i7 (First Gen)
Graphics
ATI Radeon HD 5700 Series
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Thanks cmn699. I followed your suggestion of clearing the CMOS, entering the correct BIOS settings. In the BIOS list of hardware, I could see both the USB and the harddisk. However, when I booted into Clover, it lists only the USB - hard drive is not listed. Just to check, I chose the boot from USB. It booted from the unibeast USB and went to the install Sierra screen. When I used disk utility in the installer, it lists the hard disk.

Still stuck at the same place. Any suggestions please? Thank you
 
Joined
Sep 20, 2010
Messages
29
Motherboard
GA-X58A-UD3R V2.0 (FH)
CPU
Intel Core i7 (First Gen)
Graphics
ATI Radeon HD 5700 Series
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Have you implement HFSPlus.efi in EFI/Clover/drivers64UEFI?

I downloaded HFSPlus.efi and copied that into the folder you mentioned HorchaudiBMW. I also deleted the VF*HFS*.efi (forgot the the full name of this EFI but it was also for hfsplus). Still did not work.

I forgot to mention in the first message that I had chosen Legacy Boot option while creating the UniBeast USB as my motherboard does not support EFI.

Any suggestions please? Thank you.
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,380
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
Joined
Sep 20, 2010
Messages
29
Motherboard
GA-X58A-UD3R V2.0 (FH)
CPU
Intel Core i7 (First Gen)
Graphics
ATI Radeon HD 5700 Series
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Your motherboard uses the Marvell 9182 controller.
Did you use Clover with CloverEFI > CloverEFI 64-bits BiosBlockIO instead of CloverEFI 64-bits SATA ?
See BiosBlockIO: Fix for Clover recognizing non-Intel SATA controlled Drives

Thanks BreBo.
Downloaded the clover package and ran the installer to choose the cloverEFI 64-bits BiosBlockIO (on the same USB that I created using the guide I mentioned earlier.

Still did not find the hard disk. Is the way of running the installer on the USB to upgrade the BiosBlockIO wrong? Please let me know.

Thanks in advance.
 
Joined
Sep 20, 2010
Messages
29
Motherboard
GA-X58A-UD3R V2.0 (FH)
CPU
Intel Core i7 (First Gen)
Graphics
ATI Radeon HD 5700 Series
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Tried following this guide to do a fresh install of Sierra. I had chosen Legacy Boot option while creating Unibeast USB. Could boot from USB and install Sierra successfully. Restarts into Clover bootloader screen but my hard disk - where I have installed Sierra - is not shown in the hard disk list. There are no other hard disks or any other connections to the desktop.

My build is GA-X58A-UD3R (Ver 2.0), Firmware FH (latest) with 2 Crucial Ballistix Tactical 8 GB RAM sticks (total 16 GB), AMD Radeon HD 5700, Samsung 1TB HD.

The version of the Unibeast 7.1.1.

Any help will be deeply appreciated. Thanks in advace.

The USB and HDD are showing in BIOS but not in the bootloader screen. Please help.
 
Joined
Sep 20, 2010
Messages
29
Motherboard
GA-X58A-UD3R V2.0 (FH)
CPU
Intel Core i7 (First Gen)
Graphics
ATI Radeon HD 5700 Series
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Status
Not open for further replies.
Top