Contribute
Register

Radeon RX 4XX/5XX standalone system, AMDRadeonX4250.kext (GVA support H264) does not support HEVC HW

Joined
Aug 29, 2013
Messages
3
Motherboard
Hasee A560-i7
CPU
i7-720QM/HM55
Graphics
GT335
With my Xeon E5 2680v2 with SMBIOS iMacPro1.1 not work mouse and keyboard, but all works. I have use MacPro6.1. Works Netflix with Safari??? Not to me, HTML5 or Silverlight not support.
me2
 
Joined
Feb 27, 2016
Messages
19
Motherboard
GA-Z97X-Gaming 3
CPU
i5-4460
Graphics
RX 570
Mac
iMac
Hello!
I can't get H264 hardware acceleration running. I tried already several approaches and at least got HEVC working though setting my MacModel. Can somebody help me get this to work?

My system is in the signature I believe. :)

What I have tried already:
(ref: https://www.tonymacx86.com/threads/radeon-rx-4xx-5xx-standalone-system-amdradeonx4250-kext-gva-support-h264-does-not-support-hevc-hw.240353/page-87)

1. Enable IGPU in BIOS, Inject->Intel=Yes, and use connector-less ig-platform-id=0x01620007. Or,
2. Change SMBIOS model type to iMacPro1,1. But you will get green glitches in the H.264 output. Or,
3. Keep your SMBIOS as-is and add boot flags: shikigva=32 and shiki-id=Mac-7BA5B2D9E42DDD94. Or,
4. Wait for MacOS 10.14.5 update
 

Attachments

Joined
May 11, 2011
Messages
646
Motherboard
Asrock B365M Phantom Gaming
CPU
i5-8400
Graphics
UHD 630 + RX 580
Mobile Phone
iOS
Hello!
I can't get H264 hardware acceleration running. I tried already several approaches and at least got HEVC working though setting my MacModel. Can somebody help me get this to work?

My system is in the signature I believe. :)

What I have tried already:
(ref: https://www.tonymacx86.com/threads/radeon-rx-4xx-5xx-standalone-system-amdradeonx4250-kext-gva-support-h264-does-not-support-hevc-hw.240353/page-87)

1. Enable IGPU in BIOS, Inject->Intel=Yes, and use connector-less ig-platform-id=0x01620007. Or,
2. Change SMBIOS model type to iMacPro1,1. But you will get green glitches in the H.264 output. Or,
3. Keep your SMBIOS as-is and add boot flags: shikigva=32 and shiki-id=Mac-7BA5B2D9E42DDD94. Or,
4. Wait for MacOS 10.14.5 update
4.Install MacOS 10.14.5, disable IGPU and SMBIOS iMacPro 1,1.
 
Joined
Feb 27, 2016
Messages
19
Motherboard
GA-Z97X-Gaming 3
CPU
i5-4460
Graphics
RX 570
Mac
iMac
4.Install MacOS 10.14.5, disable IGPU and SMBIOS iMacPro 1,1.
LOL
I am on 10.14.5 ✅
disabled IGPU ✅
iMacPro1,1✅

H.264 hardware exc. ❌
HEVC hardware exc. ✅
 

Attachments

Last edited:
Joined
Mar 9, 2011
Messages
626
Motherboard
Gigabyte Z390 UD
CPU
i9-9900K
Graphics
Vega 56
Mac
iMac, MacBook Pro, Mac Pro
Classic Mac
iMac
Mobile Phone
iOS
LOL
I am on 10.14.5 ✅
disabled IGPU ✅
iMacPro1,1✅

H.264 hardware exc. ❌
HEVC hardware exc. ✅
Do not inject intel or define an ig-platform-id. Just use WEG and lilu. I don't know if the RX570 will play nice with the iMac Pro 1,1 SMBIOS. Why dont you use iMac 14,2? Also remove the shikigva flag and radeondelnit. Do you make much use of HEVC?
I think the people changing to the iMac Pro SMBIOS are people with the Vega GPU
 
Top