Contribute
Register

Radeon Compatibility Guide - ATI/AMD Graphics Cards

Joined
Dec 10, 2014
Messages
17
Motherboard
ASRock H97M Pro4
CPU
i5-4670k
Graphics
RX 590 Sapphire Pulse
Hoping someone can help me out since I've been out of the hackintosh loop for years.

I built/installed one 5 years ago and want to upgrade my GPU from a GTX 760 to RX 580 Sapphire Pulse. I heard the sapphire pulse works right out of the box with no kexts needed (right?).

I'm thinking all I have to do is upgrade my OS from Mavericks to Mojave? and then replace the GPU?

What's the "easiest" way to get this GPU upgrade going without having to wipe my OS?
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,874
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I heard the sapphire pulse works right out of the box with no kexts needed (right?).


@littyboy,

There are very few GPU's (if any) that work OOB ... A PC's ACPI tables are very different to a Mac's EFI, as such when a GPU is added to a Hackintosh the ACPI device name is usually wrong (EG PEG0 when it should be GFX0).

And depending upon the GPU type certain other MacOS device properties may need to be set to avoid the common black screen on boot issue and display connectors not working.

We generally recommend installing Lilu + WhatEverGreen which will ensure that the RX 580 is configured correctly.

Cheers
Jay
 
Joined
Jan 20, 2020
Messages
14
Motherboard
Gigabyte B360N Wifi
CPU
i5 9400F
Graphics
RX570
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
[removed]
 
Last edited:
Joined
Dec 10, 2014
Messages
17
Motherboard
ASRock H97M Pro4
CPU
i5-4670k
Graphics
RX 590 Sapphire Pulse
@littyboy,

There are very few GPU's (if any) that work OOB ... A PC's ACPI tables are very different to a Mac's EFI, as such when a GPU is added to a Hackintosh the ACPI device name is usually wrong (EG PEG0 when it should be GFX0).

And depending upon the GPU type certain other MacOS device properties may need to be set to avoid the common black screen on boot issue and display connectors not working.

We generally recommend installing Lilu + WhatEverGreen which will ensure that the RX 580 is configured correctly.

Cheers
Jay

thanks. Would I be able to run the rx 580 in an old macos (el capitan) with the lilu and weg kexts?

Noob question, to install these kexts, I mount the EFI with clover config, then drop them into kexts/other folder?
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,874
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Would I be able to run the rx 580 in an old macos (el capitan) with the lilu and weg kexts?


@littyboy,

Yes that should work, the earliest version of MacOS that Lilu + WEG are listed as being compatible with is El Capitan.

Cheers
Jay
 
Joined
Oct 10, 2015
Messages
726
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Has anyone tested Radeon HD 7850 2GB with its HDMI port for macOS Catalina?

Okay I ordered one as a gamble. Let’s see if it can work with macOS nowadays.
 
Last edited:
Joined
Oct 10, 2015
Messages
726
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
AMD Radeon HD 7850 2 GB (MSI R7850 Twin Frozr 2GD5/OC) works well that I could upgrade my office build (GA-H61M-S2PV | i5-2500K) from High Sierra to Catalina smoothly. Only Lilu and WhateverGreen are needed without any specified change to config.plist. The display is connected via HDMI directly.
截圖 2020-02-25 18.38.11.png

macOS recognises it as ‘AMD Radeon R9 270 2 GB’.
截圖 2020-02-25 18.38.18.png

Metal is supported.
 
Last edited:
Joined
Mar 3, 2014
Messages
946
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
My setup at left has been working perfectly since upgrading to Mojave 10.14.6 about a year ago. BUT, I just updated Lilu and WhateverGreen to the latest versions and guess WHAT? Black screen on boot, after working for several restarts with these new kexts in both /Library/Extensions and EFI/CLOVER/kexts/other. I would like to try reinstalling the previous versions of Lilu and WhateverGreen, but... how do I get onto the Mac OS now? IGFX maybe? Or can someone confirm that their RX 580 works with the latest Lilu and WhateverGreen kexts, so that I can chase other rabbits? Thanks for reading!
 
Joined
Oct 10, 2015
Messages
726
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
My setup at left has been working perfectly since upgrading to Mojave 10.14.6 about a year ago. BUT, I just updated Lilu and WhateverGreen to the latest versions and guess WHAT? Black screen on boot, after working for several restarts with these new kexts in both /Library/Extensions and EFI/CLOVER/kexts/other. I would like to try reinstalling the previous versions of Lilu and WhateverGreen, but... how do I get onto the Mac OS now? IGFX maybe? Or can someone confirm that their RX 580 works with the latest Lilu and WhateverGreen kexts, so that I can chase other rabbits? Thanks for reading!
They should not be duplicated and the most important feature of WhateverGreen is actually addressing a black screen. You may need to check if something in your Clover conflicts with them.
 
Joined
Mar 3, 2014
Messages
946
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
They should not be duplicated and the most important feature of WhateverGreen is actually addressing a black screen. You may need to check if something in your Clover conflicts with them.
Do you mean that Lilu and WhateverGreen should not be in both the EFI partition and also in /Library/Extensions? And what could be a conflict with Clover, if Clover was not changed, except for the update of both of those kexts?
 
Top