Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD 6600 XT

Joined
May 27, 2011
Messages
235
Motherboard
Asus Z370-A Prime
CPU
i9-9900K
Graphics
RX 6800 XT
Classic Mac
  1. 512K
Mobile Phone
  1. iOS
It looks I have a serious problem with my Asrock phantom gaming RX6900xt which needs to be sent in for replacement. (As soon it gets load it will turn black / under macOS but also in Windows). I need to adjust my hack very soon to use integrated graphics for a while (i9-9900k). Can someone direct me what to adjust in opencore config? I now see only lines but I need my system very soon again to prepare my AWS cloud exam… possibly i need to adjust it from windows because it barely gives any video output. (Changed Power supply but didnt help) thanks for help!
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,841
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Can someone direct me what to adjust in opencore config?

You shouldn't need to make any adjustments to config.plist. Just enable the IGPU in BIOS and pull the 6900 XT.
 
Joined
May 27, 2011
Messages
235
Motherboard
Asus Z370-A Prime
CPU
i9-9900K
Graphics
RX 6800 XT
Classic Mac
  1. 512K
Mobile Phone
  1. iOS
Indeed no worries, Thanks... Just removed the card and enabled iGPU and back again. Do you have any idea if it can be a small issue with my RX6900XT or is it really defective? I was playing today Battlefield 3 which is almost no load for the card (approx 30% on ultra settings) and suddenly my PC crashed. I rebooted and I could enter Windows again but as soon I enter the game again both screens went black and also my system crashes in the background. First I thought It could be that the AMD adrenaline settings were wrong so I defaulted them (not that I made any stock changes) but again when I enter 3D also in other games screen went black. After that I tried macOS. It looked on first glance to be ok but when I scroll in Safari somewhat quick also in macOS the card goes to black. After that I swapped out my old power supply for a new one 850W no change. Defaulted BIOS of motherboard for Windows still same issue. What I noticed when I moved from Vega64 to this RX6900XT was a quite loud coil whine. Any tips or things I might try before sending it back for warranty ... (which I hate ...lol)?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,841
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Indeed no worries, Thanks... Just removed the card and enabled iGPU and back again. Do you have any idea if it can be a small issue with my RX6900XT or is it really defective? I was playing today Battlefield 3 which is almost no load for the card (approx 30% on ultra settings) and suddenly my PC crashed. I rebooted and I could enter Windows again but as soon I enter the game again both screens went black and also my system crashes in the background. First I thought It could be that the AMD adrenaline settings were wrong so I defaulted them (not that I made any stock changes) but again when I enter 3D also in other games screen went black. After that I tried macOS. It looked on first glance to be ok but when I scroll in Safari somewhat quick also in macOS the card goes to black. After that I swapped out my old power supply for a new one 850W no change. Defaulted BIOS of motherboard for Windows still same issue. What I noticed when I moved from Vega64 to this RX6900XT was a quite loud coil whine. Any tips or things I might try before sending it back for warranty ... (which I hate ...lol)?

I can't think of anything that can cause the crashing other than defective video card... Especially when everything works correctly with your Vega 64.
 
Joined
Feb 20, 2018
Messages
57
Motherboard
Asus ROG Strix Z370-G Gaming (WI-FI AC)
CPU
i9-9900K
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
I can try it again...
I had it with iGPU disabled, and the audio output of my FireWire audio interface broke evey time as soon as I started Logic Pro X in different versions on Monterey and never came back with this setting.

Will report back!
Report update!

Today tried again with iGPU disabled, FireWire audio didn't work in Logic with current BIOS, which was 3004.

Updated BIOW to latest version, and I can confirm that FireWire audio in Logic pro now works with both settings now, iGPU enabled and disable.
 
Joined
Apr 1, 2017
Messages
375
Motherboard
Asus Z370-I
CPU
i7-8700
Graphics
RX 5700
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Indeed no worries, Thanks... Just removed the card and enabled iGPU and back again. Do you have any idea if it can be a small issue with my RX6900XT or is it really defective? I was playing today Battlefield 3 which is almost no load for the card (approx 30% on ultra settings) and suddenly my PC crashed. I rebooted and I could enter Windows again but as soon I enter the game again both screens went black and also my system crashes in the background. First I thought It could be that the AMD adrenaline settings were wrong so I defaulted them (not that I made any stock changes) but again when I enter 3D also in other games screen went black. After that I tried macOS. It looked on first glance to be ok but when I scroll in Safari somewhat quick also in macOS the card goes to black. After that I swapped out my old power supply for a new one 850W no change. Defaulted BIOS of motherboard for Windows still same issue. What I noticed when I moved from Vega64 to this RX6900XT was a quite loud coil whine. Any tips or things I might try before sending it back for warranty ... (which I hate ...lol)?

in Windows, download WhoCrashed (home), run it, and tell us what it says. It will give a basic idea of why the system BSOD'd.

Otherwise, confirm your BIOS is vLatest from #MBMaker.
 
Joined
Feb 20, 2018
Messages
57
Motherboard
Asus ROG Strix Z370-G Gaming (WI-FI AC)
CPU
i9-9900K
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Report update!

Today tried again with iGPU disabled, FireWire audio didn't work in Logic with current BIOS, which was 3004.

Updated BIOW to latest version, and I can confirm that FireWire audio in Logic pro now works with both settings now, iGPU enabled and disable.
I did a SD clone to a new NVMe drive, and I have the same issue again on both drives, my test drive and the new NVMe, FireWire audio only works with iGPU enabled.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,841
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I did a SD clone to a new NVMe drive, and I have the same issue again on both drives, my test drive and the new NVMe, FireWire audio only works with iGPU enabled.

Weird...

Look in your config.plist and make sure that there's nothing in the config.plist > DeviceProperties section.
 
Joined
Feb 20, 2018
Messages
57
Motherboard
Asus ROG Strix Z370-G Gaming (WI-FI AC)
CPU
i9-9900K
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Weird...

Look in your config.plist and make sure that there's nothing in the config.plist > DeviceProperties section.
Ok! You mean delete all the entries here?
Sorry for me being a noob and thx for helping!
 

Attachments

  • Screenshot 2022-11-29 at 17.35.53.png
    Screenshot 2022-11-29 at 17.35.53.png
    763.9 KB · Views: 9

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,841
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Ok! You mean delete all the entries here?
Sorry for me being a noob and thx for helping!

Yes. Make a backup of your current config.plist. Then try deleting all of those entries and see if it makes any difference.
 
Top