pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD 6600 XT


May 29, 2013
Asus Z370-G Gaming (Wi-Fi AC)
i9-9900K OC'd @ 5.0GHz
RX 6600 XT
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) - i7-8700K i9-9900K - AMD Vega 56 build


Asus ROG Strix Z370-G Gaming (WI-FI AC)

Intel i7-8700K Processor

Already owned

Samsung SM951 512GB AHCI M.2 SSD
Samsung 970 EVO 1TB NVMe M.2 SSD w/Heatsink
*Note: Avoid Samsung PM981 and 970 EVO Plus NVMe M.2 SSDs. These two particular SSDs do not work well with macOS. PM1725a has also been reported to have issues with macOS.

Noctua NH-D15S Processor Cooler

G.Skill TridentZ Series DDR4 RAM 64GB Memory

Gigabyte GTX 1080 GV-N1080TTOC-8GD

MSI Radeon RX Vega 56 Air Boost 8G OC

SeaSonic X Series X-850 (SS-850KM3 Active PFC F3) 850W Power supply

SilverStone KL06B Case

BCM94360C2 Wi-Fi/Bluetooth card w/ M.2 adaptor
M.2 adaptor:​

Dell DW1830 M.2 BECM943602BAED Wi-Fi/Bluetooth card DELL HHKJD WLAN DW1830 WIRELESS-AC WI-FI CARD BCM943602BAED: Computers & Accessories

Athena Power BP-TLA2131SAC 3.5" HDD Trayless Hot-Swap Backplane module

iStarUSA BPN-2535DE-SA 3.5" to 2x2.5" Trayless Hot-Swap Backplane module

Gigabyte GC-AQC107 10GBase-T card (added January 22, 2018)

Matias Tactile Pro Mechanical Keyboard

Apple Magic Mouse

Solarflare 10GbE PCI-e card
(replaced with Gigabyte GC-AQC107 10GBase-T) (replaced with Intel X540-T2 10GBase-T)

Apple Remote IR receiver that I ripped from an old MacBook and jury-rigged to USB. Found a cleaner IR receiver here.


This build is actually an upgrade of my previous build. All I did was transplant in a new motherboard and CPU. Honestly, I really didn't need to upgrade, I just wanted to... The six core Coffee Lake CPU was too tempting and I felt like treating myself to a nice Xmas present. My Gene build ran wonderfully up until I took it out of commission and I have no problems recommending it.

Based on everything I'd read, Coffee Lake is essentially just Kaby Lake with two more cores. So, I was pretty confident that macOS could be installed with a minimal of extra effort, so I took the plunge...

The Build

I knew I wanted an mATX motherboard. It offered enough PCI-e slots for me and I would be able to find cases for it that would be smaller than my old Mac Pro which ate up way too much desk space. My previous experience with the Asus Z170 Gene motherboard was so good that I wanted to stick with Asus when upgrading. For the Z370, Asus only has one mATX motherboard available and that's what I went with.

When Asus released their mATX z270 offerings, the successor to the Gene lost its "Maximus" moniker. The reason for that is that it no longer included some of the more "advanced" features such as LED Q-Code display, motherboard "Start" button, etc. This didn't bother me since I never used any of those features. The Z370-G continues on without these features or the Maximus moniker.

I wanted the i7-8700K. Six cores and only 4W higher TDP than the i7-7700K that I had been using.

Once I received the i7-8700K, before even testing it, I delidded it and replaced the thermal compound used by Intel. Previously, I used Coollaboratory Liquid Ultra on my i7-6700K and i7-7700K with fantastic results. Since then, I became aware of a competing thermal compound, the Thermal Grizzly Conductonaut. On paper, Conductonaut was clearly the superior product with a rating of 73 W/mk vs Liquid Ultra's 38.4 W/mk. I decided to give it a try. Conductonaut turned out to be extremely difficult to handle and the syringe shot the stuff everywhere. Performance-wise, I have found both products to produce very similar results. Therefore, I would recommend just sticking with Liquid Ultra, especially if you are a little klutzy like myself.

With my current 5GHz overclock, max temps reached about 75C when the CPU was under full load.

In the past, I relied upon the Asus AI Suite to handle the overclocking of my i7-6700K and i7-7700K. However, this time around, it produced less than desirable results. I ended up duplicating the overclocking settings from this video and I'm running at 5GHz. My personal example of the i7-8700K reached a stable 5GHz with 1.38v and LLC6 and can run 24/7 without any problems.

The only thing to be aware of when following the overclocking instructions from the above video is that Mac users should not use the AVX offset setting. It does not appear to function properly in macOS.

*For those of you considering a crazy 18 core/36 thread build or something similar, please see posts #2216 and #3255 for my thoughts on that and links to some very interesting and informative videos.

Update November 21, 2018:
I upgraded to an i9-9900K. For details on how I delidded it and how it performs compared to my old i7-8700K, please see this post and this post.

Heatsink & Fans
Here, I chose Noctuas based on reviews I’d read online. They are regarded by many as the best and were supposedly extremely quiet.

After having used the Noctua heatsink and fan for about a year and a half, I can honestly say that they deserve all the accolades that they get. The fans are extremely quiet and high quality. The heatsink keeps the CPU amazingly cool. I would recommend this to anyone.

The only thing to be aware of is that if you use the NH-D15S with an mATX motherboard, the video card will be extremely close to the heatsink. You should make sure that the two do not make contact especially if the video card you use does not have a backplate. We don't want anything shorting out...

Update (April 18, 2018): I have added a heatsink to my M.2 SSD. Info is on post #1375.

Graphics card
I originally started my Gene build with a reference Nvidia GTX 980 that I pulled from my old Mac Pro. When Nvidia released drivers with Pascal support, I upgraded to a GTX 1080. I decided to go with a GTX 1080 rather than a GTX 1080 Ti, because I liked the lower TDP and the GTX 1080 offered more than enough performance for my needs.

Once again, I chose to go with a blower style GPU cooler because they push heat generated from the GPU out the rear of the computer. This helps keep internal temperatures lower inside the computer which benefits all the other components.

Update February 18, 2018:
In light of the recent problems with the Nvidia web drivers and improved support for some AMD cards, I would recommend the Sapphire Radeon RX 580 Pulse (currently the most compatible card around) or one of the AMD Vega cards if you require higher performance.

Update March 10, 2018:
I've made the switch from Nvidia to AMD in the form of an MSI Radeon RX Vega 56 Air Boost 8G OC. Everything is much smoother and less buggy. As per my usual modus operandi, I chose this card because of the blower style cooler. I want to keep temps inside the case as low as possible.

I was faced with deciding between a Vega 56 or Vega 64. At the end of the day, I went with a Vega 56 due to the significantly lower TDP. It was also the reason I chose a GTX 1080 over a GTX 1080 Ti when I bought that card. So far, I'm extremely happy with my decision.

Currently AMD Vega video cards run with the fans spinning faster than they should. To fix the fan issue, we can use the VGTab utility (see attachment below). The FakeSMC_GPUSensors.kext is not working with Vega but we can check how fast the fans are running with this Terminal command:
ioreg -l |grep \"PerformanceStatistics\" | cut -d '{' -f 2 | tr '|' ',' | tr -d '}' | tr ',' '\n'|grep 'Temp\|Fan'

I applied Thermal Grizzly Conductonaut to my Vega 56. Details are here. Details of my undervolting/overclocking findings are here.

Update (July 3, 2019):
I got a PowerColor Red Dragon Vega 56 and did some testing. Full report can be found here.

Power Supply
I went with a Seasonic under the recommendation of several friends who know their PCs. Originally, I just wanted a 750W but there was practically no price difference for the 850W, so I said what the heck…

Choosing a case took more time than choosing any other component for me. I wanted something as compact as possible without sacrificing on cooling and still provide for enough room for a decent number of drives and have easily accessible fan filters. It took a while, but I finally stumbled upon the Silverstone KL06 and it met all my requirements. In particular, I liked how I would be able to mimic my old Mac Pro’s cooling; a large CPU heatsink sandwiched between 120mm intake and exhaust fans at the bottom, a 120mm fan that blows directly at the PCI-e slots, and power supply and drives situated at the top.

Aesthetically, it can best be described as boring or nondescript but that's fine for me. I like classy more than outlandish. Quality-wise, it can't compete with Apple's cases but I doubt that many, if any, can.

Wi-Fi/Bluetooth card
Initially, I used a BCM94360 card with PCI-e adaptor. I then switched to a Dell DW1830 M.2 card that replaced the Intel card that was included with the motherboard. This allows for a much neater installation and frees up a PCI-e slot.

I have switched once again from the Dell DW1830 to a BCM94360CS2 (pulled from MacBook Airs) with an M.2 adaptor. I posted details on post #40.

*Note: If/when you need to install Windows, download Apple's Boot Camp Support Software 5.1.5722 to get drivers for the BCM94360CS2 and Bluetooth.

** Note: For those of you using DW1830 and are experiencing problems after wake, please see this post with work arounds and fixes.

The rest of the components
Everything else was transplanted from my old Mac Pro.


RAM slots:​
Asus Z370 motherboard users have reported that when using two sticks of RAM, it is recommended to install them to slots B1 and A1 rather than the manual's recommendation of B2 and A2. The reason for this is that using B2 and A2 will cause a Clover error that will prevent booting. (I don't know if this issue affects Z370 motherboards from other makes.)
No longer an issue. Latest versions of BIOS have fixed this.

BIOS settings:​
Set everything to default. Then set the following:​
  • Advanced/CPU Configuration/Intel Virtualization Technology - Enabled
  • Advanced/System Agent (SA) Configuration/VT-d - Disabled
  • Advanced/System Agent (SA) Configuration/Graphics Configuration/Primary Display - PCIE (This will not be available if you are only using UHD 630.)
  • Advanced/System Agent (SA) Configuration/Graphics Configuration/iGPU Multi-Monitor - Enabled (This will not be available if you are only using UHD 630.)
  • Advanced/System Agent (SA) Configuration/Graphics Configuration/RC6(Render Standby) - Enabled
  • Advanced/System Agent (SA) Configuration/Graphics Configuration/DVMT Pre-Allocated - 192M (64M should also work)
  • Advanced/USB Configuration/Legacy USB Support - Enabled
  • Advanced/USB Configuration/USB Keyboard and Mouse Simulator - Disabled
  • Boot/CSM (Compatibility Support Module)/ Launch CSM - Enabled (Updated January 22, 2018: I originally used Disabled because it would allow Clover to boot in to the monitor's native resolution. Since then, I have found that Enabling CSM gives better compatibility with devices such as AQC107 and multi monitor support albeit at the loss of native resolution for the Clover boot menu. Bottom line, try both and use the one that works best with your hardware.)
  • Boot/Secure Boot/ OS Type - Other OS
  • (Optional)Ai Tweaker/Ai Overclock Tuner - XMP

Create your USB installer and install macOS:​
  1. Download macOS High Sierra installer via App Store from a Mac or hackintosh.
  2. Download UniBeast 8.1.0.
  3. Initialize your USB flash drive with Mac OS Extended (Journaled) and name it USB.
  4. Launch UniBeast and let it create your USB installer.
  5. When finished, replace the EFI folder in the EFI partition with the one attached to the bottom of this post.
  6. *If you are using IGPU (as in no dedicated video card), you will need to change to iMac18,1 system definition:354842
Alternatively, you can use this method to create your USB installer and then copy EFI folder to the EFI partition of the USB flash drive.
* The reason why I have a customized EFI folder is because I was unable to boot with the EFI folder created by the current version of UniBeast. (Update (March 15, 2018): I tested the latest UniBeast/MultiBeast and they are now working with this build.) (Update (April 13, 2018): MultiBeast 8.3.1 is broken. Stick with MultiBeast 8.1, as linked above.)
** FYI, macOS Sierra has also been confirmed to run fine by forum member Lestliness.​
*** If you wish to use iMacPro1,1 system definition, simply change it in the SMBIOS section of config.plist along with new Board Serial Number, Serial Number, and UUID. No other change is needed. Be aware that iMacPro1,1 requires special builds of macOS. As of macOS 10.13.4, there is no longer special builds of macOS for iMacPro1,1. The builds have been unified.​
**** For those who have multiple hackintoshes, you can have one USB flash drive that will work on all your hacks. Instructions are here.​
  1. Boot up from the USB installer.
  2. Follow the on screen instructions and install macOS.
  3. When complete, you can copy the EFI folder linked to the bottom of this post to the EFI partition of your macOS High Sierra drive.
  4. If using Intel UHD630 graphics ONLY, open your config.plist and change the system definition to iMac18,1 in SMBIOS section.
  5. If using Nvidia graphics, install the Nvidia web drivers that are associated with the version of macOS you installed.
* If you are upgrading from another hackintosh or Mac, you can just copy the EFI folder at the bottom of this post to your existing drive and transplant the drive.
** Audio will default to Digital Out. Go to System Preferences/Sound to select the correct output you are using. The naming is deceptive. Internal Speakers in System Preferences is Line Out on the motherboard and what I use.

*** For those who want to know more about the shikigva= boot argument, the full description can be found here.
**** If you are only able to download a 19MB macOS installer from the App Store, follow this guide to get the complete installer.
* Full description of what the EFI folder does can be found here. I highly recommend you read this!

Post installation tweaks:

RAM fix:​
Initially, the system only saw 2x16GB on my system when I actually have 4x16GB. I fixed it by editing the config.plist and manually entered my RAM info in to the SMBIOS section. I still haven't been able to figure out if this actually fixes it or if it's just cosmetic... Anyway, here's how mine looks:
Update: I confirmed that all 64GB is fully recognized and in use. I ran two tests: (1) I set up a 50GB RAM disk, copied and 45GB Blu-ray image to it and played the video in VLC with a very minimal amount of memory swapping and (2) I ran memtester which wired 50GB and did one loop of its tests. Details are here and here. Here are some screenshots of the memtester run (notice that 50GB is wired and zero swapping):​
You can also check your RAM in Terminal:​
sysctl -a |  grep hw.memsize
No longer needed. Latest BIOS updates and/or versions of Clover have fixed this.​

iMessage fix:​
While you are in the SMBIOS section, you should also generate Serial Number and UUID to get iMessage working. Follow An Idiot's Guide To iMessage to get it all working.​
*Note: Regardless of whether you use iMessage or not, the guide should be followed to implement clean Board Serial Number, Serial Number, and UUID. Not having this setup can be cause for things like Bluetooth issues. Do not report problems unless you have done this.​

Power Management fix:​
There are several methods to get proper power management. Here are two that I've tested and work. You can use either, but not both.
Method 1:​
Follow the [Guide] Generate SSDT For Coffee Lake CPU | and use the Coffee Lake compatible ssdtprgen to generate an ssdt.aml file. Then place the ssdt.aml file /EFI/CLOVER/ACPI/patched/.​
Method 2:​
Open your config.plist with Clover Configurator. In the Acpi section, put a check next to PluginType.​

Enter the following command in Terminal to deactivate AutoPowerOff after 8 hours of inactivity:​
sudo pmset -a autopoweroff 0
Update: Native power management is already implemented in latest release of my EFI folders. (Depreciated stuff is in spoiler. autopoweroff setting is still needed for everyone.)​
USB fix:​
The EFI folder linked here incorporates the USB 15 port limit patch. However, this is considered a temporary fix and the proper fix is to map out the USB ports, create an SSDT, and disable enough ports to bring the total number down to 15 or less. Full explanation can be found at section 7.2 of this post. My simplified directions on how to do this can be found here. More detailed info can be found here. (*There are other methods to achieve this. If other methods work for you, use it. This is what worked for me and it's what I use.)​
I have already mapped out the USB ports and have created the .aml and .dsl files. They are linked at the bottom of this post. Remember, even with the use of this SSDT-USB.aml file, you should have the XHCI-200-series-injector.kext in your /EFI/CLOVER/kext/Other/ folder and you still have to use the uia_exclude custom flag (in Boot section of Clover Configurator) in your config.plist to bring the total port count to 15 or less. One great thing about this motherboard is that you can just disable four of the five (fifth is the USB2 port wired to the internal M.2 slot for Wi-Fi/Bluetooth card) internal USB2 ports and be at exactly 15 ports. This leaves the 4th USB2 for Bluetooth.​
  1. Download the Strix Z370 USB ports.aml file.
  2. Rename it to SSDT-USB.aml.
  3. Copy it to /EFI/CLOVER/ACPI/patched/, and, lastly.
  4. Add your uia_exclude boot argument to config.plist.
  5. Disable all the USB 15 port limit KextsToPatches in config.plist.
Here's how mine looks:​
Screen Shot 2019-04-28 at 6.16.53 PM.png
*The .aml and .dsl files are specific to the Strix Z370-G motherboard. Do not use with other motherboards!
**The .dsl file is provided for reference for those who want to see what was done to create the .aml file. It does not need to be installed anywhere.
(Update Dec 13, 2017: I have updated USB .aml and .dsl files with a few minor fixes. I forgot to map the two USB2 ports.)​
(Update Jan 6, 2018: Both .aml and .dsl files updated with corrections/bug fixes.)​
*Forum member snoopy69 made a very nice map image on post #3005.​
*For those of you who are wondering why bother when the 15 port limit patch seems to be working fine, here's a quote from RehabMan:
*** I confirmed that the two USB 3.1 gen 2 ports work great on post #3294.​
Update October 15, 2019:​
If you want to create your own SSDT (or kext) to address the USB port limit. Here are some super easy instructions.​
Audio loss after sleep fix:​
Download CoodecCommander.kext and use KextBeast to install it to /Library/Extensions/.
Starting with AppleALC v.1.2.6, audio works fine after wake from sleep.​
Enable Bluetooth on DW1830 (Optional):​
If you have decided to use a Dell DW1830 M.2 Wi-Fi/Bluetooth card, you will need to install BrcmFirmwareData.kext and BrcmPatchRAM2.kext in to your /EFI/CLOVER/kexts/Other/ folder. Both kexts can be found at: RehabMan / OS-X-BrcmPatchRAM / Downloads — Bitbucket
*Thanks to neilhart for helping me figure out how to get it working and RehabMan for the kexts.
Enable FileVault (Optional):​
I personally don't use FileVault, but if you do, here's how to get it to work.
  1. Download from the bottom of this post.
  2. Unzip and copy the file to /EFI/CLOVER/drivers64UEFI/.
  3. Enable FileVault from System Preferences.
  4. Once FileVault has been enabled, you must choose "Boot FileVault Prebooter from Preboot" at the Clover boot menu.
* Notes:​
  • I only tested on an APFS drive, I did not test HFS+.
  • I tested with Apple Bluetooth keyboard and it worked fine. If your Bluetooth keyboard works in BIOS, it should work with FileVault too.
  • If/when you update Clover, make sure you check to see that AsAmiShim.efi is still in /EFI/CLOVER/drivers64UEFI/!!! (No longer applicable. Switched to using AptioInputFix-64.efi.)
  • AsAmiShim.efi is already included in the latest release of my EFI folders. (No longer applicable. Switched to using AptioInputFix-64.efi.)
I have AptioInputFix-64.efi and UsbKbDxe-64.efi installed by default to get FileVault working.​
9th Gen CPU IGPU fix:​
Despite it being UHD 630, the 9th gen CPUs have a different device-id for IGPU. As of this writing (macOS 10.14.1), macOS has not been updated to recognize the new device-id. Therefore, we have to spoof the 8th gen device-id to get IGPU to work properly. We can do this by adding the following to config.plist.
If you have a dGPU, use these settings:​
If you are using IGPU only, use these settings:​
BIOS 1601 IGPU settings for 9th gen CPU users:​
As of macOS 10.14.4, 9th gen IGPU is correctly detected and identified automatically by macOS.​
Populating System Information > PCI (Optional):​
If you want to populate System Information > PCI, I have posted instructions on how to do it here.​
Gradient Color Banding Fix:​
If you are experiencing gradient color banding in Dashboard or Launchpad, Bustycat has posted a fix here.​

Maintenance & Future Updates

1. Always check the forum to see if new versions of macOS break anything.​
2. Check for updates to:​
  • Everything in /EFI/CLOVER/kexts/Other/
  • Clover
  • apfs.efi which is located in /EFI/CLOVER/drivers64UEFI/ (No longer needed. Superseded by ApfsDriverLoader.efi.)
Of particular interest to this build are:​

*Update: The latest version of Clover Configurator provides an easy means of keeping your kexts updated. Select "Kext Installer" and then "Other".​

3. Of course, after updating macOS, Nvidia web drivers will also need updating.​
4. On rare occasions, we need to update the SMBIOS section because of updated firmwares on real Macs. To do this:​
  1. Open your config.plist with Clover Configurator.
  2. Copy your working Serial Number, SmUUID, and Board Serial Number.
  3. Click the little up/down button to the right of the image of an iMac.
  4. Select iMac18,3.
  5. Fill in the Serial Number, SmUUID, and Board Serial Number with what you copied earlier.
  6. Save.

5. Be careful with motherboard BIOS updates!! They can sometimes break things.​
6. If you use FileVault, make sure that AsAmiShim.efi or AptioInputFix-64.efi is still in /EFI/CLOVER/drivers64UEFI whenever you update Clover.​

Temps and Power Consumption:
i7-6700K @ 4.8GHzi7-7700K @ 5.1GHzi7-8700K @ 5.0GHzi7-8700K @ 5.0GHzi9-9900K @ 5.0GHz
GPUGTX 980GTX 1080GTX 1080Vega 56Vega 56
Full load69C77C77C78C82C

i7-6700K @ 4.8GHzi7-7700K @ 5.1GHzi7-8700K @ 5.0GHzi7-8700K @ 5.0GHzi9-9900K @ 5.0GHz
GPUGTX 980GTX 1080GTX 1080Vega 56Vega 56
Full load190-193W190-193W256-259W287-290W304-308W

*All four CPUs were delidded.​
**System has 3x3.5" hard drives and 3x2.5" SSD.​
***Vega 56 fan was running higher than normal at time of testing with i7-8700K.​
****A USB 3.1 gen 2 PCI-e card was added and one of the 120mm fans were replaced by an NF-A12-25 PWM in the i9-9900K system.​

What works:
  • Quick Sync
  • Sleep/Wake
  • HEVC
  • Wi-Fi
  • Bluetooth
  • Audio
  • Ethernet
  • 10GbE
  • 10GBase-T w/ AQC107
  • Wake-On-LAN
  • AirPlay
  • iBooks
  • iMessage
  • Continuity
  • Handoff (including handing off phone calls from iPhone)
  • AirDrop
  • Night Shift
  • Power Nap
  • USB 3.1 Gen 2 ports (proof in post #755)
  • Enabling System Integrity Protection (better known as SIP).
  • FileVault
  • MSR 0xE2
  • Dual monitors (don't have enough monitors to test triple, quad, etc)
What doesn't work or works weirdly:
  • Still not sure if all RAM is working properly. (RAM has now been confirmed to be working fine.)
  • Although Sleep/Wake is working great, the Energy Saver System Preference pane is weird. It's not showing an option for Power Nap. (Fixed with proper power management.)
  • I tried to us a Dell DW1830 M.2 Wi-Fi/Bluetooth card in place of the included Intel card. Wi-Fi worked immediately with the built-in Apple drivers, however, bluetooth was not detected at all. (Fully working now.)
  • About This Mac will show Processor as Unknown, but that's purely cosmetic and all cores work fine. There's a way to edit the "Unknown" text but I didn't bother. (Fixed as of High Sierra 17G2112.)
  • Answering phone calls from iPhone is not working. Not sure why. Will continue to investigate. (Working now. Had to set input and output to "use System Setting.")
  • PCI section of System Information will not provide any PCI-e card info. This is how it is on real iMacs too. It's possible to populate it but it's strictly cosmetic and requires customized SSDTs or DSDT. This thread does not provide support for this. RehabMan confirmed that it is strictly cosmetic here.
  • Wireless diagnostic will cause hard reboot. I tested with several hackintoshes and got the same result. I assume whatever hardware check it's doing is simply incompatible with hacks.
  • DRM content from iTunes, Netflix, Amazon Video. Some iTunes videos work for me while others don't. I don't know why and never followed up, I watch my videos using Apple TV. I haven't tried but others have reported that Netflix and Amazon Video will only work with Chrome browser. Disabling IGPU and using iMacPro1,1 system definition seems to be the most reliable way to get DRM content to work. Some have reported success with NoVPAJpeg, but that disables hardware decoding... I have not tested this. Another workaround is just to watch DRM content in an Windows virtual machine... DRM works perfectly when using iMacPro1,1 system definition.
Update #1 (January 20, 2018):
I found out that the Clover r.4380 includes OsxAptioFix3Drv-64.efi and AptioMemoryFix.efi. Both versions restore native NVRAM!! In my opinion, the biggest benefit of native NVRAM support is that crash reports are generated if something goes wrong and your system reboots. This can be a huge help when troubleshooting problems. You can choose either one, but don't use both at the same time. I don't know which is better, but I have not had any issues with either.
How to upgrade to OsxAptioFix3Drv-64.efi or AptioMemoryFix.efi:
  1. Use the Clover Emulated NVRAM Uninstaller to remove emulated NVRAM.
  2. Use the latest Clover to install OsxAptioFix3Drv-64.efi.
  3. Check in /EFI/CLOVER/drivers64UEFI/ to make sure that OsxAptioFix3Drv-64.efi has replaced OsxAptioFix2Drv-64.efi. Only one should be there, not both!
  4. Reboot.
Just to be clear, this is entirely optional but recommended. If you are happy using emulated NVRAM, you do not have to do this. Also, with native NVRAM, we can disable NvidiaWeb in config.plist.

Update: OsxAptioFix3Drv.efi AptioMemoryFix.efi is already included in the latest release of my EFI folders.

Update #2 (January 26, 2018):
The Nvidia web drivers for macOS 10.13.3 and 10.13.3 Supplemental Update are causing UI lags. To circumvent this, we can continue to use the drivers for macOS 10.13.2.
Updating to macOS High Sierra 10.13.3 via App Store works fine. Unfortunately, some users have reported severe lag with the corresponding Nvidia web drivers. If you experience these lags, you can downgrade to the drivers for 10.13.2. If you are still on the older drivers, you can keep using them with these directions.
Use this Clover patch to allow previously installed Nvidia web drivers to work on versions of macOS it wasn't intended for. As of today, the last version of the Nvidia web drivers to NOT have the lag issues is 378. While .105 and .106 may work, they were intended for iMacPro1,1.

Update: This patch is already included in the latest release of my EFI folders, however, it is disabled by default. You must edit your config.plist to enable it.

If you have already upgraded the Nvidia web drivers beyond .104 and need to downgrade, Vulgo has a great tool that can help you downgrade. More info can be found at: Install any version of NVIDIA Web Drivers |

Update #3 (February 22, 2018):
Forum member @wombat94 has written a script for use with Carbon Copy Cloner that automates the backing up of our EFI folders when doing a backup. Information is here.
  1. Download the script and unzip it.
  2. Copy to /Library/Application Support/com.bonbich.ccc/Scripts/.
  3. Launch Carbon Copy Cloner.
  4. Set your Source and Destination drives.
  5. Scroll down to Advanced Settings, AFTER COPYING FILES section.
  6. Click on the little folder icon next to Run a Shell Script:.
  7. Select
  8. Click the Clone button to begin the cloning process.
  9. Done.
Update #4 (February 28, 2018):
I have updated my EFI folders to include:
  • Latest version of Clover.
  • Switch from OsxAptioFix2Drv-64.efi to OsxAptioFix3Drv-64.efi to restore native NVRAM.
  • Latest versions of all kexts.
  • Added native CPU power management via PluginType=true by default.
  • Added SSD Trim support via KextsToPatch by default.
  • Added KextsToPatch to allow older versions of Nvidia web drivers to work with newer macOS version. (Disabled by default.)
  • Included AsAmiShim.efi for FileVault support.
This update should be used by anyone currently using the previous release of my EFI folder. Just copy your Serial Number, SmUUID, and Board Serial Number from your current config.plist and apply it to the new one.

Update #5 (March 9, 2018):
Today, I switched my graphics card from an Nvidia GTX 1080 to an AMD Vega 56. If you are still in the process of deciding which to by, I wholeheartedly recommend AMD over Nvidia. More details in post #820.

Also, I posted a guide on how to install macOS on a Dell Latitude 3450. If you are looking for an inexpensive companion to your Coffee Lake, it's worth a look.

Update #6 (March 28, 2018):
For those of you with multiple hackintoshes, I posted instructions on how to have just one USB macOS installer that can be used on all your hacks on post #957.

I also updated the power consumption and temperatures chart in this post.

Update #7 (March 31, 2018):
  • macOS High Sierra 10.13.4 updates via App Store without problems.
  • Vega fan noise comes and goes, but it seems (placebo?) better than before. @quaquar found that removing FakeSMC_GPUSensors.kext helps the Vega fan. However, once ramped up due to load, it still doesn't ramp back down.
  • Based on everything I've read, the Nvidia web drivers are still very buggy.
  • Nvidia audio over HDMI/DisplayPort is broken. I'm still looking for a good fix for this.
  • IGPU only users may see two listings for the UHD 630 in System Information. This appears to be just a cosmetic issue and is fixed with Clover r4421.
  • IGPU only users may experience some flickering and performance issues. Try changing to iMac18,1 or iMac18,2 system definitions to fix this.
Those who are using AQC107 based 10GBase-T PCI-e cards will need a new KextsToPatch to get them working.
Name: AppleEthernetAquantiaAqtion
Find: 0F84C003 0000
Replace: 90909090 9090
Comment: AQC107 patch by Mieze
*(Optional) Add Custom flag "apple-axge-debug=0xff"

Alternate patch for AQC107 cards. Use either above patch or this one, not both:
Name: AppleEthernetAquantiaAqtion
Find: 6275696C 742D696E
Comment: AQC 107 10 GbE v2

There is also a new patch that disables the 15 USB port limit. If you are already using SSDT-USB.aml with uia_exclude, I would recommend sticking with that.
Find: 837D940F 0F839704 0000
Replace: 837D940F 90909090 9090
MatchOS: 10.13.x
Comment: USB 10.13.4+ by PMHeart
*Disable previous USB 15 port limit patch and remove USBInjectAll.kext.

Update #8 (April 6, 2018):
I have posted r3 of the EFI folders.
  • apfs.efi has been updated.
  • Updated to Clover r4428. This update fixes the double entry of UHD 630 in System Information for UHD 630 only users.
  • All kexts have been updated.
  • Removed RadeonDeInit for AMD users.
  • Latest NvidiaGraphicsFixup.kext has workaround for "the lag".
  • WhateverGreen.kext has been added. This will help some AMD users regain HDMI/DisplayPort audio.
  • Switched from OsxAptioFix3Drv-64.efi to AptioMemoryFix.efi. Both work but switched because of more active development for AptioMemoryFix.efi.
  • AQC107 patch v2 has been added and enabled.
  • PMHeart's USB 15 port limit patch has been added but is disabled. If you wish to use this, you can enable it in config.plist and you must remove USBInjectAll.kext.
  • UHD630 EFI folder uses iMac18,1 to avoid screen flickering issue.
*Note: AppleALC was updated to version 1.2.6 after I posted r3 of my EFI folders. If you update to this version, you will no longer need CodecCommander. Install AppleALC to /EFI/CLOVER/kexts/Other/ and delete CodecCommander. I recommend this update for everyone. It works great.

Update #9 (April 21, 2018):
I have replaced my r3 EFI folders with r3.1 because I wanted to update a few kexts and clarify some confusion.
  • AppleALC.kext updated to version 1.2.6. With this version, CodecCommander is no longer necessary.
  • NvidiaGraphicsFixup.kext updated to version 1.2.7. This version removes redundant feature now included with Nvidia web drivers version 387.
  • Renamed XHCI-300-series-injector.kext back to its correct name, XHCI-200-series-injector.kext.
Clarify confusion:
Previous releases of my EFI folders included a kext named XHCI-300-series-injector.kext. This was in fact just a renamed XHCI-200-series-injector.kext. This was used because our motherboards' USB Device ID matched the kext's.
RehabMan has now released an official XHCI-300-series-injector.kext for H370, B360, and H310 chipsets. However, the Device ID used in that kext does NOT match that of our motherboards. Therefore, if/when we update this kext, we should continue to use XHCI-200-series-injector.kext.

Also, BIOS 0615 has been released. Everything seems to be running fine with it.

Update #10 (April 26, 2018):
Updated my EFI folders to r3.2.
  • Latest version of USBInjectAll.kext. This should work better for those who had USB problems with macOS 10.13.4.
  • Added more KextsToPatches for specific versions of macOS. Again, to help address USB issues with macOS 10.13.4. Remember to disable all these patches if you use SSDT for USB.
  • Updated SMBIOS information on UHD630 EFI.

Update #11 (June 2, 2018):
macOS High Sierra 10.13.5 updates fine via App Store. No updates or changes need to be made to your EFI folder.

Vega video card fan speed fix:
okasit revealed that we can edit the power tables and fix this. The relevant info starts around page 6 of this thread:

I installed the Vega 56 kext made by wyhtc and it has been working great. Not only has it quieted the Vega fan when idle (it still gets very loud under load), it has also improved performance significantly for me. (Screenshots posted on post #1788.)

*Note: Since the FakeSMC Sensors don't give any readings for Vega cards, we can use Terminal to monitor temps and fan speeds:
ioreg -l |grep \"PerformanceStatistics\" | cut -d '{' -f 2 | tr '|' ',' | tr -d '}' | tr ',' '\n'|grep 'Temp\|Fan'

I updated the motherboard BIOS to 0805. Everything seems fine.

Update #12 (June 20, 2018):
Updated my EFI folders to r3.3. This update should work with the Mojave Public Beta when it gets released. Remember to copy/paste your uia_exclude setting, serial, board serial, and UUID to updated config.plist. Also, if you are using SSDT-USB.aml and uia_exclude, remember to disable all the 15 port limit patches in KextsToPatch section of your config.plist.

  • Clover updated to r4558.
  • All kexts updated to newest available versions.
  • Fixed icon bug in the 'mac' theme.
  • Fixed typo in one of the KextsToPatch.
  • PMHeart's 15 port limit patch set as default.
  • Added ssdt-usbx.aml for USB power injection.
Btw, here's a link to a user who is using this build for video editing and some of his benchmark results.

  • Reverted to AppleALC 1.2.7 because the version I included with r3.3 was buggy.
  • Added SSDT-LPC so that AppleLPC loads. This is modified from Violet Dragon's work. I just edited it for Coffee Lake.
BIOS 0809 is working fine.

Update #13 (July 10, 2018):
Updated my EFI folders to r3.5.

  • Added ApfsDriverLoader.eft to /EFI/CLOVER/drivers64UEFI/. This eliminates the need to ever have to update the apfs.efi file ever again. This will cause boots to be a bit slower but I'll take the convenience over having to always update apfs.efi.
  • New USB 15 port limit patch that is required for macOS High Sierra 10.13.6 added. (*Those who are using SSDT for USB should disable all these 15 port limit KextsToPatches. Those who are still using 15 port limit patches really should use SSDT for USB so you don't have to constantly deal with this PITA. Having to constantly look for a new patch is much more work than just using SSDT for USB.)
Find: 837D880F 0F83A704 0000​
Replace: 837D880F 90909090 9090​
Comments: USB 10.13.6+ by PMHeart&FredWst​
MatchOS: 10.13.6​

I updated to BIOS 1002. Lost AirDrop afterwards and audio was sporatic after wake. I ran the macOS 10.13.6 Combo Update and everything is back to normal.

Update #14 (July 16, 2018):
I'm comfortable enough with the unified EFI folder to delete the older releases. The biggest benefit of this EFI is that you can freely change video cards without the need to make any changes. I also tried my best to make it as Mojave ready as possible.

As always, backup your existing, working EFI folder. Copy/paste your Serial, Board Serial, UUID, and Memory settings to the new config.plist.

Update #15 (July 21, 2018):
EFI folder updated to r4.1. Changes are:
  • Clover r4617
  • Lilu 1.2.5
  • WhateverGreen 1.2.0
  • AppleALC 1.3.0
  • config.plist updated with new method to inject ig-platform-id
As always, backup your existing, working EFI folder. Copy/paste your Serial, Board Serial, UUID, and Memory settings to the new config.plist.

*Users who are using UHD 630 ONLY are having problems with r4.1 and should continue to use EFI r3.5 for now or upgrade to 17G2112 build of High Sierra. If you want to upgrade to 17G2112, check post #2514 and use EFI from post #2482.

In case you missed my post, this thread provides links and info to help you build your own kext to control Vega fans. However, the tools and site are in Chinese and I don't understand any of it... Use at your own risk. I have not tested it. Update: Forum member eliyu has helped us create kexts for Vega 56 and Vega 64 using this new tool. They can be found in post #2418, #2422 and #2897. Update: Forum member winslayer has helped translate the utility to english in post #2453.

Update #16 (August 5, 2018):
EFI folder updated to r4.2. Changes are:
  • Clover r4630
  • Lilu 1.2.6
  • WhateverGreen 1.2.1
  • Updated Custom Flags in config.plist (thanks goes to hoeman for reminding me.)
  • Replaced AsAmiShim.efi with AptioInputFix-64.efi
  • Using new method of Audio-ID injection
As always backup your existing, working EFI folder!!

Attached VGTab (English version) to this post. Thanks again, winslayer!!!

Update: Inadvertently included older version of Clover. Fixed with r4.2b.

Update #17 (August 17, 2018):
EFI folder updated to r4.3. Changes are:
  • Clover r4644
  • AppleALC 1.3.1

Update #18 (August 23, 2018):
EFI folder r4.4 released. This EFI folder should only be used with (1) 17G2112 or newer or (2) Mojave. If you will be remaining on Sierra or High Sierra, use r4.3. Changes are:
  • Clover r4658
  • Clover Drivers updated. More info can be found here.
  • ig-platform-id changed to Coffee Lake (previously, we had to spoof Kaby Lake)
  • IntelMausiEthernet.kext updated to 2.4.0 (I didn't update this on previous EFI folder releases to maintain backward compatibility with older versions of macOS.)

Update #18 (September 14, 2018):
Updated EFI folders.
  • AppleALC.kext 1.3.2
  • Lilu.kext 1.2.7
  • WhateverGreen.kext 1.2.2
  • UsbKbDxe-64.efi

Update #19 (September 22, 2018):
Updated EFI folders.
  • Clover r4674
  • WhateverGreen 1.2.3

Update #20 (September 26, 2018):
Updated Mojave EFI folder to included the latest USB 15 port limit patch for those who still haven't applied the proper fix. For those who have applied the proper USB fix, this can be ignored.

Comment: USB Port limit patch 10.14 (credits FredWst)​
Find: 83 FB 0F 0F 83 03 05 00 00​
Replace: 83 FB 0F 90 90 90 90 90 90​

Updated to BIOS 1406. All seems fine.
Updated to BIOS 1412. All seems fine.

Update #21 (October 6, 2018):
Updated Mojave EFI folder to r4.4.4.
  • Changed IGPU injection from manual injection to allowing macOS to detect it automatically.
  • Updated to latest FakeSMC.
Also updated the Strix Z370G USB port files. Corrected a bug and corrected some commenting errors.

Update #22 (October 27, 2018):
Updated Mojave EFI folder to r4.5.
  • Clover r4722 (which adds iGPU device id for 9th gen Intel CPUs)
  • Re-enabled the PEGP to GFX0 rename in config.plist
  • Added PS2 keyboard support via VoodooPS2Controller.kext
You can delete the VoodooPS2Controller if you like. Leaving it there shouldn't cause any problems. I have it because I"m using an old school mechanical PS2 keyboard.

Update #23 (November 7, 2018):
Updated Mojave EFI folder to r4.5.1.
  • Clover r4741
  • AppleALC 1.3.3
  • Lilu 1.2.8
  • WhateverGreen 1.2.4
  • VoodooPS2Controller 1.9.2
  • USBInjectAll 0.7.0
  • New USB 15 port limit patch for macOS 10.14.1
    • Name*:
    • Find* [Hex]: 83FB0F0F 838F0400 00
    • Replace* [Hex] : 83FB0F90 90909090 90
    • Comment: USB Port limit patch 10.14.1
    • MatchOS: 10.14.1
BIOS 1601 is working fine.

Update #24 (January 7, 2019):
@lihaoyun6 has updated his VGTab utility. More info can be found here.

Update #25 (January 27, 2019):
Updated EFI folder to r4.5.2. There's nothing in there that's "major". 4.5.1 continues to work fine. The only thing I would consider major is, thanks to @perchard, iTunes DRM is working.
  • Clover updated to r4862.
  • Startup chime components have been installed. At the Clover boot menu, go to Options > Startup Sound Output to select the output. If you don't want the chime, just select an unused output.
  • All kexts updated to latest versions.
  • config.plist > Boot > Custom Flags shikigva=60 changed to shikigva=1 (user golfleep reported that shikigva=1 breaks H.264 encoding in FCPX. shikigva=60 restored it.)
  • config.plist > SMBIOS > EFI Version populated
Also, the missing "Primary Display" option in BIOS for 9th gen CPU users will return with BIOS 1802. Expect Asus to release this any day now. It's a highly recommended update for 9th gen CPU users. As with any BIOS update, all BIOS settings will be reset to default after the update and you will have to redo the settings required to run macOS.

@mm2margaret has posted instructions and files for an alternate Boot chime method here.

Update #26 (March 3, 2019):
Updated EFI folder to r4.5.3.
  • Clover updated to r4895.
  • All kexts updated to latest versions.

Update #27 (April 4, 2019):
I posted EFI folder r5.0b (b as in beta). I'm still testing things out... iMac19,1 system definition set as default. New Serial, Board Serial, and UUID needed if updating from iMac18,x system definitions.

Make sure to make a backup of your existing EFI folder before trying this one!!!
iMac19,x requires a custom build (18E2034) of macOS that is only shipped with the new iMacs!!! (See section D2 of
KPG's Build for custom build)
Use at your own risk.

  • Clover updated to r4918
  • Using iMac19,1 system definition
  • All kexts updated to latest versions
Update: I've been testing the latest EFI folder with iMac19,1 system definition and everything seems solid. Please keep in mind that I"m using the special 18E2034 build of macOS that ships with the latest iMacs.

Update 2: To use r5.0b with macOS 10.14.3 and/or to update to standard release of 10.14.4, just open the config.plist with Clover Configurator and change system definition to iMac18,3 (or iMac18,1 if you are using IGPU only) and copy/paste your current Serial, Board Serial, and UUID. You can also add boot flag "-no_compat_check" for safe measure.

Update 3: (1) 9th gen IGPU is now correctly detected and working without the need to spoof 8th gen IGPU. Device-id=3E980000 and ig-platform-id=3E910003 on my i9-9900K. iTunes DRM working. (2) When using 10.14.4 (18E2034), the system seems to do a dark wake every few minutes. This does not happen when Wi-Fi is disabled. (Fixed with AirportBrcmFixup.kext. I was wrong. The only reason sleep worked with AirportBrcmFixup.kext was because it disabled WOL.) (3) Wake on demand working (i.e. I can now access shared folders from this system even when it is asleep. Previously, I had to send a magic packet to wake it first.). (4) According to iStat Menus, idle CPU frequency is 1.3GHz now. Previously, it was 800MHz.

Update 4: i9-9900K users who want About This Mac to correctly identify the CPU just have to add "0x1009" to config.plist > CPU > Type. Credit:

Update #28 (April 23, 2019):
I posted EFI folder r5.0.
  • Clover updated to r4920
  • Reverting back to iMac18,3 system definition for least common demonitor compatibility. Users are free to use iMac19,x as they see fit.
  • All kexts updated to latest versions
If you want to populate System Information > PCI, I have posted instructions on how to do it here.

Update #29 (May 15, 2019):
As of macOS 10.14.5, 9th gen CPU users should set ig-platform-id to 3E980003 and remove WhateverGreen.kext. Be aware that removing WhateverGreen breaks iTunes DRM for me.

As far as I know, this is is only needed for 9th gen CPU users because 8th gen IGPU is still being detected correctly.
Screen Shot 2019-05-15 at 10.24.57 AM.png

Alternatively, users can disable IGPU in BIOS and use iMacPro1,1. The benefits of this is that iTunes, Netflix, Amazon Video, etc DRM works. However, the hardware of Z370 is much closer to iMac than iMac Pro. The choice is yours...

9th gen CPU users who are using IGPU only (as in no dGPU) should use ig-platform-id 3E9B0007 and device-id 3E9B0000.

*Clover r4930 fixed this... sort of.. It auto detects the IGPU on 9th gen CPUs but spoofs 8th gen ig-platform-id. Users can, of course, use the above methods to inject the correct values.

Update #30 (May 21, 2019):
Updated EFI folder to r5.0.1.
  • Clover updated to r4930 (this release fixes auto detection of 9th gen IGPUs.)
  • Updated config.plist to include latest USB 15 port limit patch
*As stated in Update #29, while the auto detection is working again, it spoofs 8th gen ig-platform-id.

Update #31 (May 27, 2019):
Updated EFI folder to r5.0.2.
  • Clover updated to r4934
  • Latest Lilu/WhateverGreen/AppleALC included
Reminder: If you have multiple hackintoshes, you can create a single USB macOS installer that will work for all your hacks. It's always recommended to keep a USB installer around for emergency situations if/when you are unable to boot from your main system drive. Instructions are here.

Update #32 (June 24, 2019):
Updated EFI folder to r5.03.
  • Clover updated to r4972
The only change to this update is Clover which has quite a few improvements to work better with future versions of macOS. Those intending to try the upcoming Catalina public beta should use this EFI folder.

I recently switched to using iMacPro1,1 system definition full time. My reasoning can be found in this post. If you wish to do the same, just change the system definition in your config.plist and disable IGPU in BIOS.

Update #33 (June 30, 2019):
Updated EFI folder to r5.0.4.
  • Clover r4978
  • AppleALC 1.3.9
  • Lilu 1.3.7
  • WhateverGreen 1.30

Update #34 (July 1, 2019):
Updated EFI folder to r5.0.5.
  • Clover r4979
  • FakeSMC 6.11-474-g55059940.1802

Update #35 (July 6, 2019):
Updated EFI folder to r5.0.6.
  • Restored some drivers to improve FieVault compatibility.

Update #36 (July 12, 2019):
Updated EFI folder to r5.1.0.
  • Clover r4988

There's been considerable changes/updates to Clover including changes to the file structure. When updating to this EFI folder, it's best to:
  1. Make a backup of your existing, working EFI folder.
  2. Replace your existing EFI folder with r5.1.0.
  3. Replace the config.plist in /EFI/CLOVER/ with the one from your backup.
If you are experiencing gradient color banding in Dashboard or Launchpad, Bustycat has posted a fix here.

Update #37 (July 21, 2019):
Updated EFI folder to r5.1.1.
  • Clover r5027
  • AppleALC 1.4.0
  • Lilu 1.3.8
  • WhateverGreen 1.3.1

Update #38 (August 13, 2019):
I've begun testing OpenCore. If you want to try it out for yourself, I've posted an EFI here.

Update #39 (August 14, 2019):
Been testing OpenCore for the last few days and I feel confident enough to move my EFI folder to beta status and post it here.

It's currently set up with iMacPro1,1 system definition.
Catalina Public Beta 5 has been tested.
FileVault has been tested.

To use:
  1. Open the config.plist with Xcode or Plist Edit Pro.
  2. Go to the PlatformInfo section.
  3. Look for all the fields that say "fill-in" and fill in your Serial, Board Serial, UUID, or ROM info. (ROM is your network interface EN0 MAC address.)
If you are planning to use my OpenCore EFI on a Z370 motherboard other than the Asus Z370-G Gaming, I suggest clearing the Device Properties section in the config.plist and use a different SSDT-USB.aml with your own "uia_exclude" setting. Everything else should work fine.

Update #40 (October 4, 2019):
Updated EFI folder to r5.1.2. Only change is Clover has been updated to r5093.

Update #41 (October 17, 2019):
Updated EFI folder to r5.1.3.
  • Clover updated to r5096
  • AppleALC updated to 1.4.2
  • Lilu updated to 1.3.8
  • WhateverGreen updated to 1.3.3
  • AppleALC kernel panic patch added to config.plist. (Thanks to Sofronis for alerting me to the fix.)
  • SMBIOS data updated in config.plist.
  • New USB 15 port limit patch added to config.plist. (Really guys, it's time to do the proper fix. Super easy directions are here.)
  • Seeing as how the recent Chrome update caused so much havoc, I have decided to enable SIP by default in config.plist.

Update #42 (October 20, 2019):
Updated OpenCore EFI to beta 2.
  • OpenCore updated to 0.5.1
  • All kexts updated to latest versions.
  • All drivers updated to latest versions.
  • iMacPro1,1 system definition used. (You can change it to anything you like.)
  • FileVault support not implemented!
  • All external USB ports enabled.
  • Zero internal USB 2 ports are enabled.
  • USB port attached to M.2 port for Bluetooth is enabled.
  • You must fill in your Serial, Board Serial, UUID, and ethernet MAC address before using. (Please see READ ME!!! image in the zip file.)
  • Make backups of everything before using.
  • Remember, OpenCore is still considered to be in "beta".

Update #43 (October 26, 2019):
Updated OpenCore EFI to beta 3. This update is to (1) fix the "fix your kext" message that appears during boot and (2) get FileVault working.

I tested FileVault on both my Z370 and Z390 with OpenCore. It works on both. After entering your login password, there may be some slight graphical glitches but this doesn't cause any problems. Once it gets to desktop, everything is fine.

Also, if you encounter an issue where you see your desktop background instead of the login window, just reboot and select clear NVRAM at the OpenCore boot menu.

Update #44 (October 29, 2019):
Updated Clover EFI folder to r.5.1.4
  • Clover updated to r5098
  • WhateverGreen updated to 1.3.4 to address black screen condition with macOS Catalina 10.15.1

Updated OpenCore EFI to beta 4
  • WhateverGreen updated to 1.3.4 to address black screen condition with macOS Catalina 10.15.1

Warning!!! FileVault is broken with macOS Catalina 10.15.1 + Clover. FileVault works with macOS Catalina 10.15.1 + OpenCore. Fixed. Please see update #45.

Update #45 (October 31, 2019):
Updated Clover EFI folder to r5.1.5
  • AppleALC updated to 1.4.3.
  • Lilu updated to 1.3.9.
  • Fixed FileVault. Switched from Clover FileVault drivers to Acidanthera FileVault drivers. Credit goes to fewtarius.
  • Old FakeSMC kexts are included for those who don't need FileVault support and want more sensors.

Updated OpenCore EFI to beta 5
  • OpenCore updated to 0.5.2.
  • AppleALC, Lilu, WhateverGreen, VirtualSMC all updated to latest versions.

Update #46 (December 4, 2019):
Updated Clover EFI Folder to r5.1.6
  • Clover updated r5099.
  • All kexts updated to latest versions.
Updated OpenCore EFI to beta 6
  • OpenCore updated to 0.5.3.
  • config.plist updated. (Please copy your PlatformInfo from your old config.plist to new config.plist.)
  • All kexts updated to latest versions.

Update #47 (January 14, 2020):
Updated Clover EFI Folder to r5.1.7
  • Clover updated to r5103.
  • All kexts updated to latest release versions.

Updated OpenCore EFI to beta 7
  • OpenCore updated to 0.5.4.
  • config.plist updated. (Please copy your PlatformInfo from your old config.plist to new config.plist.)
  • All kexts updated to latest release versions.

Update #48 (January 23, 2020):
Updated OpenCore EFI to beta 8. I cleaned up the config.plist a little and put back USBInjectAll.kext which I mistakingly left out.

Update #49 (February 5, 2020):
Updated OpenCore EFI to beta 9.
  • OpenCore updated to 0.5.5
  • All kexts updated to latest release versions.

Update #50 (March 2, 2020):
Updated both the Clover and OpenCore EFI folders. Latest release versions of the bootloaders and kexts are in there.

To update:
  1. Make backups of everything.
  2. Download and unZip your EFI of choice.
  3. Copy/Paste your Serial, Board Serial, UUID (and MAC address if you are on OpenCore) to the included config.plists.
  4. Replace the EFI folders in the EFI partitions of your main system drive.
  5. Reboot.
* I have not tried the new boot picker and boot chime functions of OpenCore. I have no plans to incorporate these yet.

Update #51 (April 24, 2020):
Updated Clover EFI.
  • Clover r5114
  • OcQuirks-Revision 22
  • Added RadeonBoost.kext

Updated Vega 56 results with Vega Fan Fix applied, Liquid Metal used between the GPU and heatsink, and macOS High Sierra 17G2112:
*All benchmarks taken with CPU clocked at 5GHz.

My current Vega 56 settings:
1590MHz core @ 1010mV, 920MHz HBM, 50 power limit, and 55 target temperature.

*Various benchmarks with my Vega 56 undervolted, overclocked, and with power limit changes can be found on post #3091.

My Radeon VII results:
Screen Shot 2019-07-01 at 6.14.42 AM.png Screen Shot 2019-06-30 at 3.04.14 AM.png
Screen Shot 2019-06-30 at 2.52.35 AM.png Screen Shot 2019-06-30 at 3.20.38 AM.png
Screen Shot 2019-07-05 at 5.14.21 AM.png Screen Shot 2019-07-05 at 5.15.06 AM.png


    11.9 KB · Views: 1,458
  • EFI for Intel UHD630
    33.7 MB · Views: 3,146
    429.5 KB · Views: 2,850
  • EFI Unified 4.3.2 (High Sierra)
    27.4 MB · Views: 2,366
  • Strix Z370G USB ports.aml
    931 bytes · Views: 1,730
  • Strix Z370G USB ports.dsl
    5.9 KB · Views: 1,562
  • EFI Unified r5.1.6 (Catalina).zip
    29.8 MB · Views: 858
  • OpenCore 0.5.3 Z370G Beta
    5.1 MB · Views: 531
  • EFI Unified r5.1.7 (Catalina).zip
    29.8 MB · Views: 893
  • EFI OpenCore 0.5.6 Z370G (Catalina).zip
    18.6 MB · Views: 437
  • EFI Clover r5114 Z370G (Catalina).zip
    24.7 MB · Views: 582
  • EFI OpenCore 0.5.9 Z370G (Catalina).zip
    6.4 MB · Views: 637
  • EFI Clover r5120 Z370G (Catalina)
    24.7 MB · Views: 455
  • EFI Clover r5122
    24.8 MB · Views: 982
  • EFI OpenCore 0.6.2 Z370G
    6.5 MB · Views: 281
  • EFI Clover r5127
    24.9 MB · Views: 350
  • EFI OpenCore 0.6.5
    61.7 MB · Views: 612
  • EFI Clover r5128
    24.9 MB · Views: 357
  • EFI Clover r5131
    25 MB · Views: 245
  • EFI Clover r5132
    25 MB · Views: 147
  • EFI OpenCore 0.6.8
    61.9 MB · Views: 210
  • EFI Clover r5134
    25.1 MB · Views: 183
  • EFI Clover r5136
    25.1 MB · Views: 132
  • EFI OpenCore 0.7.2
    12.3 MB · Views: 186
  • EFI Clover r5139
    25.2 MB · Views: 137
  • EFI Clover r5141
    26.6 MB · Views: 155
  • EFI Clover r5142
    26.6 MB · Views: 135
  • EFI OpenCore 0.7.6
    13.7 MB · Views: 214
  • EFI Clover r5144
    27 MB · Views: 69
  • EFI OpenCore 0.7.8
    12.9 MB · Views: 138
  • EFI Clover r5145
    27 MB · Views: 83
  • EFI OpenCore 0.7.9
    12.9 MB · Views: 175
  • EFI Clover r5146
    27.1 MB · Views: 152
  • EFI OpenCore 0.8.0
    13 MB · Views: 204
  • EFI OpenCore 0.8.1
    13 MB · Views: 137
  • EFI OpenCore 0.8.2
    13 MB · Views: 87
  • EFI OpenCore 0.8.3
    13.1 MB · Views: 95
  • EFI OpenCore 0.8.4
    13.3 MB · Views: 73
  • EFI OpenCore 0.8.5
    13.3 MB · Views: 94
  • EFI OpenCore 0.8.6
    13.3 MB · Views: 64
Last edited:


May 29, 2013
Asus Z370-G Gaming (Wi-Fi AC)
i9-9900K OC'd @ 5.0GHz
RX 6600 XT
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
When I compared other Z370 mATX motherboards, all the other ones seemed to be missing one thing or another, including lack of USB 3.1 Gen 2, only 4 SATA connections, lack of M.2 Wi-Fi/Bluetooth, etc. This Strix Z370-G had the most features.

I had no problems booting with all four RAM slots populated. However, only 32GB was initially recognized. I edited my config.plist and populated the SMBIOS/Memory section to get all 64GB recognized. I don't know if this is cosmetic or if all 64GB is actually seen now.

I haven't done a clean install yet. I simply modified my config.plist and changed a few kexts on my old Gene build prior to taking it out of commission, then I transplanted the SSD to the Strix and have been continuing to use my existing macOS install. I haven't done a true clean install in over a decade and have simply transplanted my boot drive each time I changed systems.

Yes, I was aware of the VDroop and LLC issues and updated the BIOS immediately. I followed the video I linked above to overclock to 5GHz.


May 29, 2013
Asus Z370-G Gaming (Wi-Fi AC)
i9-9900K OC'd @ 5.0GHz
RX 6600 XT
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I tested a Dell DW1830 M.2 Wi-Fi/Bluetooth card. The Wi-Fi worked with the native drivers, however, Bluetooth did not show up. I have ordered a BCM942602 card pulled from a 2014 MacBook Air along with an M.2 adaptor to see if I will have better luck with that card. I really want to utilize the M.2 slot for Wi-Fi/Bluetooth to keep the internals a bit neater.

I forgot to check if the 32GB was recognized a dual channel.


May 29, 2013
Asus Z370-G Gaming (Wi-Fi AC)
i9-9900K OC'd @ 5.0GHz
RX 6600 XT
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
The BCM943602 from MacBook Airs use only two antennas. The Dell DW1830 that I tested uses three antennas. I have spare antennas that I connected to the DW1830 when I tested it.


May 29, 2013
Asus Z370-G Gaming (Wi-Fi AC)
i9-9900K OC'd @ 5.0GHz
RX 6600 XT
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
My pleasure!! Glad I was able to help!!

Have you applied the proper USB 15 port limit fix? I've already done all the tedious work. It should be a breeze for everyone else now.

Note that if you use:
All USB ports will be active except for the 2 USB 2 ports in the rear and 3 out of 4 of the internal USB2 ports from the internal headers. The fourth can be used for Bluetooth with Wi-Fi/Bluetooth adaptors.
Last edited:


May 29, 2013
Asus Z370-G Gaming (Wi-Fi AC)
i9-9900K OC'd @ 5.0GHz
RX 6600 XT
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
As per RehabMan, the USB 15 port limit KextToPatch should only be used temporarily for the purpose of port discovery so that the permanent fix can be applied.

Source: #1553

That being said, plenty of people (majority?) probably never apply the permanent fix and are fine with it...


May 29, 2013
Asus Z370-G Gaming (Wi-Fi AC)
i9-9900K OC'd @ 5.0GHz
RX 6600 XT
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Out of curiosity, with the BCM942602 card and M2 adapter. How does the antenna fit together, I'm assuming the card has either 3 or 4 antenna connectors. I think for the dual channel 32GB you would need 16GB memory in slot B1, and 16GB in A1.


I got the Dell DW1830 working! All I needed were two kexts. I've updated my build description with the details.


Staff member
Sep 21, 2010
Gigabyte Z690 Aero G
RX 6800 XT
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Very nice build description. I've decided to get the ASUS ROG MAXIMUS Z370 X HERO (non WiFi/BT version) with a i7 K processor, and I'll use either my Gigabyte 1060 or Sapphire RX 580 Pulse 8GB graphics card (works OOB). So, you got the mATX GENE Club covered, and I'll continue with the HERO Club.

However, I can't wait for 2018 as Intel will drop charging royalty fees for Thunderbolt. So, we'll see more motherboards with Thunderbolt 3 chipsets. :thumbup:
Last edited:


May 29, 2013
Asus Z370-G Gaming (Wi-Fi AC)
i9-9900K OC'd @ 5.0GHz
RX 6600 XT
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Thanks, Stork!

Getting this Z370 build up and running seems to have gone much smoother than when I did my first build, the Gene. I find it amazing that just about everything is working so well, especially Sleep/Wake. On the Gene, there were several occasions where I had to figure out what was breaking it. On this build, it just works.

I was a little too impatient to wait for Thunderbolt to go royalty free. I have a friend who was willing to take my delidded i7-7700K off my hands and went with it.

I think you will be extremely happy with Z370. Also, I'm quite certain that the EFI folder I posted on post #1 will work fine for the Hero too. ;)
Nov 19, 2017
I'm following the discussion with very interest. So i'd like post 2 question about the other z370 mATX:
ASRock Z370M Pro4, Gigabyte Z370M D3H, MSI Z370M GAMING PRO AC i noticed they are without WIfi ngff card a part MSI but is full of USB Type A and no 3.1. Is it more hackintoshable(XD) the asus for you or there is somenthing else apart the higher price :-D? And Did u enable the type A? I see you remapping well by your pic u posted but no about that. Sorry for several questions but it's christmas time for hackintosh gift lol.