Contribute
Register

Mojave installation freezes at 2 minutes left

Joined
Sep 28, 2018
Messages
10
Motherboard
ASUS PRIME H370-A
CPU
i7-8700
Graphics
RX 570
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
Ok boys,

for my Hardware the shutdown freeze - problem is THE SAME issue, because I can't install it without freeze.
There at the "2 min. remaining"-position the PC would normally restart and continue with 2nd stage of installation.
BUT: It cannot restart, because it freezes on restart.

So, for my hardware (see profile): I used "OsxAptioFixDrv-64.efi" in the "Drivers64UEFI"-folder (not v2, v3 or old AptioMemoryFix) and it's working great for now. It seems, that this is depending on, which hardware you have.
Working Shutdown, Restart, Standby - FINE!

In CLOVER, I am using:
  • Fixes:
    • FixShutdown
    • FixDisplay
    • FixUSB
    • AddPNLF
    • FixS3D
  • Boot:
    • darkwake=1
    • dart=0
    • disablegfxfirmware
  • SMBIOS iMac 18,3

After I got restart / shutdown running, I tried to vanilla install Mojave fresh again and it worked - no crash or freeze.
 
Joined
Oct 11, 2018
Messages
1
Motherboard
ASUS H370-A
CPU
i7 8700
Graphics
Sapphire Nitro RX580 8GB OC
Mac
MacBook Pro
Mobile Phone
iOS
Ok boys,

for my Hardware the shutdown freeze - problem is THE SAME issue, because I can't install it without freeze.
There at the "2 min. remaining"-position the PC would normally restart and continue with 2nd stage of installation.
BUT: It cannot restart, because it freezes on restart.

So, for my hardware (see profile): I used "OsxAptioFixDrv-64.efi" in the "Drivers64UEFI"-folder (not v2, v3 or old AptioMemoryFix) and it's working great for now. It seems, that this is depending on, which hardware you have.
Working Shutdown, Restart, Standby - FINE!

In CLOVER, I am using:
  • Fixes:
    • FixShutdown
    • FixDisplay
    • FixUSB
    • AddPNLF
    • FixS3D
  • Boot:
    • darkwake=1
    • dart=0
    • disablegfxfirmware
  • SMBIOS iMac 18,3

After I got restart / shutdown running, I tried to vanilla install Mojave fresh again and it worked - no crash or freeze.
Would you put here your EFI directory? My hardware is ASUS PRIME H370-A, i7-8700, and RX 580 (Sapphire Nitro), and has similar problems.
 
Joined
Sep 28, 2018
Messages
10
Motherboard
ASUS PRIME H370-A
CPU
i7-8700
Graphics
RX 570
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
Would you put here your EFI directory?
Hey! Yes, I will upload it, once I fixed some other issues (like Preview not showing JPG). Count on me this weekend! :)
 
Joined
Sep 28, 2018
Messages
10
Motherboard
ASUS PRIME H370-A
CPU
i7-8700
Graphics
RX 570
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
Hey @shzrn,
to be clear, my issue was, that it FREEZES on Installation or shutdown or restart. The issue was not, that it restarts at the 2 min. remaining position - this happened to me too after fixing the FREEZE - but everything went fine, when booting then from the "HDD" Install Volume.

HighSierra (without my fixes) didn't work to install.

So, here is my EFI-Folder, I changed the Serial-Nr., you should do that, too.

The issue with preview not showing JPG files, was not to fix with this. I could fix this with changing the Bios-Settings in Advanced -> [Forgot how the option tree is named...] -> Graphics -> Initial Display = CPU Graphics + iGPU MultiMonitor = ON


Hope you can rock your Hackintosh on Mojave as well! Mine is working even better than my 2013 MacPro.

Wish you a nice Sunday! :)

(I changed the theme of the boot loader, it should look nice :D)
 

Attachments

Joined
Oct 13, 2018
Messages
1
Thank you 1000 times, your settings fixed my 2 min remaining freeze. I also have a asus h370 mainboard.
 
Last edited:
Joined
Nov 18, 2018
Messages
7
Motherboard
ASUS Prime H370-A
CPU
i7-8700
Graphics
RX-570
As an example.
I write my installation of mojave.
ms-staips said that an EFI file on a memory relation was a problem.
The installation of me was also same.
In case of me, the one necessary to the installation was OsxAptioFix2Drv-64.efi.
I tried an article of installation of techhowdy by chance. That was good luck. The EFI isn't refined. But it was simple. I add improvement to the EFI and use it.
 

Attachments

Joined
Nov 18, 2018
Messages
1
Motherboard
Asus ROG Strix H370-I
CPU
i3-8100
I am a total noob to all this.
I generated my bootable USB drive using Unibeast.
I have a Asus H370-I board, with a i3-8100.
I erased my 970 EVO SSD to Mac OSX Journaled (GUID).
I also get the 2 minute remaining freeze at the first boot with the error in log: „disk[...] is not convertible to APFS [...]“.
It seems that in this thread a solution to my problem has been found, but I don't quite undestand how to implement it.
Are the suggested changes even possible with a Unibeast generated USB stick or do I have to generate the USB stick on my own for that?
Any suggestions where to start here?

Thanks in advance.
 
Joined
Nov 18, 2018
Messages
7
Motherboard
ASUS Prime H370-A
CPU
i7-8700
Graphics
RX-570
I'm not good at English, but I try to explain.

The contents of the LOG suggest that there is possibly a different problem.

But first, I write the approach of a problem here.
1.Insert a USB memory of installation(After set up with unibeast).
2.And install Clover Configrator.It is here.
3.Start Clover Configrator.
4.Click ”MountEFI” of the left Tools space.
5.Find the name of the USB Installer in ”Efi Patition space” for the lower half.
6.And click the "Mount Patition" of the USB Installer memory.
7.Type your password in the window of confirmation.
8.Click "Open Partition" of the USB Installer.And finder will be opened.

Try NEXT 9(and SMBIOS changing) or 9-a~9-b

9.Find "EFI" folder,and rename e.g. "EFI.bak" for the backup.go to 10.

9.a Find "EFI" folder,Click'nOpen "EFI-CLOVER-drivers64UEFI"
9.b Find
  1. AptioMemoryFix-64.efi
  2. OsxAptioFix3Drv-64.efi
  3. OsxAptioFix2Drv-64.efi
  4. OsxAptioFixDrv-64.efi
  5. OsxLowMemFixDrv-64.efi
and use only one,try OsxAptioFixDrv-64.efi or OsxAptioFix2Drv-64.efi, deleting other.go to 12.
10.Download ms-staips EFI or my EFI,the differents is using OsxAptioFixDrv-64.efi or OsxAptioFix2Drv-64.efi.Try each.
11.copy as "EFI"(If necessary, rename) which is downloaded to the EFI of the USB Installer memory.
12.Finally click "unMount partition" of the USB memory installer on "Clover Configrator"
13.Try Boot the USB memory Installer on Hackintosh computer.(Push F3 button to see all boot choices)
(You may have to change SMBIOS to iMac14.2.
1.Do 1-8.Click "Open Partition" of the USB Installer.And Finder will be opened.
2.And click on Finder to EFI-CLOVER,And right-click config.plist,open Clover Configrator.
3.So Clover Configtator re-open,Click ”SMBIOS” of the left "Sections" space.
4.On the right end,under the "Check Coverage", the select button is here,click it and select iMac14.2
5.Click the 2nd icon from the left of bottom left corner, save.
6.By the same way as the top, unmount.
)

All the best
 
Last edited:
Top