Contribute
Register

Mojave installation freezes at 2 minutes left

Joined
Dec 24, 2015
Messages
10
Motherboard
MSI B360m Mortar
CPU
i5-8400
Graphics
RX 570
Hey everyone. so I'm on my first Hackntosh build and and to be honest its kicking my ass. Getting stuck on the 2 min remaining. I'm trying to install on an Intel Nuc 8.

Hi, maybe it is related to your Aptiomemoryfix or AptioFixDrv2-64 + EmuVariableUefi-64 setting.
Search online for the similar build as yours and try replacing *.efi files using clover configurator. It is about tries and errors.
 
Joined
Jan 7, 2019
Messages
3
Motherboard
Intel NUC8i5BEK
CPU
i5
Graphics
Iris Plus Graphics 655
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Thanks, Cheng10. It gives me a starting point.
 
Joined
Feb 2, 2019
Messages
3
Motherboard
Asus Z390 Gaming Pro
CPU
i9-9900K
Graphics
Vega 64
Mac
iMac, MacBook, MacBook Pro, Mac mini
Mobile Phone
iOS
Have the same issue here. Trying it at a i9 9900K on a Asus Z390-PRO.
CPU is running heavily. Have same result with high sierra.
Any help?
 
Joined
Jan 7, 2019
Messages
3
Motherboard
Intel NUC8i5BEK
CPU
i5
Graphics
Iris Plus Graphics 655
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
@macamiga, I wish I could help, but I'm still not getting much traction here. I'm still on the fence, but rapidly approaching the point of going with Plan B: keep the NUC as a Linux machine.

I'm a long-time Mac user and thought I'd stick with the platform forever. But things have changed at Apple since Jobs' death—just like they dipped when he "left" the first time. It almost seems as though they've left MacOS behind in favor of iPhones, which is all I hear about anymore. That, and the latest wave of new-and-improved smiling poo emojis. When an actual laptop or desktop computer is upgraded, it is ridiculously over-priced (like never before), has underwhelming specs, and Louis Rossmann's videos have helped me see how very shoddy the build quality is. That's how I got around to trying Hackintoshing.

Apple hardware has generally been very problem-free for me, but I'm not blind to all the reports I've seen of other users having problems. Then when I saw the "stagelighting" problem on the latest MacBooks in one of Rossmann's videos, it rang a bell—I had a first gen Titanium die just like that. So, obviously Apple isn't learning from some very old mistakes.

Linux has improved so much over the years that I'd now recommend some distros to even the least propellerheaded of my friends. I'd lose a few apps by jumping platforms, but I've been finding replacements—as well as pleasant surprises like discovering that the scan software (Hamrick's VueScan) and "lifetime" serial number I've been using for over a decade now works on Linux. Lots of my favorite apps are already FOSS, and some companies (like Blackmagic Design) are catering to Linux.

I may beat my head on this Hackintosh thing for a while longer, but if I wanted to flush away all my hours tinkering with the computer, rather than getting work done with it, I'd use Windows.
 
Joined
Feb 2, 2019
Messages
3
Motherboard
Asus Z390 Gaming Pro
CPU
i9-9900K
Graphics
Vega 64
Mac
iMac, MacBook, MacBook Pro, Mac mini
Mobile Phone
iOS
Hi metryq, I do understand your point here and I am not happy at all with apples direction. Especially the price of their hardware. This leads me to think about hackintosh. This is not my first attempt and let's say here:
all guys who develop all this stuff is unbelievable great!
But even when I chose my hardware to be high compatible i.e. having a AMD Vega that has lower performance compared to Nvidia and choosing Intel and Z-chipset - it's still not easy to set this beast up ;-)

So the last days I learned a lot. i.e. not every usb stick leads to equal results :-O
I own a very fast MX-ES Stick - creation unibeast is so fast, but I get an error that it can't find root filesystem when trying to use it for installation...

But anyway - I tried to copy stuff from EFI @ms-staips to and it booted a lot faster, but still stuck at 2 mins freeze.
Shall I copy over/replace the whole EFI dir on stick?
I did partial...because some file were newer. But I copied the properties file.
(will retry this and post the result)

Is there a way to remount this EFI partition using terminal?

thx in advance
 
Joined
Mar 9, 2019
Messages
23
Motherboard
ASUS PRIME H310M-K
CPU
i5-8400
Graphics
UHD 630
Mobile Phone
Android
@mp-staips

Why do you use -lilubetaall?

There is warning about this one

to enable Lilu and all loaded plugins on unsupported os versions (use very carefully).
 
Joined
Mar 17, 2019
Messages
3
Motherboard
Lenovo Thinkpad T480 X220
Mac
MacBook Pro, Mac mini
Mobile Phone
Android, iOS
My Mojave installation freezes at 2 minutes left. The mouse pointer frozen, I've left it for 30 minutes, changes usb ports, erase sdd, all no luck.
I am having this same issue with a T480 using kexts from https://gitlab.com/maemo8086/thinkintosh_t480, which solved my issue with trackpad and keyboard (was not able to select language by any means before gitlab EFI)

any suggestions? recommendations?
 
Joined
Mar 9, 2019
Messages
23
Motherboard
ASUS PRIME H310M-K
CPU
i5-8400
Graphics
UHD 630
Mobile Phone
Android
I am having this same issue with a T480 using kexts from https://gitlab.com/maemo8086/thinkintosh_t480, which solved my issue with trackpad and keyboard (was not able to select language by any means before gitlab EFI)

any suggestions? recommendations?
try to use OsxAptioFix2Drv.efi or OsxAptioFixDrv.efi

don't use OsxAptioFix3Drv.efi and AptioMemoryFix-64.efi

use only one of them, don't put them together
 
Joined
Mar 17, 2019
Messages
3
Motherboard
Lenovo Thinkpad T480 X220
Mac
MacBook Pro, Mac mini
Mobile Phone
Android, iOS
try to use OsxAptioFix2Drv.efi or OsxAptioFixDrv.efi

don't use OsxAptioFix3Drv.efi and AptioMemoryFix-64.efi

use only one of them, don't put them together
So I thought I deleted AptioFixDrv.efi but I ended up deleting AptioInputFix.efi. so I had both OsxAptioInputFix.efi and AptioInputFix.efi

Clover loads, Select install from USB, Now I get the apple icon, And just hangs No loading bar, any way to recover? I can install a *nix distro on the drive but Mojave will not load.

Any recommendations?
 
Last edited:
Joined
Mar 9, 2019
Messages
23
Motherboard
ASUS PRIME H310M-K
CPU
i5-8400
Graphics
UHD 630
Mobile Phone
Android
So I thought I deleted AptioFixDrv.efi but I ended up deleting AptioInputFix.efi. so I had both OsxAptioInputFix.efi and AptioInputFix.efi

Clover loads, Select install from USB, Now I get the apple icon, And just hangs No loading bar, any way to recover? I can install a *nix distro on the drive but Mojave will not load.

Any recommendations?
screenshot of your kexts and drivers64 folder

and screenshot of boot, you have to set "-v" parameter in clover options before selecting mojave installation
 
Top