Contribute
Register

macOS 10.14.4 Update

Joined
Dec 24, 2015
Messages
18
Motherboard
Gigabyte GA‑Z170X‑Gaming 3
CPU
i7‑6700K
Graphics
RX 570
Mac
iMac
Mobile Phone
iOS
Note: anyone updating clover make sure to select the “Customize” tab on the left before instal option. Go to the Drivers64EFI folder and manually select “apfsautoloader”, and “aptiomemoryfix”.
Before rebooting mount your EFI and check Drivers64EFI folder and check that they installed, then remove apfsEFI if it’s there from previous clover build and also OSXAptiofixdriver(s) as well. Aptiomemoryfix replaces that and will not work right if both are there.

Thanks!! Did this and it worked for me now, Kept hanging on update screen although I had updated Clover already.
 
Joined
Jun 5, 2015
Messages
4
Motherboard
Gigabyte B250M-DS3H
CPU
i7
Graphics
RX 570
Mac
iMac
Mobile Phone
iOS
Update Clover, Lilu, WhateverGreen and the installation went without problems for me.
Thank you
 
Joined
Oct 3, 2011
Messages
78
Motherboard
Asus Prime Z390-P
CPU
i3-8100
Graphics
UHD630, RX 580
Mac
MacBook Pro
Mobile Phone
Android, iOS
The ALC1150 has a silent problem after sleep. I hope that the GregP9999 accessory can solve this problem, but it has not been tested yet.

Motherboard Asus b85-pro gamer silent after sleep in mojave 10.14.4,
Inject ID in a variety of ways, still silent after sleep

Clover config.plist + DSDT + SSDT-HDEF.aml
--------------------------------------------------
The AppleALC.kext provided in the attachment seems to perfectly solve the silent problem after ALC1150 sleeps.
Can confirm that the kext from @GregP9999 is also working on my build with ALC1150. Sound after sleep is still there. Thank you.
 
Joined
Apr 25, 2017
Messages
21
Motherboard
Gigabyte GA-Z370-HD3P
CPU
i5-9600K
Graphics
UHD 630
Classic Mac
iBook, iMac
Mobile Phone
Android, iOS
Hi! do you say that with this update, Mojave supports Intel Graphics UHD 630 native now?
So, you had made a video patch in config.plist with hackintool (platformId, etc)... and now it is not necessary?

Can you explain something more about this?

thanks!
Yes just like you said:
Before the update:
IntelGFX: 0x59128086
Checked: Inject Intel
ig-platform-id: 0x59120000
Result: Intel UHD Graphics 630 1536 MB

After the update:
IntelGFX: 0x0
Unchecked: Inject Intel
ig-platform-id: clear the value
Result: Intel UHD Graphics 630 1536 MB

Here are the kext that I have installed:
AppleALC
FakeSMC (ofcourse)
IntelMausiEthernet
Lilu (I don't think that I have to use this now, but didn't tested it)
Whatevergreen (I don't think that I have to use this now, but didn't tested it)
 
Last edited:
Joined
Nov 8, 2011
Messages
44
Motherboard
Z370 HD3 (UEFI F7)
CPU
i7-8700K
Graphics
RX 580
Updated Clover (4910), Lilu, WEG and AppleALC. Currently using a headless configuration with platform ID (0x3E920003) and inject Intel. Used system update and got 10.14.4 with three reboots in about 15-20 minutes. All in all very smooth update. Audio works, USB 3 works (custom SSDT), nothing seems to be broken.

395774
395775
 
Joined
Sep 21, 2013
Messages
554
Motherboard
Gigabyte Aorus Z370 GA-7
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook, MacBook Pro, Mac mini
Classic Mac
Classic, iBook, Power Mac, PowerBook, Quadra, SE/30
Mobile Phone
Android, iOS
This video processing display right above ^ -I've never found it via System Info, etc. Is it a special app?
I never get the "Hardware Accelerated" logo on my "About" page, though everything seems to work.
BTW, love the logo!
Overlay Systems and GPU stuff.png
 
Joined
Sep 6, 2016
Messages
2
Did not update clover, and upon reboot the computer attempted to boot from the installer preboot partition to drive the install - but it hung with the progress bar and Apple logo. It complained about "unsupported CPU" or something when I turned on verbose from clover.

Updated to the latest bleeding-edge clover (r4910): https://sourceforge.net/projects/cloverefiboot/files/latest/download
Restarted the update and it successfully ran.

I would say that yes, updating clover should be everyone's first step before attempting this update.
 
Last edited:
Joined
Jan 4, 2014
Messages
55
Motherboard
Gigabyte Z390 AORUS PRO
CPU
i9-9900K
Graphics
RX 5700 XT + RX 590
Mac
MacBook Air
Mobile Phone
Android
This is my first update to my new hackintosh, since the clean install of Mojave 10.14.3.
I followed all instructions: backup of EFI, updated clover and suggested kexts, backup of ssd, and update via App Store.

All is actually working fine (Audio, USBs with custom SSTD and headless iGPU)

I've never found it via System Info, etc. Is it a special app?
It's a video encoding program with functions like Avi Demux called VideoProc, very useful to test if the iGPU/dGPU are correctly detected by the system.
 

Attachments

Joined
Oct 19, 2015
Messages
5
Motherboard
Gigabyte Z370M AORUS Gaming
CPU
i3-8100
Graphics
RX 580
Mac
iMac
I had the same problem, the update went just fine but after the T6E wasn't detected anymore. Added AirportBrcmFixup.kext and now it's detected and works as before with the added bonus of being recognized as AirPort Extreme :)
Thanks for the reply, but you can pass me the links from where to download
 
Joined
Sep 1, 2016
Messages
334
Motherboard
GA-Z170N Gaming 5
CPU
i7-6700K
Graphics
RX 580
Was already on Clover 4871, so I didn't update for this one. Updated to the latest WhateverGreen, Lilu, and AppleALC kexts from the TonyMac Downloads section. Backed up via SuperDuper!, and went for it. Three, maybe four restarts and close to a half-hour or so of updating, and everything appears to be working fine. Thanks all!

Screen Shot 2019-03-29 at 10.36.35 AM.png
 
Top