Contribute
Register

macOS 10.14.4 Update

Status
Not open for further replies.
Joined
Aug 5, 2012
Messages
324
Motherboard
GIGABYTE H270N-WIFI
CPU
i7-7700
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. iOS
MAS update went smoothly, without any problems with my config. All good.
 
Joined
Sep 30, 2018
Messages
6
Motherboard
ASUS Z97m-plus
CPU
E3-1230 v3
Graphics
RX 470
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
@Cam-Resu
Thank you, under your guidance, I have completed the modification work, thank you!
Gimp, size 512*512, PNG
 

Attachments

  • 屏幕快照 2019-03-30 下午10.29.37.png
    屏幕快照 2019-03-30 下午10.29.37.png
    347.9 KB · Views: 137
Joined
Mar 20, 2016
Messages
9
Motherboard
Dell Optiplex 7010 USFF
CPU
i7 3770s
Graphics
HD 4000
Mac
  1. iMac
Sleep was working for me under 10.14.3.
Not working now since this update.
But I also updated Clover to 4862 before installing the update.
I might troubleshoot with some other Clover versions
 

elfcake

Banned
Joined
Nov 26, 2012
Messages
1,740
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Updated through System Preferences, three restarts, 19 minutes from download to desktop.
Everything is working.
Screen Shot 2019-03-30 at 9.50.35 AM.png
 
Last edited:
Joined
Feb 22, 2011
Messages
4
Motherboard
<< need model # >> See Forum Rules !!
CPU
i5 << need model # >> See Forum Rules !!
Graphics
hd 4000
10.14.3 went fine, but 10.14.4 does not like something. At reboot it hangs. I am trying to figure out where exactly it hangs.
Update to latest Clover boot loader, download the update, install, and, when it hangs, restart and boot with Mac installer from Clover selection. It will install the update and will restart.
 
Joined
Feb 23, 2015
Messages
12
Motherboard
GA Z97X-UD3H
CPU
I5-4690
Graphics
MOBO
Mac
Classic Mac
Mobile Phone
Had the exact same issue when I was trying out beta version on a test drive. Looks like the issue still persists with the final version.

Important. U must to have latest Clover boot-loader. Do not touch anything. Clover know wat to do.
 

Attachments

  • Screenshot 2019-03-30 at 20.29.58.png
    Screenshot 2019-03-30 at 20.29.58.png
    70.1 KB · Views: 70
Last edited:
Joined
Dec 16, 2017
Messages
2
Motherboard
Fatal1ty Z270 Gaming-ITX/ac
CPU
i7
Graphics
RX 580
After a good SuperDuper backup and updating the bootloader and all pertinent kexts the installation of the 10.14.4 update went without a hickup. The only mod was the usual port limit update (Thanks @ModMike,) My build is ASRock Fatal1ty Z7270, I7 7700K (Kaby Lake) with a Radeon RX 580. Everything working now, including iMessage and sound. Still breathing fire!
 
Joined
Feb 19, 2011
Messages
23
Motherboard
DeskMini 110 W (H110M-STX)
CPU
i3-7100
Graphics
HD 630
Pre Update Notes:
- This update may break some of your Mojave functions, like audio. Make sure you backup first.:thumbup:

- There are NO Nvidia Web drivers for Mojave as of this date/time. So, this update is for non Nvidia graphics card users.

- Make sure you use the latest versions of the Lilu.kext and WhateverGreen.kext. They will be in the Downloads > Kexts area. AppleALC.kext is located here.



Please post help requests in the Mojave Desktop Support Forum section (not in this thread).



Here's the step by step way to update:
:ch:Backup your current installation using Carbon Copy Cloner or SuperDuper;

:ch: Update to the latest Clover: Downloads > Clover Builds.

:ch: Download the Mojave 10.14.4 Update or Combo Update in Post #1 or the update from Apple's Mac App Store and run it - the updater will reboot upon completion.
...

I had a different experience, and a few things didn't go well, but, since I heeded your primary statement [BACK UP!] all ended well.

I first tried updating to the latest Clover build (here) but it was bugging out and the install failed [>once], and I also [first] tried to upgrade directly from the [upgrade] preference panel--no joy. After a few mishaps, I just did a retroactive backup to a relatively recent snapshot and started over...using the older Unibeast USB I had used for 10.14.3.

I ended up going to the Clover site ( https://sourceforge.net/projects/cloverefiboot/ ) and got the most recent stable build at that time (4910), and it installed successfully. Then, after restart, I used the link provided here to download the [basic] update (not the combo), and installed that without a hitch.

Upgrade didn't take long, and after a couple restarts, in which the correct drive/partition was automatically chosen through the update software process (unlike some in recent past upgrades), so I booted into 14.4 -- woohoo!

Everything seemed to work OK except the audio, which was expected, based upon experiences.
Using current MultiBeast, I then installed driver for audio (ALC and 3-port option), and my HDMI audio was all set for selection and setup using Audio MIDI Setup, after restart. Although I haven't checked EVERYTHING exhaustively, everything seemd to work well, and I have sleep/wake, etc., sound and graphics seem great etc.

Success! Thanks, to yall and the resources here at TonyMac ;)
Thumbs up doods!
 
Joined
Feb 17, 2019
Messages
8
Motherboard
ASUS Prime Z390-A
CPU
i7-9700K
Graphics
UHD 630 / RX 580
Mac
  1. MacBook Pro
Piece of junk broke my imessage
 
Joined
Jul 3, 2015
Messages
94
Motherboard
HP Elite Desk 800 G4 SFF - Q370
CPU
i7-8700
Graphics
WX 4100
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Updated to 10.14.4 using combo update.
Have a GA-Z97N motherboard with ALC892 audio.
No audio on wake from sleep after updating to 10.14.4.
Downloaded and installed most recent AppleALC kext (1.3.6) used Kextbeast to install updated kext, restarted and then cleared cache using Kext Utility.
Followed An iDiot's Guide To Lilu and its Plug-ins
Audio now working after sleep.
I still have same audio problem as you mentioned, and it didn't help after upgrading the AppleALC and Lilu. How did you clear the cache?
 
Status
Not open for further replies.
Top