Contribute
Register

macOS 10.14.1 Update

Status
Not open for further replies.
Joined
Jun 16, 2018
Messages
21
Motherboard
ThinkPad Yoga 12
CPU
i5-5200U
Graphics
HD 5500, 1920x1080
after update, when all set and done, restarted with a fatal osxaptio error.

Had to update my old OsxAptioFixDrv-64.efi to OsxAptioFix3Drv-64.efi.

All perfect now!

Thanks for this feedback. This helped solving my problem.
 
Joined
Sep 23, 2011
Messages
18
Motherboard
Gigabyte Z370 HD3P
CPU
i7-8700
Graphics
HD 630
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
Gosh, 10.14.1 got me a hard time! It installed OK but then, it just got stuck with no error message, with no crash or whatsoever, just not willing to start the GUI.
I even restored my previous 10.14 conf. from Time Machine backup 3 times, before I thought about changing the SMBIOS Product Model from iMac 17,1 to iMac 18,3 in the Clover options at boot time. Stupid me!
Then at last, it accepted starting, but with an intolerable flicker of the display, which I had already noticed with iMac 18,3 on Mojave.
Finally, after multiple trials, it turned out iMac 14,2 stopped the flicker for me.

Screen Shot 2018-11-07 at 11.23.47 PM.png
 
Joined
Nov 9, 2010
Messages
72
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4790K
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Looking for the definitive expert on Mojave here...
Still struggling to get a valid update installed. Early on in betas there was a flag allowing install on HFS+ so I chose that method since APFS was getting some bad ink back there... so when the final release arrived I tried and was unable to install using Unibeast... but I discovered another method elsewhere which did allow the HFS+ install, and that was successful. All my testing is using SSD drives.

Lastly, I cloned and then converted that disk to APFS and then attempted to install the update using the 6gb image download. It did begin that install but then after the progress bar had barely moved, the system just rebooted and gave up, so that was about as close as I've come so far.

I'm hoping someone can affirm or deny that APFS will be mandatory from this point forward.
I've also discovered that if I'm booted to the HFS+ version, and go into Update in SysPref, the system says I'm up to date at 10.14, and that there are no updates available... but if I clone and then convert to APFS, now the system is willing to download the update... which again seems to say the HFS+ ship has sailed. I'm about to try that download and install method next but still looking for some more experienced wisdom on all this.
 
Joined
Jul 26, 2012
Messages
12
Motherboard
ASUS H370-i
CPU
i7-8700
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Gosh, 10.14.1 got me a hard time! It installed OK but then, it just got stuck with no error message, with no crash or whatsoever, just not willing to start the GUI.
I even restored my previous 10.14 conf. from Time Machine backup 3 times, before I thought about changing the SMBIOS Product Model from iMac 17,1 to iMac 18,3 in the Clover options at boot time. Stupid me!
Then at last, it accepted starting, but with an intolerable flicker of the display, which I had already noticed with iMac 18,3 on Mojave.
Finally, after multiple trials, it turned out iMac 14,2 stopped the flicker for me.

View attachment 363836

SMBIOS'es 18.3 and 18.2 expect that the device has two graphic cards, internal and external, that's why there is flicker when you use only internal Intel card. 18.1 is your friend, since it is from a iMac without external card.
 
Joined
Feb 11, 2013
Messages
12
Motherboard
Gigabyte Z370 Aorus Gaming 3
CPU
i7-8700
Graphics
RX 480
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
I also lost Quicksync after updating to 10.14.1. I had also updated Whatevergreen and Lilu kexts at the same time. I went back to previous versions of those kexts and now Quicksync works again.

View media item 191192
Can you send them to kexts please?
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,998
Motherboard
GB Z490 Vision G
CPU
i9 10850K OC @ 5.2 GHz
Graphics
Vega 64 LC + HD 630
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
I'm hoping someone can affirm or deny that APFS will be mandatory from this point forward. I've also discovered that if I'm booted to the HFS+ version, and go into Update in SysPref, the system says I'm up to date at 10.14, and that there are no updates available... but if I clone and then convert to APFS, now the system is willing to download the update... which again seems to say the HFS+ ship has sailed. I'm about to try that download and install method next but still looking for some more experienced wisdom on all this.

The 10.14.1 Update will only install on a APFS system partition, but you can clone a 10.14.1 APFS formatted system back on to a HFS+ partition and it will run fine. See my post here :-

https://www.tonymacx86.com/threads/using-hfs-instead-of-apfs-for-mojave-update.264001/#post-1842436

Post #1 of the thread confirms the problem, post #6 confirms that 10.14.1 still works ok on HFS+

Cheers
Jay
 
Joined
Sep 1, 2016
Messages
382
Motherboard
GA-Z170N Gaming 5
CPU
i7-6700K
Graphics
RX 580
I picked up a used rx 570 8gb for $120. Or you can get a rx 560 4gb for about $70 on ebay.

Got a new rx 580 4gb on eBay for $60. 2gb more than I have now, so... thanks!

[Edit: too good to be true. eBay sent me an email that the listing was bogus. Money refunded, and searching anew...]
 
Last edited:
Joined
Sep 21, 2016
Messages
2
Motherboard
GA-Z170N Gaming 5
CPU
Core i5-6600K @ 4.3 Ghz
Graphics
Radeon HD 7970
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
No issues on my z170 machine: i5-6600k, Radeon HD 7970.

I didn't lose my audio (configured via Clover) or QuickSync (Whatevergreen, Lilu are the same ones from when I updated to Mojave).
 
Status
Not open for further replies.
Top