Contribute
Register

macOS 10.13.4 Update

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
19,997
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
Intel HD Graphics 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Would you take a photo of this and post it here for review ?
It's not news - Mieze has no love for this site and includes that message in her drivers.
I think that the one available for download here has had that line removed.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,689
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
This is probably not the place to ask this, but why is my IntelMausiEthernet kext saying "Don't support Tonymacx86.com" in boot? I mean, whatever issue is here, placing it in user's boot messages is kinda, super ****ing wrong IMO.
Use the IntelMausiEthernet kext in the Downloads > Kext section as it doesn't have that embedded message.
 
Joined
Nov 27, 2011
Messages
12
Motherboard
GA Z170MX-Gaming 5
CPU
Skylake 6700K
Graphics
Aorus Radeon RX 570 4GB
Mac
MacBook Pro
Mobile Phone
iOS
It's as you quoted above.

It takes a good 30 seconds before I get any signs of life from my screen after sleep. My computer turns back on, I can hear new emails and such, but no video until I wait about 30 seconds. It seems like the computer is waking up and trying to access my IGPU first, when it sees that it doesn't have a signal from that, it switches over the the RX 480. If I disable the IGPU in the bios, this issue disappears. Problem is, I have to have the IGPU enabled, otherwise I get quicksync issues and my graphics performance drops in half after watching videos or playing a game. Putting whatevergreen back seems to resolve this issue, but I'm not sure if it's causing any overlapping driver issues.

As far as Injecting intel goes, I'm not entirely sure what you mean. I simply have the flag ticked in Clover Configurator. I also have ig-platform-id enabled, along with IntelGFX Fake ID so that it picks up my IGPU. This means the operating system can see both graphics cards and I don't get any quicksync issues. Just the sleep issues if I remove Whatevergreen.

I also can't wake from sleep using my bluetooth devices (keyboard and mouse).
OK. But your machine sleeps. I am also experiencing this delay with 10.13.4 (without Whatevergreen) but I'm not treating it as a biggy. We're both on Skylake with BIOS Intel enabled and I'm injecting Intel 'headlessly' with an ig-platform-id of 19120001 not 19120000, and the Intel card does not show up in System Report > Graphics/Displays, which I like, just my AMD. I have video Hardware Encoding. Sorry if you know all that.

As for not waking from bluetooth I assume you have 'Allow Bluetooth devices to wake this computer' true in advanced bluetooth settings?
 
Joined
Feb 28, 2018
Messages
15
Motherboard
MSI z170a xPower Titanium
CPU
i5-6600K
Graphics
RX 480
Mac
MacBook
Mobile Phone
iOS
OK. But your machine sleeps. I am also experiencing this delay with 10.13.4 (without Whatevergreen) but I'm not treating it as a biggy. We're both on Skylake with BIOS Intel enabled and I'm injecting Intel 'headlessly' with an ig-platform-id of 19120001 not 19120000, and the Intel card does not show up in System Report > Graphics/Displays, which I like, just my AMD. I have video Hardware Encoding. Sorry if you know all that.

As for not waking from bluetooth I assume you have 'Allow Bluetooth devices to wake this computer' true in advanced bluetooth settings?
Yeah, my machine definitely sleeps. I'm using the exact same ig-platform-id. What do you mean by "headlessly"? Do you experience the graphics card performance degradation after playing videos in VLC or playing a game? Is your IGPU disabled in your bios? And how would one go about enabling video hardware encoding? And OMG, I had no idea that the wake from Bluetooth feature was an option. I'll have to check when I'm home, although I'm a little worried because ALL of my USB connections disconnect during sleep.

Sorry for all the questions, you've been extremely helpful!
 
Last edited:
Joined
Nov 19, 2016
Messages
33
Motherboard
Gigabyte GA Z170X UD3
CPU
i7-6700K
Graphics
RX 580
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Everything works great. Audio worked as well. Maybe it's because I didn't use Toleda's script in the first place. Since High Sierra, NVidia's automatic upgrades haven't worked for me. Someone posted here about a script where it chooses the best Nvidia driver for you. That fixed all the display problems. Although, before running the script, I had to install the Nvidia driver update in Sys Pref.
https://github.com/Benjamin-Dobell/nvidia-update
 
Joined
Mar 29, 2011
Messages
230
Motherboard
GA-Z170X-UD3 (F23g)
CPU
Intel Core i5-7400
Graphics
Asus Radeon RX 560 4GB
Joined
Feb 5, 2013
Messages
778
Motherboard
Asus X299 Prime Deluxe
CPU
i9 7940X
Graphics
Radeon VII
Mac
iMac, Mac Pro
Top