Contribute
Register

List of AMD Radeon Navi cards in Catalina That work.

Joined
May 11, 2011
Messages
1,154
Motherboard
Asrock B365M Phantom Gaming
CPU
i5-9600KF
Graphics
RX 580
Mobile Phone
  1. iOS
My way :twisted: :

  1. agdpmod=pikera
  2. InjectATI=YES
  3. Framebuffer=Boa
  4. Remove WEG!


Geekbench 4 performance went up from 90000 to 122000 using RX 5500 XT 4GB.

Someone should test with the RX 5700 XT and see the performance improvement.
 
Joined
Apr 26, 2014
Messages
143
Motherboard
Asus Z270-WS
CPU
i7-6700K
Graphics
RX 5700 XT
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. Other
My way :twisted: :

  1. agdpmod=pikera
  2. InjectATI=YES
  3. Framebuffer=Boa
  4. Remove WEG!


Geekbench 4 performance went up from 90000 to 122000 using RX 5500 XT 4GB.

Someone should test with the RX 5700 XT and see the performance improvement.

I thought agdpmod=pikera was dependent on WEG? In anycase will try by your example. Also whats Framebuffer = Boa. Google searched it and got nothing.

Thanks!
 
Last edited:
Joined
Apr 26, 2014
Messages
143
Motherboard
Asus Z270-WS
CPU
i7-6700K
Graphics
RX 5700 XT
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. Other
So is "Framebuffer=Boa" a typo or something. Google searching just gives me bank of america lol.

Must be documented somewhere?

Edit: Didn't work for me. Got instant Black screen.
 
Last edited:

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,288
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
I just upgraded from a GTX 970 to a PowerColor Red Devil RX 5700 XT and AMD GPUs are new to me. Currently I have WEG installed and agdpmod=pikera. I can also boot without both of those so I am not sure they are necessary but I have to have that boot arg in order to boot with WEG.

One issue I am running into is that I have to unplug HDMI whenever I reboot or the display doesn't detect the connection, at bios or anytime there after. Once I unplug and plug it back in it works fine. Any advice on getting that fixed or is that just something I will have to deal with? I don't have this issue when rebooting from Windows.
 
Joined
May 11, 2011
Messages
1,154
Motherboard
Asrock B365M Phantom Gaming
CPU
i5-9600KF
Graphics
RX 580
Mobile Phone
  1. iOS
So is "Framebuffer=Boa" a typo or something. Google searching just gives me bank of america lol.

Must be documented somewhere?

Edit: Didn't work for me. Got instant Black screen.


For the people who want more performance.

I posted a list with framebuffers for Navi GPUS to inject if you want to try.

That's my Geekbench score for my Sapphire RX 5500 XT 4GB after injecting the Framebuffer Boa, its for navi 14.

IOREG shows the navi 14 controller is injected.

I am using display port and everything works, sleep, wake.

Edit.: Tried python and gave me a Geekbench score of 130000 but only the HDMI output works.

Screenshot 2020-04-10 at 19.54.34.png

Screenshot 2020-04-10 at 19.44.18.png

Screenshot 2020-04-10 at 19.43.07.png
 
Last edited:
Joined
Nov 3, 2017
Messages
335
Motherboard
Gigabyte Z490 Designare
CPU
i9-10850K
Graphics
Radeon VII
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
macOS Catalina Beta 15.1 version 2 now includes the new AMDRadeon6000kext and supporting kexts to allow support for the new Navi cards.
Whatevergreenkext either needs to be disabled or removed or you can use this boot argument. agpdmod=pikera

List of 5700 Series Cards tested and working:
Sapphire 5700XT reference
Sapphire Pulse 5700XT
Sapphire Nitro + 5700XT
Sapphire Pulse 5700
Gigabyte reference 5700
**Gigabyte Gaming 5700XT
MSI Evoke 5700XT
Asus ROG Strix 5700XT
Asus 5700XT reference
Asus TUF gaming
XFX 5700XT reference
Powercolor Red Dragon 5700XT
Visiontek 5700


No Sapphire Radeon VII ?
 
Joined
Oct 29, 2015
Messages
69
Motherboard
MSI Z270 Gaming Pro Carbon
CPU
i7-7700K
Graphics
HD 630 + RX 5600 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
For the people who want more performance.

I posted a list with framebuffers for Navi GPUS to inject if you want to try.

That's my Geekbench score for my Sapphire RX 5500 XT 4GB after injecting the Framebuffer Boa, its for navi 14.

IOREG shows the navi 14 controller is injected.

I am using display port and everything works, sleep, wake.

Edit.: Tried python and gave me a Geekbench score of 130000 but only the HDMI output works.
I did test with Adder because i own a 5600 XT, instant blackscreen, if i remove ati injection it boots but it uses the standard RadeonFramebuffer.
 
Joined
May 11, 2011
Messages
1,154
Motherboard
Asrock B365M Phantom Gaming
CPU
i5-9600KF
Graphics
RX 580
Mobile Phone
  1. iOS
I did test with Adder because i own a 5600 XT, instant blackscreen, if i remove ati injection it boots but it uses the standard RadeonFramebuffer.
Try the second one Ikaheka. Are you using hdmi?
 
Top