Contribute
Register

List of AMD Radeon Navi cards in Catalina That work.

Joined
Nov 23, 2010
Messages
525
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
I managed to get it working with Idrakus modified config, his EFI. On imac 19.1

Then I added some kexts to monitor system and driver for bluetooth
so, I think there are 2 options:
it's my motherboard fault, or my bios version or, maybe, the fact that I have a more recent version of clover. I will test today
 
Joined
Nov 23, 2010
Messages
525
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
so, I think there are 2 options:
it's my motherboard fault, or my bios version or, maybe, the fact that I have a more recent version of clover. I will test today

solution found!
do you want to know where the problem was?
bios? motherboard? gpu brand?clover version? kext?

none of these.
the issue was on the smbios...latest firmware version of both imac19,1 or imacpro1,1 doesn't work.
using posted version or prior version does work. the newer one doesn't work for me.
 

Attachments

Joined
Dec 28, 2019
Messages
2
Hey guys, can the latest Catalina be installed on a fresh built system with a Navi card inside? I have read conflicting infos here and elsewhere, so now I'm not sure. Lots of people seem to recommend installation with a RX 580 or similar and then switching to e.g. 5700 XT. But is that really necessary, now Navi is supported natively?


Thanks!
 
Joined
Feb 7, 2019
Messages
13
Motherboard
Asus Z390-E
CPU
i9-9900K
Graphics
RX 5700 XT
Mobile Phone
iOS
Asus Strix RX 5700 XT Working
 
Joined
Aug 29, 2012
Messages
24
Motherboard
Aorus Gaming 7 Z370
CPU
i7 8700K
Graphics
Powercolor Radeon 5700XT
Mac
MacBook Air
Mobile Phone
Android
How do you get it to work? I have the same card however I got kernel panic during boot. It is working fine with window 10.

Tried adgpmod=pikera
Updated Weg, lilu still cannot get it to work?
I got it working without any problems with iMacPro config (configured after OS install) and upgraded directly from High Sierra to Catalina. There must be something else in your configuration.
 
Joined
Oct 23, 2010
Messages
838
Motherboard
GA-Z77X-UP5-TH
CPU
i7-3770K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
Android, iOS,
macOS Catalina Beta 15.1 version 2 now includes the new AMDRadeon6000kext and supporting kexts to allow support for the new Navi cards.
Appreciate the list of Navi cards "supported".

It would be helpful to the readers and members here to mention a "caveat".
That caveat being that the "AMDRadeon6000kext and supporting kexts to allow support for the new Navi cards" for GUI acceleration of the macOS User interface and not necessarily the acceleration of H.264/HEVC video encoding/decoding in specific macOS Apps (e.g. Quicktime, FCPX, etc). Unless, you can list the Apps that will work with these "supported" Navi cards.

That is, "support" does not necessarily mean support for encode/decode of those codecs via the Navi cards.

In other words, you would not want to inadvertantly mislead any users into assuming that if they bought a new navi card (because it is listed here), then it will "just" work with their video editing apps. It may or it may not.

I suggest a caution should be added to you original post.
 
Joined
May 15, 2016
Messages
5,110
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
Appreciate the list of Navi cards "supported".

It would be helpful to the readers and members here to mention a "caveat".
That caveat being that the "AMDRadeon6000kext and supporting kexts to allow support for the new Navi cards" for GUI acceleration of the macOS User interface and not necessarily the acceleration of H.264/HEVC video encoding/decoding in specific macOS Apps (e.g. Quicktime, FCPX, etc). Unless, you can list the Apps that will work with these "supported" Navi cards.

That is, "support" does not necessarily mean support for encode/decode of those codecs via the Navi cards.

In other words, you would not want to inadvertantly mislead any users into assuming that if they bought a new navi card (because it is listed here), then it will "just" work with their video editing apps. It may or it may not.

I suggest a caution should be added to you original post.
Good idea, I’ll put a disclaimer in there. It would be a good idea to star another h264, HVEC thread for Navi cards like the Polaris thread.

What really sucks is Apple changing up support and card functions on a whim with updates or new software releases.
 
Joined
Oct 23, 2010
Messages
838
Motherboard
GA-Z77X-UP5-TH
CPU
i7-3770K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
Android, iOS,
Good idea, I’ll put a disclaimer in there. It would be a good idea to star another h264, HVEC thread for Navi cards like the Polaris thread.
Thanks.

What really sucks is Apple changing up support and card functions on a whim with updates or new software releases.
I agree. They did that for Polaris when Catalina and FCPX 10.4.7 came out. They don't don't really care as most of the "professional" community have fairly hi-end CPU's in their Mac's and will probably not notice that their CPU/iGPU is getting thrashed instead of the GPU.
 
Joined
Jul 1, 2011
Messages
147
Motherboard
GA-Z77X-UD5H
CPU
i7-3770
Graphics
GTX 980 Ti
Mac
Mac mini
Classic Mac
PowerBook
So same of them support H.264/HEVC and same not? I would not call it supported.

So is there any of them which support H.264/HEVC for the moment?
 
Joined
Feb 7, 2019
Messages
13
Motherboard
Asus Z390-E
CPU
i9-9900K
Graphics
RX 5700 XT
Mobile Phone
iOS
My Asus Strix RX 5700 XT Ram is mostly on load for 90% all the time does anybody have the same problem or is it a problem if yes how to fix it? I monitor it with istat menu and tried other apps the ram is used for 90% most of the time.
 
Top