Contribute
Register

Intel UHD 630 Graphics (0x3e918086 i3-8100) Native support with GfxId Injection

Status
Not open for further replies.
Joined
Jul 24, 2018
Messages
27
Motherboard
Gigabyte B360 AORUS GAMING 3 WIFI (rev. 1.0)
CPU
i5-8400k
Graphics
UHD 630, GTX-1050 Ti
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
ok i m trying...
ok when using usb to boot in verbose mode..
struck at : failed to load executable for kext com.apple.driver.Appleintelkblgraphics
kext com.apple.driver.Appleintelkblgraphics failed to load (0xdc008016)
kext stall[0], (60s) : "IGPU"
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,687
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Did you use my kext and drivers? config.plist?

Paste this in google
GET I3-8100/I3-8350K UHD 630 IGPU WORKING IN HIGH SIERRA
First page on search, read that guide, METHOD3 (BEST), for "some reason" I cannot hyperlink that website here.
After you follow the steps in how to edit those two kexts, please follow step by step, from 1 to 25, add AppleIntelKBLGraphics.kext and AppleIntelKBLGraphicsFramebuffer.kext toto CLOVER/KEXT/OTHER after you edit them, do not delete them from S/L/E. To answer your question, I have not added any KEXTS to S/L, I know is recommended, but I just keep them in OTHER.
With the above said, and using the kext and drivers I have, you should be good to go, use my config.plist, the patches in there are what make graphics work entirely.
Here are the patches, but again, I already have them in my .plist
In clover configurator, under Kernel and Kext Patches; add
1.
Name

com.apple.driver.usb.AppleUSBXHCI
Find HEX
01050900 00040000 87010000
Replace
02021200 00800000 87010000
Comment
KBL-5912000-Port_0x6_HDMI
2.
Name

AppleIntelKBLGraphicsFramebuffer
Find HEX
02040A00 00040000 87010000
Replace
03041200 00040000 87010000
Comment
KBL-5912000-Port_0x7_DP
3.
Name

AppleIntelKBLGraphicsFramebuffer
Find HEX
03060A00 00040000 87010000
Replace
01011200 00080000 87010000
Comment
KBL-5912000-Port_0x5_HDMI
That is how I got graphics after many days of searching, if you follow what I just told you here, it should get you up, otherwise, I don't know. Good luck :thumbup:

Are you sure the first patch is correct? The comment says you are patching graphics, bu the name is for USB.
 
Joined
Jul 2, 2013
Messages
202
Motherboard
HP EliteBook 8460P-CLover
CPU
i7-2670QM
Graphics
HD 3000 1366 x 768
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Are you sure the first patch is correct? The comment says you are patching graphics, bu the name is for USB.
Without that first patch I couldn’t get graphics, on my h370n(current) and h370m (returned) I didn’t use it on my b360n( returned). I’m not expert at all, but it wasn’t till I added it that igpu worked :confused:
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,687
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Without that first patch I couldn’t get graphics, on my h370n(current) and h370m (returned) I didn’t use it on my b360n( returned). I’m not expert at all, but it wasn’t till I added it that igpu worked :confused:

I mean, are you sure it should be com.apple.driver.usb.AppleUSBXHCI and not AppleIntelKBLGraphicsFramebuffer?
 
Joined
Jul 2, 2013
Messages
202
Motherboard
HP EliteBook 8460P-CLover
CPU
i7-2670QM
Graphics
HD 3000 1366 x 768
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I mean, are you sure it should be com.apple.driver.usb.AppleUSBXHCI and not AppleIntelKBLGraphicsFramebuffer?
Oh, I got you now, looking at it you are right, I wrote that wrong, the name is wrong, i typed it wrong into my plist, and now I cannot remember where I got that patch from while I was researching to get igpu working, I will update my post and clarify that.
I’m certain is for AppleIntelKBLGraphics.kexts....
 
Last edited:
Joined
Jul 24, 2018
Messages
27
Motherboard
Gigabyte B360 AORUS GAMING 3 WIFI (rev. 1.0)
CPU
i5-8400k
Graphics
UHD 630, GTX-1050 Ti
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Oh, I got you now, looking at it you are right, I wrote that wrong, the name is wrong, i typed it wrong into my plist, and now I cannot remember where I got that patch from while I was researching to get igpu working, I will update my post and clarify that.
I’m certain is for AppleIntelKBLGraphics.kexts....
so could you re write as i m still unable to boot ..planning for fresh install
 
Joined
Jul 2, 2013
Messages
202
Motherboard
HP EliteBook 8460P-CLover
CPU
i7-2670QM
Graphics
HD 3000 1366 x 768
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
so could you re write as i m still unable to boot ..planning for fresh install
I’m at work right now, and even though the “Name” “Comment” of the patch is wrong, the patch itself is right, in other words, it works cause I have it like that in my machine. Name and Comment are used to identify the patch it won’t affect the patch other than the person wouldn’t know what is for, I will edit that comment once I get my hands on my config.plist.
 
Joined
Jul 24, 2018
Messages
27
Motherboard
Gigabyte B360 AORUS GAMING 3 WIFI (rev. 1.0)
CPU
i5-8400k
Graphics
UHD 630, GTX-1050 Ti
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I’m at work right now, and even though the “Name” “Comment” of the patch is wrong, the patch itself is right, in other words, it works cause I have it like that in my machine. Name and Comment are used to identify the patch it won’t affect the patch other than the person wouldn’t know what is for, I will edit that comment once I get my hands on my config.plist.


I just did fresh install as I was unable to boot in due to black screen....now guide me to get graphics running
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,687
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I’m at work right now, and even though the “Name” “Comment” of the patch is wrong, the patch itself is right, in other words, it works cause I have it like that in my machine. Name and Comment are used to identify the patch it won’t affect the patch other than the person wouldn’t know what is for, I will edit that comment once I get my hands on my config.plist.

Name is the name of the kext that is being patched.
 
Joined
Jul 24, 2018
Messages
27
Motherboard
Gigabyte B360 AORUS GAMING 3 WIFI (rev. 1.0)
CPU
i5-8400k
Graphics
UHD 630, GTX-1050 Ti
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Alright, I had the same issue as you, post your efi folder for me to take a look at it, is late here and I have to get up in a few hours for work, I’ll check it tomorrow. Be patient, that is a virtue, you will be able to fix it, don’t give up:thumbup:
here is my efi..I used your clover folder to config ..but its seems not working
 

Attachments

  • EFI.zip
    20.8 MB · Views: 71
Status
Not open for further replies.
Top