iCloud - The Official Thread

Not open for further replies.
i'm not using RAID ,i tried all solutions in this topic except installing chameleon (i like chimera) the problem is still there "this is valid apple id but isn't iCloud account".
any suggestion ?!
(i'm using WiFi and USB Modem in college hotel)
Hi All -

I just wanted to let you guys know that Chameleon's new trunk fixes both Facetime and iCloud while being compatible with RAID 0.
Check out the trunk here:

Hopefully, it'll be merged into the Chimera branch soon!

Cheers /gx
Tonys tips did not work for me, even though I tried each (not necessarily in the same order).

What worked for me is adding:

to Extras org.chamelon.Boot.plist (which I think earlier had a different name).

That is the same tip that got the App Store to work a month ago.
Unfortunately this tip DISABLES my second monitor. That is quite annoying because I need it to cut video and don't like to switch back and forth.

Removing it now does not bring back my second monitor (as it did before starting iCloud.)
So I need some advice on the iCloud front. I've tried:

1) Resetting network (as in first post of this thread)
2) Changing to multiple real serials in smbios (as in first post of this thread and multiple other threads)
3) Adding PCIRootUID=1 to org.chameleon.boot.plist

I am using the Chimera 1.5.4 via Multibeast as a bootloader. I can log-in to the App Store, however. My error message is "This Apple ID is valid but is not an iCloud account." I have successfully set up iCould with my Apple ID from my iPad and Macbook tho.

Any other recs or things that have worked for people?

D-an-W said:
[quote="Logicpro8_user":2xf453s2]10.7.2 up ok iCloud working fine and as it should apart from Find My Mac.... I have the new apple Recovery HD to make it work but evey time I restart Find My Mac is un ticked in the iCloud prefs... Anyone any ideas?

Hi LP8, I have now created the hidden partition as have the same issue as you, could it be something with it asking for permission every time?

I'll research it later, going to watch a movie right now :geek:

Maybe it is supposed to be off on reboot :think:

As it could potentially give away your location to anyone who has your Apple ID credentials, and would also enable Apple to track your movements, Find My Mac is disabled by default. Activate it through 'system preferences' and then 'iCloud'. Click the check box beside 'Find My Mac' and confirm that you want to authorise it to lock or wipe your Mac remotely.

I am quoting myself here ( :crazy: ) but has anyone else come across the above problem and resolved it yet?

From what I have found so far it seems to be a hack issue so might be fixable with Chameleon / Chimera (For example)?
I don't understand: did you do this passage?
Download Chameleon Wizard from kext dot com, then run it and in its smbios section generate a new random serial for your machine, then reboot.
iCloud, AppStore and Facetime should work. :thumbup:

Can you give me directions on how to use Chameleon Wizard? Never used it before, not sure how to use it. Trying to get App Store & iCloud working.

No luck for me,

Tried all 3 steps from Tony's Guide.

Running Chimera 1.6.0

Reset Network Preferences (couldn't find the networkinterfaces.plist though, I moved and from /library/preferences to the desktop)

brought up built-in ethernet first (though it doesn't show it as en(0) as some suggest).

Changed Serial # to

and of course restarted. Still getting this Apple ID is valid but not an iCloud Account.

anymore ideas? quite the bummer :(

Got it to work. First off, for those who are stupid like me, there are 2 library files.

If you go to the library you can unhide in finder that is the {username}/library and this is the wrong place.

If you enter finder and press shift-command-g then type /library this will bring up the correct place to find the network files you will need to delete. (to find the other library this way you type ~/library).

Anyway, once reboot, I brought up ethernet first then wifi.

Logged into app store first, then logged into iCloud. All worked finally.

BTW, iCloud really isn't very good, in fact I think it sucks. Transitioning from the MobileMe service which I loved. They had great a photo gallery and iDisk was awesome. You could access files from iPhone,laptop, share w/ pc, whatever. The file storage on iCloud being limited to iWork files, quite lame.

my .02
So I got mine working after reading this post so THANK YOU!!! you guys RoCk...

Anyway, two things I did:
1) changed the /Extra/smbios.plist serial number to something like the orignal post suggested

2) I used the plist editor NOT textedit to modify the ethernetbuild key. On mine, eventhough the TXT file had a yes, it showed a 0.... Once I used the plist editor and changed to YES, everythign worked fine!!! Besides textedit complained about the permisions were plist editor didnt!! :)

Again, thank you so much for the help!!!
Not open for further replies.