Contribute
Register

How to build your own iMac Pro [Successful Build/Extended Guide]

Status
Not open for further replies.
Joined
Feb 15, 2011
Messages
121
Motherboard
Asus X299 Sage 10G
CPU
i9-7980XE
Graphics
WX7100
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
As we don't know about content and constitution of your EFI-Folder, I can just guess that there is something wrong with your CPU BIOS settings for now. Try to lower max. CPU core ratio (e.g. to 32 for all cores) depending on the sophistication of your CPU waterblocking but use core ratio = sync all cores and AVX/AVX-512 offsets in any case.

Else please read beginning of Section C.) and provide adequate information that others can help you in your issue. Due to repetitive unpleasant feedback along my threads and due to an already excessive workload in providing my user specific support, I stopped with the latter for now, which hopefully also will find your comprehension.

For the Deluxe II and with the help of @Maywitt, @AsEvil and @applemacosxGOD, we came up with a complete set of SSDTs for the Deluxe II, which you will find in respective posts along my X299 threads, while the starting EFI-Folder remains being my default X299 EFI-Folder distribution.

You might be also interested in some of my general conclusions about the Deluxe II up to now. Just see post #2,246 in this case.

Good luck, man!

KGP

My bad, I will be posting a EFI folder here shortly. I have been trying to follow the Deluxe II posts. Any idea which page has all the SSDTs? I have found the ones relating to usb, and TB, but not a resource of all SSDTs. Thanks so much!
 

kgp

Retired
Joined
May 30, 2014
Messages
6,778
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
My bad, I will be posting a EFI folder here shortly. I have been trying to follow the Deluxe II posts. Any idea which page has all the SSDTs? I have found the ones relating to usb, and TB, but not a resource of all SSDTs. Thanks so much!

You will need to adopt the SSDTs depending on your hardware and slot configuration.. ;)

The EFI-Folder and all implemented Kext and Kernel patches are for 10.14.3 and need to be changed in case of 10.13.6!

Be aware about current 5GB onboard NIC and onboard TTR restrictions outlined in post #2,246 .

Good luck,

KGP
 

Attachments

  • KGP-Deluxe-II-BCM943602CS-M.2-10.14.3-EFI.zip
    24.2 MB · Views: 64
Joined
Feb 15, 2011
Messages
121
Motherboard
Asus X299 Sage 10G
CPU
i9-7980XE
Graphics
WX7100
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
My bad, I will be posting a EFI folder here shortly. I have been trying to follow the Deluxe II posts. Any idea which page has all the SSDTs? I have found the ones relating to usb, and TB, but not a resource of all SSDTs. Thanks so much!

Here is my EFI folder. So far the only thing I have noticed is it won't shutdown properly. Testing Nvidia drivers next. Did a full search for SSDT`s for the Deluxe II and still cant find the resource, please send a link if you can, as always...you rock!
 
Joined
Feb 15, 2011
Messages
121
Motherboard
Asus X299 Sage 10G
CPU
i9-7980XE
Graphics
WX7100
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
You will need to adopt the SSDTs depending on your hardware and slot configuration.. ;)

The EFI-Folder and all implemented Kext and Kernel patches are for 10.14.3 and need to be changed in case of 10.13.6!

Be aware about current 5GB onboard NIC and onboard TTR restrictions outlined in post #2,246 .

Good luck,

KGP
Awesome! Thank you so much, I am going to test this one. This should work just fine for High Sierra if I just use the usb patches from your original post? I can't run Mojave as I need to have cuda power with Octane Render. Thanks!
 
Joined
Feb 15, 2011
Messages
121
Motherboard
Asus X299 Sage 10G
CPU
i9-7980XE
Graphics
WX7100
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Awesome! Thank you so much, I am going to test this one. This should work just fine for High Sierra if I just use the usb patches from your original post? I can't run Mojave as I need to have cuda power with Octane Render. Thanks!

WOW, I wish I would have found your post on the Deluxe II! I should have NOT bought this board! I still can't see if anyone has gotten hot-swap working. Is the onboard TB working properly? I am going to do my tests too.
 

kgp

Retired
Joined
May 30, 2014
Messages
6,778
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Awesome! Thank you so much, I am going to test this one. This should work just fine for High Sierra if I just use the usb patches from your original post? I can't run Mojave as I need to have cuda power with Octane Render. Thanks!

Disable USB port limit patches and use 15-port USB kext instead of fully inplemented XHC USB kext.
 

kgp

Retired
Joined
May 30, 2014
Messages
6,778
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
WOW, I wish I would have found your post on the Deluxe II! I should have NOT bought this board! I still can't see if anyone has gotten hot-swap working. Is the onboard TB working properly? I am going to do my tests too.

TB works, but apparently no hotplug under macOS. TTR USB-C is only implemented with respective devices connected at boot.

However note that I do not own a Deluxe II myself. All results and conclusions have been derived based on the input and feedback provided by the three guys mentioned above.

I don‘t know if your other post in the X299 10.14 thread is still necessary, as you are anyway on 10.13.6, which could just create unnecessary discussion and confusion in any case.
 
Last edited:
Joined
Feb 15, 2011
Messages
121
Motherboard
Asus X299 Sage 10G
CPU
i9-7980XE
Graphics
WX7100
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
TB works, but apparently no hotplug under macOS. TTR USB-C is only implemented with respective devices connected at boot.

I don‘t know if your other post in the X299 10.14 thread is still necessary, as you are anyway on 10.13.6, which could create unnecessary discussion and confusion in any case.
Ok, thank you for the clarification! I will be continuing to test today and be reporting back. I still can't get a proper shutdown, any suggestions on that? I did use your EFI folder.
 

kgp

Retired
Joined
May 30, 2014
Messages
6,778
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Ok, thank you for the clarification! I will be continuing to test today and be reporting back. I still can't get a proper shutdown, any suggestions on that? I did use your EFI folder.

Proper shutdown? I told you that you need to adopt the SSDTs for your additional PCIe hardware and slot configuration! E.g., the EFI-Folder contains a SSDT-X299-RX580.aml, which is definitely not suited in your case! You should also remove the fully implemented USB kext, unzip the 15-port USB kext and disable the port limit patches in the config.plist, etc., etc. etc. ... Study this small guideline for a proper SSDT adaptation and else take profit of available SSDT approaches provided in the X299 SSDT Github library.

Take your time before unnecessarily posting issues. I guess, I already helped you a lot for now. You should get the rest of things done by yourself. If really necessary, others might be also able to help you with remaining issues, if there are any at all. Just ask @AsEvil, @applemacosxGOD or @Maywitt for help if really necessary. But please here in this thread as you are on 10.13.6 and please not in the 10.14 thread!

BTW.. you know that CUDA drivers can mess up your system? And concerning your multi-multi-multi Nvidia GPU approach I am sceptic and pessimistic anyway. I abandoned Nvidia long time ago and with 10.14, Nvidia is history now anyway on state-of-the-art Hackintosh systems where Metal also substitutes CUDA.

Good luck, my friend!

KGP
 
Last edited:
Joined
Feb 15, 2011
Messages
121
Motherboard
Asus X299 Sage 10G
CPU
i9-7980XE
Graphics
WX7100
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Proper shutdown? I told you that you need to adopt the SSDTs for your additional PCIe hardware and slot configuration! E.g., the EFI-Folder contains a SSDT-X299-RX580.aml, which is definitely not suited in your case! You should also remove the fully implemented USB kext, unzip the 15-port USB kext and disable the port limit patches in the config.plist, etc., etc. etc. ...

Take your time before unnecessarily posting issues. I guess, I already helped you a lot for now. You should get the rest of things done by yourself. If really necessary, others might be also able to help your with remaining issues, if there are any at all.

Good luck,

KGP
I guess I should have mentioned I did do that. I swapped the RX580.aml for the Nvidia.aml and I have nothing in the PCI-e slots as of now, just the 1080ti in slot one. I also used the 15 port usb kext. I also disabled the mojave usb kexts. Here is the efi folder attached. I followed all your steps so far. I really do appreciate your help, and taking your time with all of us non Jedi`s!
 
Status
Not open for further replies.
Top